<!DOCTYPE html>
<!-- Get M Theater WordPress Theme at BY HAND Media (http://www.byhandmedia.net/mtheater) -->
<!--[if IE 7 | IE 8]>
<html class="ie" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition |  Film Fetish | Crush Collectibles </title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.filmfetish.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://www.filmfetish.com/wp-content/themes/m-theater/js/html5.js" type="text/javascript"></script>
<![endif]-->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//i.hit.pictures' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Film Fetish | Crush Collectibles &raquo; Feed" href="https://www.filmfetish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Film Fetish | Crush Collectibles &raquo; Comments Feed" href="https://www.filmfetish.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Film Fetish | Crush Collectibles &raquo; The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition Comments Feed" href="https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.filmfetish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.6"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://www.filmfetish.com/wp-content/plugins/instagram-feed-pro/css/sb-instagram.css?ver=2.9.7' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-style-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/style.css?ver=4.9.6' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelementcss-css'  href='https://www.filmfetish.com/wp-includes//js/mediaelement/mediaelementplayer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='naranja-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/theme-color-naranja.css' type='text/css' media='all' />
<link rel='stylesheet' id='liquidslcss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/liquid-slider.css?ver=2.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='bhadsharecss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/style-shared.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='bhadcss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccaltltpcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzstooltip/dzstooltip.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccuscalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-cal-cus.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccartcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-shopcart.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='myccmaincss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-mycc.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js?ver=2.1.4'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=4.9.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='https://www.filmfetish.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.filmfetish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.filmfetish.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Ghost in the Shell Deluxe Slipcover Edition Manga: Complete Boxed Set + Premium Lithograph Art by creator Shirow Masamune' href='https://www.filmfetish.com/ffmkt/ghost-in-the-shell-deluxe-slipcover-edition-manga-complete-boxed-set-premium-lithograph-art-by-creator-shirow-masamune/' />
<link rel='next' title='The Return of Swamp Thing 2-Disc Special Collector&#8217;s Edition &#8211; MVD Rewind Collection' href='https://www.filmfetish.com/ffmkt/the-return-of-swamp-thing-2-disc-special-collectors-edition-mvd-rewind-collection/' />
<meta name="generator" content="WordPress 4.9.6" />
<link rel="canonical" href="https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/" />
<link rel='shortlink' href='https://www.filmfetish.com/?p=73585' />
<link rel="alternate" type="application/json+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;format=xml" />
<link rel="image_src" href="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-back.jpg" />
<meta name="web_author" content="Web Site Development: HitPictures.tech" />
<meta name="wp_theme_name" content="M Theater" />
<link rel="wp_theme_address" href="http://hitpictures.tech/mtheater/" />
<meta name="copyright" content="Film Fetish | Crush Collectibles" />
<meta name="googlebot" content="noodp" />
<meta name="robots" content="noodp" />
<meta name="no-email-collection" content="No spam harvesting allowed" />
<meta name="dc.source" content="https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/" />
<meta name="dc.publisher" content="Film Fetish | Crush Collectibles" />
<meta name="dc.date" content="2018-06-04T22:38:12-04:00" />
<meta name="dc.title" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" />
<meta name="dc.creator" content="René Carson" />
<meta name="description" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition-BSX Music has released a new recording for the 1982 horror classic, THE THING MUSIC FROM THE MOTION PICTURE, featuring" />
<meta name="keywords" content="action,alan howarth,bsx music,charles hallahan,cult cinema,cult cinema icons,david clennon,donald moffat,ennio morricone,featured,featured - email,horror,joel polis,john carpenter,keith david,kurt russell,larry hopkins,larry j. franco,music &amp; spoken word,mvd,nate irwin,norbert weisser,peter maloney,richard dysart,richard masur,science fiction,suspense,t.k. carter,the thing,thomas g. waites,thrillers,throwback space,vinyl,wilford brimley," />
<meta name="author" content="René Carson" />
<meta name="abstract" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" />
<meta property="og:title" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" />
<meta itemprop="name" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" />
<meta name="twitter:title" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" />
<meta property="og:type" content="article" />
<meta property="article:published_time" content="2018-06-04T22:38:12-04:00" />
<meta property="article:modified_time" content="2018-06-04T22:55:19-04:00" />
<meta property="og:description" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition-BSX Music has released a new recording for the 1982 horror classic, THE THING MUSIC FROM THE MOTION PICTURE, featuring" />
<meta name="twitter:description" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition-BSX Music has released a new recording for the 1982 horror classic, THE THING MUSIC FROM THE MOTION PICTURE, featuring" />
<meta itemprop="description" content="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition-BSX Music has released a new recording for the 1982 horror classic, THE THING MUSIC FROM THE MOTION PICTURE, featuring" />
<meta itemprop="image" content="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-back.jpg" />
<meta name="twitter:card" content="summary" />
<meta property="og:url" content="https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/" />
<meta property="og:image" content="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-back.jpg" />
<meta property="og:site_name" content="Film Fetish | Crush Collectibles" />
	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px);
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<!-- M Theater Custom CSS -->
<style type="text/css" media="screen" id="mtheater-custom-styles">
@import url("//cdn-images.mailchimp.com/embedcode/classic-10_7.css");

@import url("//www.filmfetish.com/wp-content/fetish-styles.css");

@import url("//i.hit.pictures/css/network-shops.css");
</style><!-- End Custom CSS -->

<style type="text/css" media="screen" id="mtheater-custom-plugin-styles">
/* Custom M Theater CSS */
.archive-txt { display: none; }
/* Mailchimp */
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
/* Plugin */
p.bhmspamkill, textarea#bhm_nonviewable { display:none;position:absolute;left:-9000px; }
/* ie */
.ie #bhmmainpg .bhmmainlogobx .bhmmaintxt { width: 46%; float: left; }
.ie #bhmmainpg .bhmmainlogobx { width: 43%; padding: 2%; float: left; min-height: 320px; min-height: 22.857142857rem; }
.ie #bhmmainpg .bhmmainlogobx.right { float: right; }
</style></head>

<body id="top" class="ffmktcrt-template-default single single-ffmktcrt postid-73585 httpswwwfilmfetishcom custom-background-empty custom-font-enabled nav-nobanner style-fnt-hdr-sz-a style-fnt-hdr-styl-a style-fnt-ttl-styl-a style-fnt-bod-styl-a">

<div id="page" class="hfeed site">
	<header id="masthead" class="site-header" role="banner">
		<hgroup class="title-background">
			<h1 class="site-title"><a href="https://www.filmfetish.com/" title="Film Fetish | Crush Collectibles" rel="home">Film Fetish | Crush Collectibles</a></h1>
			<h2 class="site-description">Cool Movies, TV, Music and Sports</h2>
		</hgroup>


<nav id="site-navigation" class="main-navigation" role="navigation">
	<button class="menu-toggle">Menu</button>
	<div class="skip-link assistive-text"><a href="#content" title="Skip to content">Skip to content</a></div>
	<div class="menu-flea-market-container"><ul id="menu-flea-market" class="nav-menu"><li id="menu-item-49430" class="nav-depts menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49430"><a title="Departments" href="https://www.filmfetish.com/market/archive/">Depts</a>
<ul class="sub-menu">
	<li id="menu-item-49470" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49470"><a title="Apparel" href="https://www.filmfetish.com/market/archive/?mcrterm=24386&#038;mcrtrmkey=category">Apparel</a></li>
	<li id="menu-item-49471" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49471"><a title="Books" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></li>
	<li id="menu-item-49489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49489"><a title="Featured" href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured</a></li>
	<li id="menu-item-62384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62384"><a title="Home Goods" href="https://www.filmfetish.com/market/archive/?mcrterm=24612&#038;mcrtrmkey=category">Home Goods</a></li>
	<li id="menu-item-49472" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49472"><a title="Lobby Cards" href="https://www.filmfetish.com/market/archive/?mcrterm=24383&#038;mcrtrmkey=category">Lobby Cards</a></li>
	<li id="menu-item-49473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49473"><a title="Movies &#038; TV" href="https://www.filmfetish.com/market/archive/?mcrterm=24129&#038;mcrtrmkey=category">Movies &#038; TV</a></li>
	<li id="menu-item-49474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49474"><a title="Mugs &#038; Cups" href="https://www.filmfetish.com/market/archive/?mcrterm=24277&#038;mcrtrmkey=category">Mugs &#038; Cups</a></li>
	<li id="menu-item-49475" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49475"><a title="Music" href="https://www.filmfetish.com/market/archive/?mcrterm=24252&#038;mcrtrmkey=category">Music</a></li>
	<li id="menu-item-49476" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49476"><a title="Photo Prints" href="https://www.filmfetish.com/market/archive/?mcrterm=24274&#038;mcrtrmkey=category">Photo Prints</a></li>
	<li id="menu-item-49477" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49477"><a title="Poster Crush" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
	<li id="menu-item-49478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49478"><a title="Toys" href="https://www.filmfetish.com/market/archive/?mcrterm=24128&#038;mcrtrmkey=category">Toys</a></li>
</ul>
</li>
<li class="mbtn"><div class="mycc-viewcart"><form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post"><input type="hidden" name="business" value="rene@hitpictures.com"><input type="hidden" name="cmd" value="_cart"><input type="hidden" name="display" value="1"><input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/"><input type="image" name="submit" src="https://www.filmfetish.com/img/p/2016/11/view-cart.gif" alt="View Cart" title="View Cart"><img alt="" width="1" height="1" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif"><input type="hidden" name="cpp_logo_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_checkout_logo161114.gif"><input type="hidden" name="page_style" value="film_fetish"></form></div></li><li><form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Search Market"><select name="post_type" style="display: none;"><option value="ffmktcrt">ffmktcrt</option></select></form></li><li class="nav-logo"><a href="https://www.filmfetish.com/market/" title="CRUSHCOLLECTIBLES.COM"><img class="logo-img arc" src="https://www.filmfetish.com/img/p/2018/01/main-crush-logo.gif" alt="CRUSHCOLLECTIBLES.COM" /></a><img src="https://www.filmfetish.com/img/p/2018/01/main-reel-brand.gif" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="FILMFETISH.COM"><img class="logo-img live" src="https://www.filmfetish.com/img/p/2018/01/main-filmfetish-logo.gif" alt="FILMFETISH.COM" /></a></li></ul></div></nav>
        


<div id="search-social">



<div id="searchmain" class="searchwrap">
<form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Search Market"><select name="post_type" style="display: none;"><option value="ffmktcrt">ffmktcrt</option></select></form><div class="respo"><a href="https://www.filmfetish.com/market/" title="CRUSHCOLLECTIBLES.COM"><img class="logo-img arc" src="https://www.filmfetish.com/img/p/2018/01/main-crush-logo.gif" alt="CRUSHCOLLECTIBLES.COM" /></a><img src="https://www.filmfetish.com/img/p/2018/01/main-reel-brand.gif" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="FILMFETISH.COM"><img class="logo-img live" src="https://www.filmfetish.com/img/p/2018/01/main-filmfetish-logo.gif" alt="FILMFETISH.COM" /></a></div></div>




</div><!-- #search-social -->
	</header><!-- #masthead -->

	<div id="main" class="wrapper">  	<div id="primary" class="site-content">
		<div id="content" role="main">

			
				
	<article id="post-73585" class="solo post-73585 ffmktcrt type-ffmktcrt status-publish hentry category-action category-bsx-music category-cult-cinema category-cult-cinema-icons-lines category-featured category-featured-email category-horror-films category-music-type category-mvd category-sci-fi-films category-suspense-films category-thrillers category-throwback-space category-vinyl cppl-alan-howarth cppl-charles-hallahan cppl-david-clennon cppl-donald-moffat cppl-ennio-morricone cppl-joel-polis cppl-john-carpenter cppl-keith-david cppl-kurt-russell cppl-larry-hopkins cppl-larry-j-franco cppl-nate-irwin cppl-norbert-weisser cppl-peter-maloney cppl-richard-dysart cppl-richard-masur cppl-t-k-carter cppl-thomas-g-waites cppl-wilford-brimley cshow-the-thing fffmclass fffmsingle less-three">
    <div id="social-nav-top"><a class="mycc-inline protected" href="#sotop">Share Page</a>
<div style="display:none;"><div id="sotop"> <div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2018%2F06%2Fthe-thing-vinyl-back.jpg&#038;description=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D73585" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;title=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;title=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;name=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;n=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;t=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20Film Fetish | Crush Collectibles&body=Found%20this%20link%20of%20interest%20at%20Film Fetish | Crush Collectibles:%20https://www.filmfetish.com/?p=73585"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20Film Fetish | Crush Collectibles:%20https://www.filmfetish.com/?p=73585"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	 </div></div>
<div id="socplus-right"><nav class="nav-single-top">
					<h3 class="assistive-text">Previous page navigation</h3>
									</nav><!-- #socplus-right -->
                </div><!-- .nav-single-top -->
		</div><!-- #social-nav-top -->

		<header class="entry-header">
			
                       
            <h1 class="entry-title myc-center ">The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition</h1>
		</header><!-- .entry-header -->

		<div class="entry-content">
		<div class="myc-prod-wrapper"><div class="myc-prod-wrapper-left">
<figure class="cart-image"><a href="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-back.jpg" title="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-back-210x210.jpg" width="210" height="210" class="cart-thumb" alt="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition"><div class="myc-caption">View larger</div></a></figure>

<div class="myc-related gal"><div><a href="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-back.jpg" title="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-back-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition"></a></div><div><a href="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-front.jpg" title="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/06/the-thing-vinyl-front-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition"></a></div></div></div><div class="myc-prod-wrapper-right">
<div class="mycc-addtocart">
<p class="myc-price"><span>$29.99</span></p>
<p class="myc-price">$28.87</p>
<form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post">

	<input type="hidden" name="business" value="rene@thecolorbindery.com">
	<input type="hidden" name="cmd" value="_cart">  
	<input type="hidden" name="item_name" value="The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition">
	<input type="hidden" name="item_number" value="180605-73585">
	<input type="hidden" name="add" value="1">
	<input type="hidden" name="currency_code" value="USD">

  	<input type="hidden" name="page_style" value="film_fetish">

	<input type="hidden" name="image_url" value="https://www.filmfetish.com/img/p/2016/11/paypal_150x50_161122.gif">

	<input type="hidden" name="cpp_header_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_banner161114.jpg">
  
  <input type="hidden" name="paymentaction" value="sale">
  


<div class="myc-output">


<table>
	<tr>
		<td><select name="quantity">
        <option value="1">- Select Qty -</option>
		<option value="1">1</option><option value="2">2</option>		</select> <br/>2 in stock		</td>
	</tr>
</table>

 
</div><!-- .output -->

	<input type="hidden" name="weight" value="1" id="mycweight">
	<input type="hidden" name="weight_unit" value="lbs">


    	<input type="hidden" name="amount" value="28.87">

		














  
    
    
        
  	    <input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/">
    
	    <input type="hidden" name="return" value="https://www.filmfetish.com/transaction-complete/">
        
        <input type="hidden" name="cbt" value="Continue Shopping">
        
    	<input type="hidden" name="cancel_return" value="https://www.filmfetish.com/market/">
    
        <input type="hidden" name="no_shipping" value="2">
    
        <input type="hidden" name="no_note" value="0">
    <input type="hidden" name="cn" value="Add special instructions:">
    
    <br/><br/><input type="image" name="submit" src="https://www.paypalobjects.com/webstatic/en_US/i/btn/png/btn_addtocart_120x26.png" alt="Add to Cart">
  <img alt="" width="1" height="1" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif">

</form>
</div>	

</div></div><div class="spec-wrap"><span class="mycc-details">Vinyl</span>SKU: 180604-73585-1<br/>UPC: 866550000354<br/>Part No: BSXCD8895<br/>Weight: 1.02 lbs<br/>Condition: New</div><p class="spec-wrap">View All: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1081&#038;mcrtrmkey=cppl">John Carpenter</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=13622&#038;mcrtrmkey=cshow">The Thing</a></strong> &nbsp;<strong>items</strong><br/>Product Types: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24292&#038;mcrtrmkey=category">Products</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24252&#038;mcrtrmkey=category">Music &amp; Spoken Word</a></strong><br/>Lines: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24381&#038;mcrtrmkey=category">Cult Cinema Icons</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24627&#038;mcrtrmkey=category">Throwback Space</a></strong><br/>Formats: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24261&#038;mcrtrmkey=category">Vinyl</a></strong><br/>Genres: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24211&#038;mcrtrmkey=category">Action</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1383&#038;mcrtrmkey=category">Cult Cinema</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=15473&#038;mcrtrmkey=category">Horror</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=15475&#038;mcrtrmkey=category">Science Fiction</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1369&#038;mcrtrmkey=category">Suspense</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=322&#038;mcrtrmkey=category">Thrillers</a></strong><br/>Studio: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25515&#038;mcrtrmkey=category">BSX Music</a></strong><br/>Original U.S. Release: June 25, 1982<br/>Item Release Date: January 18, 2018<br/>Rating: R<br/><strong>Visit our main page for additional items <a href="http://www.filmfetish.fm/">Here</a>.</strong></p><h2 class="myc-center low">Details</h2><p>BSX Music has released a new recording for the 1982 horror classic, THE THING MUSIC FROM THE MOTION PICTURE, featuring music composed by Ennio Morricone for the film directed by John Carpenter (HALLOWEEN, ESCAPE FROM NEW YORK), written by Bill Lancaster, starring Kurt Russell, Keith David, Donald Moffat, Wilford Brimley, Richard Masur, Charles Hallahan, Peter Maloney, Richard Dysart, David Clennon, Thomas G. Waites, Joel Polis and T.K. Carter. For this new recording, the music has been produced and arranged by Alan Howarth and Larry Hopkins.</p>
<p>THE THING is a 1982 remake of the 1951 classic THE THING FROM ANOTHER WORLD. Both films were based on the classic story written by John W. Campbell Jr. THE THING tells the story of an American scientific expedition located at a remote research station in the Antarctic who have their routine interrupted by a crazed Norwegian who storms into their camp chasing a snow dog, firing shots at it with his rifle. Unable to reason with the Norwegian, they kill him and save the dog, not knowing that the dog is the host for a destructive alien-form that is able to mutate into other life-forms by infecting them and taking them over at the genetic level. As the scientists begin to unravel the mystery of the new organism they ve discovered and its potential threat, tension builds as they begin to distrust each other. With no way to communicate with the outside world, can they survive long enough for help to arrive or will some&#8230; thing else be waiting in their place?</p>
<p>The music for THE THING was composed by the great Ennio Morricone. Prior to THE THING, director John Carpenter had gained a reputation as a director who also composed the music for his own films and had begun collaborating with sound designer and fellow composer Alan Howarth on the music for his films. With the enormous success of HALLOWEEN and ESCAPE FROM NEW YORK, he found himself working for Universal on his first big studio film. Working with a larger budget at his disposal, Carpenter was able to hire one of his musical idols to score the film. The movie s final soundtrack, though, would be a combination of both Morricone and Carpenter s sensibilities. Characteristically, Morricone did not compose his score to picture. He composed many pieces of music inspired by the film he d watched and by the directions he d received from Carpenter. The music would be edited to fit the film as Carpenter wanted. During the post-production process, Carpenter decided he needed more music for the film and worked with collaborator Alan Howarth to produce some additional electronic music.</p>
<p>The original 1982 soundtrack release for THE THING featured Ennio Morricone s score for the film, including a wealth of music that ultimately did not get used in the film. For this new release of music from THE THING, the music has been produced and arranged by Alan Howarth and Larry Hopkins, to include newly recorded renderings of the Morricone music (including recreations of the tracks not used in the film) and Howarth has also provided new performances of the music he produced for the film with John Carpenter, making their premiere appearance on this album. The music is presented in a sequence closer to film order.</p>
<p>Alan Howarth, in addition to being a composer, is an accomplished sound designer and editor, having worked on films such as STAR TREK: THE MOTION PICTURE, POLTERGEIST, TOTAL RECALL, ARMY OF DARKNESS, BRAM STOKER S DRACULA, STARGATE and many others. He has been a frequent music collaborator with John Carpenter on his films beginning with ESCAPE FROM NEW YORK in 1980 and including HALLOWEEN II &#038; III, CHRISTINE, BIG TROUBLE IN LITTLE CHINA, THEY LIVE and PRINCE OF DARKNESS.</p>
<h2 class="myc-center low">Special Features</h2><ul class="mycc-features"><li><span class="featright">This release features three music cues used in Quentin Tarantino's new motion picture, THE HATEFUL EIGHT, "Despair," "Eternity'" and "Bestiality." These cues do not appear on the HATEFUL EIGHT soundtrack.</span></li></ul><h2 class="myc-center low">Playlists</h2><ul class="mycc-features"><li><span class="featright">Main Title &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Main Theme - Desolation &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Humanity 2 &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Despair &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Humanity &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Shape &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Burn It &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Solitude &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Fuchs &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">To Mac's Shack &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Wait &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Sterilization &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Eternity &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Contamination &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Bestiality &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li><li><span class="featright">Main Theme - End Credit &nbsp;&nbsp;by: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></span></li></ul><h2 class="myc-center low">Specifications</h2><ul class="mycc-features"><li><span class="featleft">Number of Discs: </span><span class="featright">2</span></li></ul><p>Cast: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25949&#038;mcrtrmkey=cppl">Charles Hallahan</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25948&#038;mcrtrmkey=cppl">David Clennon</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=18271&#038;mcrtrmkey=cppl">Donald Moffat</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25951&#038;mcrtrmkey=cppl">Joel Polis</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=2374&#038;mcrtrmkey=cppl">Keith David</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1920&#038;mcrtrmkey=cppl">Kurt Russell</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25952&#038;mcrtrmkey=cppl">Larry J. Franco</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25953&#038;mcrtrmkey=cppl">Nate Irwin</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=19249&#038;mcrtrmkey=cppl">Norbert Weisser</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25950&#038;mcrtrmkey=cppl">Peter Maloney</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=18270&#038;mcrtrmkey=cppl">Richard Dysart</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=7302&#038;mcrtrmkey=cppl">Richard Masur</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25947&#038;mcrtrmkey=cppl">T.K. Carter</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=18426&#038;mcrtrmkey=cppl">Thomas G. Waites</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=11651&#038;mcrtrmkey=cppl">Wilford Brimley</a></strong><br/>Directors: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1081&#038;mcrtrmkey=cppl">John Carpenter</a></strong><br/>Composers: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=1015&#038;mcrtrmkey=cppl">Ennio Morricone</a></strong><br/>Contributors: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25881&#038;mcrtrmkey=cppl">Alan Howarth</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25946&#038;mcrtrmkey=cppl">Larry Hopkins</a></strong></p><h2 class="myc-center low">Related Items</h2><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/the-silver-screen-gang-hollywood-chapter-art-36-x-19-inch-movie-poster/" title="The Silver Screen Gang (Hollywood Chapter) Art 36 X 19 inch Movie Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/01/silver-screen-gang-poster-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Silver Screen Gang (Hollywood Chapter) Art 36 X 19 inch Movie Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/re-animator-special-edition-blu-ray/" title="Re-Animator Special Edition Blu-ray (2018)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/09/re-animator-2-disc-limited-edition-arrow-170x170.jpg" width="170" height="170" class="related-thumb" alt="Re-Animator Special Edition Blu-ray (2018)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/madman/" title="Madman Combo Set" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/01/madman-combo-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Madman Combo Set"></a></div><div><a href="https://www.filmfetish.com/ffmkt/friday-the-13th-parts-2-and-3-music-from-the-motion-pictures-by-harry-manfredini-limited-edition/" title="Friday the 13th Parts 2 and 3: Music from the Motion Pictures by Harry Manfredini &#8211; Limited Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/01/friday-the-13th-pt3-soundtrack-170x170.jpg" width="170" height="170" class="related-thumb" alt="Friday the 13th Parts 2 and 3: Music from the Motion Pictures by Harry Manfredini &#8211; Limited Edition"></a></div><div><a href="https://www.filmfetish.com/ffmkt/asia-extreme-collection-volume-1-south-korean-horror-films-dvd-box-set/" title="Asia Extreme Collection Volume 1: South Korean Horror Films DVD Box Set" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/02/asia-extreme-collection-volume-1-so-korean-horror-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Asia Extreme Collection Volume 1: South Korean Horror Films DVD Box Set"></a></div><div><a href="https://www.filmfetish.com/ffmkt/star-wars-episode-iv-a-new-hope-a-long-time-ago-in-a-galaxy-far-far-away-24-x-36-inch-movie-poster/" title="Star Wars: Episode IV &#8211; A New Hope &#8220;A Long Time Ago in a Galaxy Far Far Away&#8221; 24 x 36 Inch Movie Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/11/star-wars-long-time-ago-movie-poster-170x170.jpg" width="170" height="170" class="related-thumb" alt="Star Wars: Episode IV &#8211; A New Hope &#8220;A Long Time Ago in a Galaxy Far Far Away&#8221; 24 x 36 Inch Movie Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/stephen-kings-it-1990-24-x-36-inch-tv-miniseries-poster/" title="Stephen King&#8217;s IT (1990) 24 x 36 Inch TV Miniseries Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/11/stephen-kings-it-original-miniseries-we-all-float-170x170.jpg" width="170" height="170" class="related-thumb" alt="Stephen King&#8217;s IT (1990) 24 x 36 Inch TV Miniseries Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/forbidden-planet-24-x-36-inch-movie-poster/" title="Forbidden Planet 24 x 36 Inch Movie Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/12/forbidden-planet-movie-poster-170x170.jpg" width="170" height="170" class="related-thumb" alt="Forbidden Planet 24 x 36 Inch Movie Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/avengers-infinity-war-portrait-collage-chart-22-x-34-inch-movie-poster-15241/" title="Avengers: Infinity War Portrait Collage Chart 22 x 34 inch Movie Poster 15241" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/04/avengers-infinity-war-poster-15241-170x170.jpg" width="170" height="170" class="related-thumb" alt="Avengers: Infinity War Portrait Collage Chart 22 x 34 inch Movie Poster 15241"></a></div><div><a href="https://www.filmfetish.com/ffmkt/jcvd-original-soundtrack-by-gast-waltzing-jean-claude-van-damme/" title="JCVD Original Soundtrack by Gast Waltzing &#8211; Jean-Claude Van Damme" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/09/jcvd-jean-claude-van-damme-soundtrack-album-gast-waltzing-170x170.jpg" width="170" height="170" class="related-thumb" alt="JCVD Original Soundtrack by Gast Waltzing &#8211; Jean-Claude Van Damme"></a></div></div><h2 class="myc-center low">Categories</h2>
			<p class="myc-center"><span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24211">Action</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=25515">BSX Music</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=1383">Cult Cinema</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24381">Cult Cinema Icons</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24161">Featured</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=33655">Featured - Email</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=15473">Horror</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24252">Music &amp; Spoken Word</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=15475">Science Fiction</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=1369">Suspense</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=322">Thrillers</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24627">Throwback Space</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24261">Vinyl</a></span></p>
		</div><!-- .entry-content -->
		<div class="share-meta">
        <div class="shareline">#</div>
        <div class="bkmrk-bottom"><div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2018%2F06%2Fthe-thing-vinyl-back.jpg&#038;description=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D73585" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;title=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;title=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;name=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;n=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fthe-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition%2F&#038;t=The%20Thing%3A%20Music%20From%20The%20Motion%20Picture%20Composed%20by%20Ennio%20Morricone%202-Disc%20Vinyl%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20Film Fetish | Crush Collectibles&body=Found%20this%20link%20of%20interest%20at%20Film Fetish | Crush Collectibles:%20https://www.filmfetish.com/?p=73585"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20Film Fetish | Crush Collectibles:%20https://www.filmfetish.com/?p=73585"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	</div> 
<p class="cntr">Page Link<br />
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/' /><br/>
Short Link<br/>
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/?p=73585' /></p>
<div class="shareline">#</div>
        </div><!-- .share-meta -->

		<footer class="entry-meta">
					</footer>
	</article><!-- #post -->

			
<div id="comments" class="comments-area">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.filmfetish.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p><label for="bhmcorans">What is <strong>3 + 20</strong> ?</label><input name="bhmcorans" id="bhmcorans" placeholder="Total" type="text" /></p>
	<p class="bhmspamkill"><label for="bhm_nonviewable">Comment</label><textarea id="bhm_nonviewable" name="bhm_nonviewable"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='73585' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
			
		</div><!-- #content -->
 		
<div id="secondary-2" class="widget-area-footer" role="complementary">
		<div class="first foot-widgets">
		<aside id="text-10" class="widget widget_text">			<div class="textwidget"><style type="text/css">
#siteseal,#siteseal img{ box-shadow:none !important; }
</style><span id="siteseal"><script async type="text/javascript" src="https://seal.godaddy.com/getSeal?sealID=rH1l6dk2mtoVz3jYyGon3RFfR7VdpW5gXXKlATaM6kRI0sfrsWYmRCxiSuDt"></script></span></div>
		</aside><aside id="rss-11" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/shop/misc/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Latest Crush Items</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-return-of-swamp-thing-2-disc-special-collectors-edition-mvd-rewind-collection/'>The Return of Swamp Thing 2-Disc Special Collector’s Edition – MVD Rewind Collection</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/'>The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/ghost-in-the-shell-deluxe-slipcover-edition-manga-complete-boxed-set-premium-lithograph-art-by-creator-shirow-masamune/'>Ghost in the Shell Deluxe Slipcover Edition Manga: Complete Boxed Set + Premium Lithograph Art by creator Shirow Masamune</a></li></ul></aside><aside id="nav_menu-17" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-departments-container"><ul id="menu-departments" class="menu"><li id="menu-item-49437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49437"><a title="Apparel" href="https://www.filmfetish.com/market/archive/?mcrterm=24386&#038;mcrtrmkey=category">Apparel</a></li>
<li id="menu-item-49438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49438"><a title="Books" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></li>
<li id="menu-item-49488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49488"><a title="Featured" href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured</a></li>
<li id="menu-item-68606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68606"><a title="Games" href="https://www.filmfetish.com/market/archive/?mcrterm=30441&#038;mcrtrmkey=category">Games</a></li>
<li id="menu-item-62385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62385"><a title="Home Goods" href="https://www.filmfetish.com/market/archive/?mcrterm=24612&#038;mcrtrmkey=category">Home Goods</a></li>
<li id="menu-item-49439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49439"><a title="Lobby Cards" href="https://www.filmfetish.com/market/archive/?mcrterm=24383&#038;mcrtrmkey=category">Lobby Cards</a></li>
<li id="menu-item-49440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49440"><a title="Movies &#038; TV" href="https://www.filmfetish.com/market/archive/?mcrterm=24129&#038;mcrtrmkey=category">Movies &#038; TV</a></li>
<li id="menu-item-49441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49441"><a title="Mugs &#038; Cups" href="https://www.filmfetish.com/market/archive/?mcrterm=24277&#038;mcrtrmkey=category">Mugs &#038; Cups</a></li>
<li id="menu-item-49442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49442"><a title="Music" href="https://www.filmfetish.com/market/archive/?mcrterm=24252&#038;mcrtrmkey=category">Music</a></li>
<li id="menu-item-49443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49443"><a title="Photo Prints" href="https://www.filmfetish.com/market/archive/?mcrterm=24293&#038;mcrtrmkey=category">Photo Prints</a></li>
<li id="menu-item-49444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49444"><a title="Poster &#038; Canvas Shop" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
<li id="menu-item-49445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49445"><a title="Toys" href="https://www.filmfetish.com/market/archive/?mcrterm=24128&#038;mcrtrmkey=category">Toys</a></li>
</ul></div></aside><aside id="rss-6" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="http://myfantasticart.com/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="http://myfantasticart.com/">MyFantasticArt.com</a></h3><ul><li><a class='rsswidget' href='http://myfantasticart.com/2018/05/29/my-gallery/'>M &amp; J Arts and Crafts</a></li><li><a class='rsswidget' href='http://myfantasticart.com/2017/08/26/funko-hqs-new-retail-store-features-themed-sections-and-everything-funatics-want/'>Funko HQ’s new retail store features themed sections and everything “Funatics” want</a></li><li><a class='rsswidget' href='http://myfantasticart.com/2017/08/23/sean-mackiewicz-and-niko-walter-team-up-for-crime-thriller-gasolina/'>Sean Mackiewicz and Niko Walter team up for crime thriller Gasolina</a></li><li><a class='rsswidget' href='http://myfantasticart.com/2017/06/07/ix-gallery-inaugural-show-to-include-julie-bell-hajime-sorayama-greg-tim-hildebrandt-and-dozens-more/'>IX Gallery inaugural show to include Julie Bell, Hajime Sorayama, Greg &amp; Tim Hildebrandt and dozens more</a></li><li><a class='rsswidget' href='http://myfantasticart.com/2017/04/12/resident-evil-vendetta-trailer-plus-limited-theatrical-engagement-details/'>Resident Evil Vendetta trailer plus limited theatrical engagement details</a></li></ul></aside><aside id="nav_menu-13" class="widget widget_nav_menu"><h3 class="widget-title">#FilmFetish #CrushCollectibles</h3><div class="menu-soc-media-container"><ul id="menu-soc-media" class="menu"><li id="menu-item-48865" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48865"><a title="FilmFetish on Facebook" target="_blank" href="https://www.facebook.com/filmfetish">facebook.com/filmfetish</a></li>
<li id="menu-item-48871" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48871"><a title="Go-phile on Facebook" target="_blank" href="https://www.facebook.com/gophile/">facebook.com/GOphile</a></li>
<li id="menu-item-48866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48866"><a title="FilmFetish on Twitter" target="_blank" href="http://twitter.com/filmfetish">twitter.com/filmfetish</a></li>
<li id="menu-item-48872" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48872"><a title="GO-phile on Twitter" target="_blank" href="https://twitter.com/GOphiles">twitter.com/GOphiles</a></li>
<li id="menu-item-68742" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68742"><a title="Crush Collectibles on Instagram" target="_blank" href="http://instagram.com/crushcollectibles">instagram.com/crushcollectibles</a></li>
<li id="menu-item-48867" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48867"><a title="FilmFetish on Instagram" target="_blank" href="http://instagram.com/filmfetish">instagram.com/filmfetish</a></li>
<li id="menu-item-48870" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48870"><a title="GO-phile on Instagram" target="_blank" href="https://www.instagram.com/go.phile">instagram.com/GO.phile</a></li>
<li id="menu-item-48868" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48868"><a title="FilmFetish on MyFantasticArt" target="_blank" href="http://myfantasticart.com/id/filmfetish">myfantasticart.com/id/filmfetish</a></li>
<li id="menu-item-48873" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48873"><a title="GO-phile on MyFantasticArt" target="_blank" href="http://myfantasticart.com/id/gophile/">myfantasticart.com/id/GOphile</a></li>
<li id="menu-item-48869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48869"><a title="Get our RSS Feed" target="_blank" href="http://www.filmfetish.com/feed/">filmfetish.com/feed</a></li>
</ul></div></aside>	</div><!-- .first -->
	
		<div class="second foot-widgets">
		<aside id="custom_html-3" class="widget_text widget widget_custom_html"><h3 class="widget-title">Crush Collectibles!</h3><div class="textwidget custom-html-widget"><p><a href="http://crushcollectibles.com" title="CRUSH COLLECTIBLES"><img src="https://www.filmfetish.com/img/p/2016/06/filmfetish-teaser-announcement.jpg" alt="Pop Culture, Sports and Music Collectibles" /></a></p></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside><aside id="rss-5" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/type/quote/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">PopCultureQuotes.com</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73493/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73491/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73489/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73487/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73485/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li></ul></aside><aside id="rss-10" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/editorials/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Recent News</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/film-fetish-crush-collectibles-meta-image180530/'>film-fetish-crush-collectibles-meta-image180530</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/30/todd-mcfarlane-to-direct-and-jamie-foxx-to-star-in-new-film-adaptation-of-spawn/'>Todd McFarlane to direct and Jamie Foxx to star in new film adaptation of ‘Spawn’</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/25/red-band-trailer-and-alt-poster-for-horror-upgrade-released/'>Red band trailer and alt. poster for horror Upgrade released</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/updates-on-the-status-of-tales-from-the-hood-2-and-it-looks-like-we-go-back-to-the-hood-this-september/'>Updates on the status of Tales from the Hood 2 and it looks like we go back to the hood this September</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/crush-taxi-driver/'>Crush Collectibles Taxi Driver Homage</a></li></ul></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">About Us</h3><div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-70051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70051"><a title="Share Our Banners and Spread the Word About Us!" href="https://www.filmfetish.com/category/editorials/media-photos/banners/">Share Our Banners</a></li>
<li id="menu-item-37141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37141"><a href="https://www.filmfetish.com/about/">About Us</a></li>
<li id="menu-item-49547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49547"><a href="https://www.filmfetish.com/about/return-policy/">Return Policy</a></li>
<li id="menu-item-49546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49546"><a href="https://www.filmfetish.com/about/shipping-information/">Shipping Information</a></li>
<li id="menu-item-49656" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49656"><a href="https://www.filmfetish.com/product-size-charts/">Product Size Charts</a></li>
<li id="menu-item-37143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37143"><a href="https://www.filmfetish.com/about/copyright/">Copyright</a></li>
<li id="menu-item-37145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37145"><a href="https://www.filmfetish.com/about/privacy-policy/">Privacy Policy | Terms of Use | Disclaimer</a></li>
<li id="menu-item-49545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49545"><a href="https://www.filmfetish.com/about/contact/">Contact</a></li>
</ul></div></aside>	</div><!-- .second -->
	</div><!-- #secondary -->       
	</div><!-- #primary -->

	<div id="secondary" class="widget-area" role="complementary">
		<aside id="nav_menu-18" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-store-quick-links-container"><ul id="menu-store-quick-links" class="menu"><li id="menu-item-65771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65771"><a href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured Items</a></li>
<li id="menu-item-68607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68607"><a title="Poster Crush" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
<li id="menu-item-65769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65769"><a href="https://www.filmfetish.com/market/archive/?mcrky=_mycprcgrp&#038;mcrvl=preorder&#038;mcrcpr=LIKE">Preorders</a></li>
<li id="menu-item-65770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65770"><a href="https://www.filmfetish.com/market/archive/">Specials</a></li>
<li id="menu-item-65768" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65768"><a href="https://www.filmfetish.com/market/">All Items</a></li>
</ul></div></aside><aside id="mtheater_content_widget-6" class="widget mthecontentwidg"><h3 class="widget-title">Shoppers Also Purchased</h3><h2 class="myc-center low">Related Items</h2><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/g-i-joe-a-real-american-hero-season-1-1-4-dvd-box-set/" title="G.I. Joe A Real American Hero: Season 1.1 &#8211; 4 DVD Box Set" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/02/gi-joe-season-1-dvd-01b-170x170.jpg" width="170" height="170" class="related-thumb" alt="G.I. Joe A Real American Hero: Season 1.1 &#8211; 4 DVD Box Set"></a></div><div><a href="https://www.filmfetish.com/ffmkt/city-on-fire/" title="City on Fire" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/02/city-on-fire-movie-images-poster-art-170x170.jpg" width="170" height="170" class="related-thumb" alt="City on Fire"></a></div><div><a href="https://www.filmfetish.com/ffmkt/steve-mcqueens-bullitt-original-mass-market-paperback-novel-by-robert-l-pike-1968/" title="Steve McQueen&#8217;s Bullitt Original Mass Market Paperback Novel by Robert L. Pike (1968)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/03/bullitt-steve-mcqueen-book-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Steve McQueen&#8217;s Bullitt Original Mass Market Paperback Novel by Robert L. Pike (1968)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/frank-frazetta-death-dealer-three-24-x-36-inch-fantasy-art-poster/" title="Frank Frazetta Death Dealer Three 24 x 36 inch Fantasy Art Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/08/frank-frazetta-death-dealer-three-170x170.jpg" width="170" height="170" class="related-thumb" alt="Frank Frazetta Death Dealer Three 24 x 36 inch Fantasy Art Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/ennio-morricone-erotic-soundtracks-compilation/" title="Ennio Morricone &#8211; Erotic Soundtracks Compilation" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/12/ennio-morricone-erotic-soundtracks-cd-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Ennio Morricone &#8211; Erotic Soundtracks Compilation"></a></div><div><a href="https://www.filmfetish.com/ffmkt/dc-comics-retro-montage-superman-flash-batman-green-lantern-22-x-34-inch-poster/" title="DC Comics Retro Montage Superman, Flash, Batman, Green Lantern 22 x 34 inch Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/08/dc-comics-retro-montage-superman-flash-batman-green-lantern-170x170.jpg" width="170" height="170" class="related-thumb" alt="DC Comics Retro Montage Superman, Flash, Batman, Green Lantern 22 x 34 inch Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-man-who-fell-to-earth-2-cd-original-soundtrack-recording/" title="The Man Who Fell To Earth 2 CD Original Soundtrack Recording" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/11/the-man-who-fell-to-earth-original-soundtrack-album-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Man Who Fell To Earth 2 CD Original Soundtrack Recording"></a></div><div><a href="https://www.filmfetish.com/ffmkt/dc-comics-trinity-war-35-x-23-inch-poster/" title="DC Comics Trinity War 35 x 23 inch Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/01/P4302-DC-Comics-Trinity-War-170x170.jpg" width="170" height="170" class="related-thumb" alt="DC Comics Trinity War 35 x 23 inch Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/action-comics-80-years-of-superman-deluxe-edition-hardcover/" title="Action Comics: 80 Years of Superman Deluxe Edition Hardcover" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/05/action-comics-superman-80-years-deluxe-hardcover-book-170x170.jpg" width="170" height="170" class="related-thumb" alt="Action Comics: 80 Years of Superman Deluxe Edition Hardcover"></a></div><div><a href="https://www.filmfetish.com/ffmkt/terminator-the-sarah-connor-chronicles-original-television-soundtrack-music-by-bear-mccreary/" title="Terminator: The Sarah Connor Chronicles Original Television Soundtrack Music by Bear McCreary" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/08/terminator-sarah-connor-chronicles-tv-soundtrack-musicbear-mccreay-170x170.jpg" width="170" height="170" class="related-thumb" alt="Terminator: The Sarah Connor Chronicles Original Television Soundtrack Music by Bear McCreary"></a></div></div></aside><aside id="rss-13" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/shop/misc/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Latest Featured Items</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-return-of-swamp-thing-2-disc-special-collectors-edition-mvd-rewind-collection/'>The Return of Swamp Thing 2-Disc Special Collector’s Edition – MVD Rewind Collection</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-thing-music-from-the-motion-picture-composed-by-ennio-morricone-2-disc-vinyl-edition/'>The Thing: Music From The Motion Picture Composed by Ennio Morricone 2-Disc Vinyl Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/ghost-in-the-shell-deluxe-slipcover-edition-manga-complete-boxed-set-premium-lithograph-art-by-creator-shirow-masamune/'>Ghost in the Shell Deluxe Slipcover Edition Manga: Complete Boxed Set + Premium Lithograph Art by creator Shirow Masamune</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/star-wars-rogue-one-hot-wheels-character-car-darth-vader/'>Star Wars: Rogue One Hot Wheels Character Car Darth Vader</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/star-wars-hot-wheels-character-cars-r2-d2-and-c-3po/'>Star Wars Hot Wheels Character Cars R2-D2 and C-3PO</a></li></ul></aside><aside id="nav_menu-14" class="widget widget_nav_menu"><h3 class="widget-title">Departments</h3><div class="menu-departments-container"><ul id="menu-departments-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49437"><a title="Apparel" href="https://www.filmfetish.com/market/archive/?mcrterm=24386&#038;mcrtrmkey=category">Apparel</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49438"><a title="Books" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49488"><a title="Featured" href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68606"><a title="Games" href="https://www.filmfetish.com/market/archive/?mcrterm=30441&#038;mcrtrmkey=category">Games</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62385"><a title="Home Goods" href="https://www.filmfetish.com/market/archive/?mcrterm=24612&#038;mcrtrmkey=category">Home Goods</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49439"><a title="Lobby Cards" href="https://www.filmfetish.com/market/archive/?mcrterm=24383&#038;mcrtrmkey=category">Lobby Cards</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49440"><a title="Movies &#038; TV" href="https://www.filmfetish.com/market/archive/?mcrterm=24129&#038;mcrtrmkey=category">Movies &#038; TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49441"><a title="Mugs &#038; Cups" href="https://www.filmfetish.com/market/archive/?mcrterm=24277&#038;mcrtrmkey=category">Mugs &#038; Cups</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49442"><a title="Music" href="https://www.filmfetish.com/market/archive/?mcrterm=24252&#038;mcrtrmkey=category">Music</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49443"><a title="Photo Prints" href="https://www.filmfetish.com/market/archive/?mcrterm=24293&#038;mcrtrmkey=category">Photo Prints</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49444"><a title="Poster &#038; Canvas Shop" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49445"><a title="Toys" href="https://www.filmfetish.com/market/archive/?mcrterm=24128&#038;mcrtrmkey=category">Toys</a></li>
</ul></div></aside><aside id="nav_menu-15" class="widget widget_nav_menu"><h3 class="widget-title">Popular Genres</h3><div class="menu-popular-genres-container"><ul id="menu-popular-genres" class="menu"><li id="menu-item-49449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49449"><a title="Action" href="https://www.filmfetish.com/market/archive/?mcrterm=24211&#038;mcrtrmkey=category">Action</a></li>
<li id="menu-item-49450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49450"><a title="Adventure" href="https://www.filmfetish.com/market/archive/?mcrterm=24212&#038;mcrtrmkey=category">Adventure</a></li>
<li id="menu-item-49451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49451"><a title="Comedy" href="https://www.filmfetish.com/market/archive/?mcrterm=24216&#038;mcrtrmkey=category">Comedy</a></li>
<li id="menu-item-49452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49452"><a title="Crime" href="https://www.filmfetish.com/market/archive/?mcrterm=24217&#038;mcrtrmkey=category">Crime</a></li>
<li id="menu-item-49453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49453"><a title="Documentary" href="https://www.filmfetish.com/market/archive/?mcrterm=24218&#038;mcrtrmkey=category">Documentary</a></li>
<li id="menu-item-49454" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49454"><a title="Exploitation" href="https://www.filmfetish.com/market/archive/?mcrterm=24220&#038;mcrtrmkey=category">Exploitation</a></li>
<li id="menu-item-49455" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49455"><a title="Fantasy" href="https://www.filmfetish.com/market/archive/?mcrterm=958&#038;mcrtrmkey=category">Fantasy</a></li>
<li id="menu-item-49456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49456"><a title="Horror" href="https://www.filmfetish.com/market/archive/?mcrterm=24226&#038;mcrtrmkey=category">Horror</a></li>
<li id="menu-item-49457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49457"><a title="Martial Arts" href="https://www.filmfetish.com/market/archive/?mcrterm=24227&#038;mcrtrmkey=category">Martial Arts</a></li>
<li id="menu-item-49458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49458"><a title="Mystery" href="https://www.filmfetish.com/market/archive/?mcrterm=24231&#038;mcrtrmkey=category">Mystery</a></li>
<li id="menu-item-49459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49459"><a title="Science Fiction" href="https://www.filmfetish.com/market/archive/?mcrterm=24235&#038;mcrtrmkey=category">Science Fiction</a></li>
<li id="menu-item-49460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49460"><a title="Thriller" href="https://www.filmfetish.com/market/archive/?mcrterm=24240&#038;mcrtrmkey=category">Thriller</a></li>
</ul></div></aside>	</div><!-- #secondary -->
	</div><!-- #main .wrapper -->
	<footer id="colophon" role="contentinfo">
		<div class="site-info">
					&copy; 2018 Film Fetish | Crush Collectibles | <a href="http://hitpi.cc/mtheaterfooterurl/" title="M Theater Wordpress Theme created by Rene Carson from HIT PICTURES" target="_blank"> Website Design: HIT PICTURES</a> <span class="logshow off"><a href="https://www.filmfetish.com/wp-login.php">Log in</a></span></div><!-- .site-info -->
	</footer><!-- #colophon -->

<div id="gotop"><a href="#top"><span></span></a></div>
</div><!-- #page -->

<!-- Instagram Feed JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.filmfetish.com/wp-admin/admin-ajax.php";
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.widowbuster.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/comment-reply.min.js?ver=4.9.6'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids-ld.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.colorbox.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.topspring.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/nav.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/mediaelement-ld.js'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.easing.js?ver=1.3'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.touchSwipe.min.js?ver=1.3'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.liquid-slider.min.js?ver=2.3.8'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/wp-embed.min.js?ver=4.9.6'></script>
   
<script>		
jQuery(window).load(function($) {	
	jQuery('a[href$=".jpg"],a[href$=".jpeg"],a[href$=".png"],a[href$=".gif"]').colorbox({rel:'gal',maxHeight:'100%',speed:700,fadeOut:600,initialWidth:false,maxWidth:'100%',initialHeight:false,slideshow:true,slideshowAuto:false,slideshowSpeed:6000,slideshowStart:'slideshow',slideshowStop:'stop',transition:'fade'});
	jQuery('.mycc-ajax').colorbox();
	jQuery('.mycc-inline').colorbox({inline:true,speed:700,fadeOut:600,width:'100%',height:'100%',transition:'fade'});
});
</script>
	<script>
jQuery(window).load(function($){
var d = new Date();
var n = d.getMonth() + 1;
var yr = d.getFullYear();
var design_month_covers = ['https://www.filmfetish.com/img/p/2016/07/calimg160718-body-double-melanie-griffith-craig-wasson.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-elton-john-diana-ross-cher-awards-show-1980s.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-bridget-fonda-robert-deniro-samuel-l-jackson-in-jackie-brown.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-janet-leigh.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-vincent-donofrio-martin-sensmeier-manuel-garciarulfo-ethan-hawke-denzel-washington-chris-pratt-byunghunlee-magnificent-seven.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-five-easy-pieces-loews-holly-theater-hollywood-blvd.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-linda-lovelace-deep-throat-porn-icon.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-le-mans-playing-loews-state-times-square-new-york-city-1971.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-rebecca-ferguson-mission-impossible-rogue-nation-2015.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-lauren-cohan-the-boy-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-yoo-gong-in-train-to-busan-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-dane-dehaan-valerian-city-thousand-planets-2017.jpg'];
dzscal_init("#tr1",{
design_month_covers : design_month_covers,
start_month: n,
	start_year: yr
});
});
</script>
<div class="bhad-wrapper plugin_load_early"><div class='bhadads plugin_load_early'><div class='liquid-slider ad' id='adsysslide'>
<div>
<h2 class='bhadadtitle'><a href="https://widget.sx/2018/05/10/movie-tv-music-and-sports-collectibles/" title="Movie, TV, Music and Sports Collectibles">Movie, TV, Music and Sports Collectibles</a></h2>
<p><a href="http://crushcollectibles.com/" target="_blank"><span class="icn">a</span> Crush Collectibles <span class="arw">&#8658;</span></a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://widget.sx/2018/05/10/flyer-hype-promotional-event-flyers/" title="Flyer Hype Promotional Event Flyers">Flyer Hype Promotional Event Flyers</a></h2>
<p><a href="http://hitpi.cc/domains/" target="_blank"><span class="icn">Y</span> Promo Flyers for Deejay/Filmmaker Events <span class="arw">&#8658;</span></a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://widget.sx/2018/05/10/headshotcard-com-comp-card-services/" title="HeadshotCard.com Comp Card Services">HeadshotCard.com Comp Card Services</a></h2>
<p><a href="http://headshotcard.com/" target="_blank"><span class="icn">r</span> HEADSHOTCARD.COM <span class="arw">&#8658;</span> Comp Cards, Headshots</a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://widget.sx/2018/05/10/website-services/" title="Website Services">Website Services</a></h2>
<p><a href="http://hitpi.cc/domains/" target="_blank"><span class="icn">X</span> HitPictures.tech <span class="arw">&#8658;</span> Domain Names, Websites</a></p>
</div>
</div></div></div><script>
			$('#adsysslide').liquidSlider({
				panelTitleSelector:".bhadadtitle",
				autoSlide:true,
				dynamicArrows:false,
				hoverArrows:false,
				dynamicArrowsGraphical:false,
				autoSlideInterval:10000,
				dynamicTabs:false,
				pauseOnHover:true,
				autoHeight:false,
				mobileNavigation:false,
				includeTitle:false
		});
	</script><!-- Start of StatCounter Code for Default Guide -->
<script type="text/javascript">
var sc_project=6854008; 
var sc_invisible=1; 
var sc_security="5609cdda"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="shopify
analytics ecommerce" href="http://statcounter.com/shopify/"
target="_blank"><img class="statcounter"
src="//c.statcounter.com/6854008/0/5609cdda/1/" alt="shopify
analytics ecommerce"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->
</body>
</html>