<!DOCTYPE html>
<!-- Get M Theater WordPress Theme at BY HAND Media (http://www.byhandmedia.net/mtheater) -->
<!--[if IE 7 | IE 8]>
<html class="ie" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Trailer for Swedish horror The Evil Next Door |  FilmFetish.com | Film Fetish and the Crush Collectibles Shop </title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.filmfetish.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://www.filmfetish.com/wp-content/themes/m-theater/js/html5.js" type="text/javascript"></script>
<![endif]-->

<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop &raquo; Feed" href="https://www.filmfetish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop &raquo; Comments Feed" href="https://www.filmfetish.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.filmfetish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sbi_styles-css'  href='https://www.filmfetish.com/wp-content/plugins/instagram-feed-pro/css/sbi-styles.min.css?ver=5.11.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.filmfetish.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-style-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/style.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelementcss-css'  href='https://www.filmfetish.com/wp-includes//js/mediaelement/mediaelementplayer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='naranja-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/theme-color-naranja.css' type='text/css' media='all' />
<link rel='stylesheet' id='mycccaltltpcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzstooltip/dzstooltip.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccuscalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-cal-cus.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccartcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-shopcart.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='myccmaincss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-mycc.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js?ver=2.1.4' id='jquery-js'></script>
<link rel="https://api.w.org/" href="https://www.filmfetish.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.filmfetish.com/wp-json/wp/v2/posts/87119" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.filmfetish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.filmfetish.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel="canonical" href="https://www.filmfetish.com/2021/05/25/trailer-for-swedish-horror-the-evil-next-door/" />
<link rel='shortlink' href='https://www.filmfetish.com/?p=87119' />
<link rel="alternate" type="application/json+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;format=xml" />
<link rel="image_src" href="https://www.filmfetish.com/img/p/2021/05/evil_next_door_sldr-1100x623.jpg" />
<meta name="web_author" content="Web Site Development: HitPictures.tech" />
<meta name="wp_theme_name" content="M Theater" />
<link rel="wp_theme_address" href="http://hitpictures.tech/mtheater/" />
<meta name="copyright" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
<meta name="googlebot" content="noodp" />
<meta name="robots" content="noodp" />
<meta name="no-email-collection" content="No spam harvesting allowed" />
<meta name="dc.source" content="https://www.filmfetish.com/2021/05/25/trailer-for-swedish-horror-the-evil-next-door/" />
<meta name="dc.publisher" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
<meta name="dc.date" content="2021-05-25T14:55:57-04:00" />
<meta name="dc.title" content="Trailer for Swedish horror The Evil Next Door" />
<meta name="dc.creator" content="René Carson" />
<meta name="description" content="Trailer for Swedish horror The Evil Next Door-https://www.youtube.com/watch?v=t-X3WL8WFJ8  The Evil Next Door centers on new stepmom Shirin (Dilan Gwyn), who moves into a duplex with her partner, Fredrik" />
<meta name="keywords" content="delilah kujala,dilan gwyn,eddie eriksson dominguez,henrik norlén,horror,jakob fahlstedt,janna granström,karin holmberg,linus wahlgren,news,niklas jarneheim,oskar mellander,posters,sovi rydén,the evil next door,thrillers,tord danielsson,trailers,troy james," />
<meta name="author" content="René Carson" />
<meta name="abstract" content="Trailer for Swedish horror The Evil Next Door" />
<meta property="og:title" content="Trailer for Swedish horror The Evil Next Door" />
<meta itemprop="name" content="Trailer for Swedish horror The Evil Next Door" />
<meta name="twitter:title" content="Trailer for Swedish horror The Evil Next Door" />
<meta property="og:type" content="article" />
<meta property="article:published_time" content="2021-05-25T14:55:57-04:00" />
<meta property="article:modified_time" content="2021-05-25T14:56:17-04:00" />
<meta property="og:description" content="Trailer for Swedish horror The Evil Next Door-https://www.youtube.com/watch?v=t-X3WL8WFJ8  The Evil Next Door centers on new stepmom Shirin (Dilan Gwyn), who moves into a duplex with her partner, Fredrik" />
<meta name="twitter:description" content="Trailer for Swedish horror The Evil Next Door-https://www.youtube.com/watch?v=t-X3WL8WFJ8  The Evil Next Door centers on new stepmom Shirin (Dilan Gwyn), who moves into a duplex with her partner, Fredrik" />
<meta itemprop="description" content="Trailer for Swedish horror The Evil Next Door-https://www.youtube.com/watch?v=t-X3WL8WFJ8  The Evil Next Door centers on new stepmom Shirin (Dilan Gwyn), who moves into a duplex with her partner, Fredrik" />
<meta itemprop="image" content="https://www.filmfetish.com/img/p/2021/05/evil_next_door_sldr-1100x623.jpg" />
<meta name="twitter:card" content="video" />
<meta property="og:url" content="https://www.filmfetish.com/2021/05/25/trailer-for-swedish-horror-the-evil-next-door/" />
<meta property="og:image" content="https://www.filmfetish.com/img/p/2021/05/evil_next_door_sldr-1100x623.jpg" />
<meta property="og:site_name" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px);
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<!-- M Theater Custom CSS -->
<style type="text/css" media="screen" id="mtheater-custom-styles">
@import url("//cdn-images.mailchimp.com/embedcode/classic-10_7.css");

@import url("//www.filmfetish.com/wp-content/fetish-styles.css");

@import url("//i.hit.pictures/css/network-shops.css");
</style><!-- End Custom CSS -->

<link rel="shortcut icon" href="https://hit.pics/favicon.ico" />
<style type="text/css" media="screen" id="mtheater-custom-plugin-styles">
/* Custom M Theater CSS */
.archive-txt { display: none; }
/* Mailchimp */
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
/* Plugin */
p.bhmspamkill, textarea#bhm_nonviewable { display:none;position:absolute;left:-9000px; }
/* ie */
.ie #bhmmainpg .bhmmainlogobx .bhmmaintxt { width: 46%; float: left; }
.ie #bhmmainpg .bhmmainlogobx { width: 43%; padding: 2%; float: left; min-height: 320px; min-height: 22.857142857rem; }
.ie #bhmmainpg .bhmmainlogobx.right { float: right; }
</style></head>

<body id="top" class="post-template-default single single-post postid-87119 single-format-video httpswwwfilmfetishcom custom-background-empty custom-font-enabled nav-nobanner style-fnt-hdr-sz-a style-fnt-hdr-styl-a style-fnt-ttl-styl-a style-fnt-bod-styl-a">

<div id="page" class="hfeed site">
	<header id="masthead" class="site-header" role="banner">
		<hgroup class="title-background">
			<h1 class="site-title"><a href="https://www.filmfetish.com/" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" rel="home">FilmFetish.com | Film Fetish and the Crush Collectibles Shop</a></h1>
			<h2 class="site-description">Cool Movies, TV, Music and Sports</h2>
		</hgroup>


<nav id="site-navigation" class="main-navigation-fet" role="navigation">
	<div class="skip-link assistive-text"><a href="#content" title="Skip to content">Skip to content</a></div>
	<div class="menu-ff-top-nav-container"><ul id="menu-ff-top-nav" class="nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"><a class="mycc-inline" href="#nav_menu-18">Menu</a></li><li class="mbtn"><div class="mycc-viewcart"><form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post"><input type="hidden" name="business" value="sitepay@crushcollectibles.com"><input type="hidden" name="cmd" value="_cart"><input type="hidden" name="display" value="1"><input type="hidden" name="shopping_url" value="https://www.filmfetish.com/2021/05/25/trailer-for-swedish-horror-the-evil-next-door"><input type="image" name="submit" src="https://www.filmfetish.com/wp-content/plugins/concoupons/images/spcr22.gif" alt="View Cart" title="View Cart"><img alt="" width="1" height="1" src="https://www.filmfetish.com/wp-content/plugins/concoupons/images/spcr.gif"><input type="hidden" name="cpp_logo_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_checkout_logo161114.gif"><input type="hidden" name="page_style" value="film_fetish"></form></div></li><li><form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Try A Search!"></form></li></ul></div></nav>
        


<div id="search-social">



<div id="searchmain" class="searchwrap"><div class="respo"><a href="https://www.crushcollectibles.com/" title="Crush Collectibles"><img class="cc logo-img  live" src="https://www.filmfetish.com/wp-content/special-imgs/crush-collectibles.svg" alt="CRUSHCOLLECTIBLES.COM" /></a><img class="ffrl logo-img" src="https://www.filmfetish.com/wp-content/special-imgs/film-fetish-reel.svg" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="Film Fetish Home"><img class="ff logo-img  arc" src="https://www.filmfetish.com/wp-content/special-imgs/film-fetish.svg" alt="FILMFETISH.COM" /></a></div></div>




</div><!-- #search-social -->
	</header><!-- #masthead -->

	<div id="main" class="wrapper">  	<div id="primary" class="site-content">
		<div id="content" role="main">

			
					
	<article id="post-87119" class="solo post-87119 post type-post status-publish format-video hentry category-news post_format-post-format-video cppl-delilah-kujala cppl-dilan-gwyn cppl-eddie-eriksson-dominguez cppl-henrik-norlen cppl-jakob-fahlstedt cppl-janna-granstrom cppl-karin-holmberg cppl-linus-wahlgren cppl-niklas-jarneheim cppl-oskar-mellander cppl-sovi-ryden cppl-tord-danielsson cppl-troy-james cshow-the-evil-next-door cgenr-horror-films cgenr-thrillers cstry-movie-tv-posters cstry-trailers less-three">
    <div id="social-nav-top"><a class="mycc-inline protected" href="#sotop">Share Page</a> <a class="protected" href="https://www.filmfetish.com/support/">Support Us</a>
<div style="display:none;"><div id="sotop"> <div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2021%2F05%2Fevil_next_door_sldr-1100x623.jpg&#038;description=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D87119" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;title=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;title=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;name=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;n=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;t=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=87119"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=87119"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	 </div></div>
<div id="socplus-right"><nav class="nav-single-top">
					<h3 class="assistive-text">Post navigation</h3>
					<a href="https://www.filmfetish.com/2021/05/25/check-out-the-poster-and-teaser-trailer-for-edgar-wright-psychological-thriller-last-night-in-soho/" rel="prev"><span class="nav-previous">&#8212; Previous</span></a>					<a href="https://www.filmfetish.com/2021/05/25/marvel-studios-revealed-new-trailer-for-oscar-winner-chloe-zhao-directed-eternals/" rel="next"><span class="nav-next">Next &#8212;</span></a>				</nav><!-- #socplus-right -->
                </div><!-- .nav-single-top -->
		</div><!-- #social-nav-top -->
        
				<header class="entry-header">
			            
            
                       
            <h1 class="entry-title">Trailer for Swedish horror The Evil Next Door</h1>
		</header><!-- .entry-header -->

		<div class="entry-content">
			<p><iframe loading="lazy" title="The Evil Next Door - Official Trailer" width="625" height="352" src="https://www.youtube.com/embed/t-X3WL8WFJ8?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p><a href="https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster.jpg"><img loading="lazy" src="https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster-210x310.jpg" alt="" width="210" height="310" class="alignleft size-medium wp-image-87120" srcset="https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster-210x310.jpg 210w, https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster-745x1100.jpg 745w, https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster-768x1134.jpg 768w, https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster-1040x1536.jpg 1040w, https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster-340x502.jpg 340w, https://www.filmfetish.com/img/p/2021/05/evil_next_door_movie_poster.jpg 1300w" sizes="(max-width: 210px) 100vw, 210px" /></a>The Evil Next Door centers on new stepmom Shirin (Dilan Gwyn), who moves into a duplex with her partner, Fredrik (Linus Wahlgren), and his son, Lucas (Eddie Eriksson Dominguez). The new home feels like the right place to start becoming a family. But when Fredrik leaves for work, strange things are heard from the other, uninhabited side. Also, who is Lucas&#8217; new friend?</p>
<p>Tord Danielsson and Oskar Mellander co-wrote and directed Swedish horror The Evil Next Door, which stars Jakob Fahlstedt, Janna Granström, Dilan Gwyn, Karin Holmberg, Troy James, Niklas Jarneheim, Delilah Kujala, Henrik Norlén, Sovi Rydén, Eddie Eriksson Dominguez and Linus Wahlgren.</p>
<p>Magnet Releasing will release The Evil Next Door in theaters and on demand June 25th, 2021.</p>
<div class="explore-more"><span>Explore More...</span><br/><ul><li>Categories: <a href="https://www.filmfetish.com/category/news/">News</a></li><li>Formats: <a href="https://www.filmfetish.com/type/video/">Video</a></li><li>People / Bands: <a href="https://www.filmfetish.com/cpeople/delilah-kujala/">Delilah Kujala</a> | <a href="https://www.filmfetish.com/cpeople/dilan-gwyn/">Dilan Gwyn</a> | <a href="https://www.filmfetish.com/cpeople/eddie-eriksson-dominguez/">Eddie Eriksson Dominguez</a> | <a href="https://www.filmfetish.com/cpeople/henrik-norlen/">Henrik Norlén</a> | <a href="https://www.filmfetish.com/cpeople/jakob-fahlstedt/">Jakob Fahlstedt</a> | <a href="https://www.filmfetish.com/cpeople/janna-granstrom/">Janna Granström</a> | <a href="https://www.filmfetish.com/cpeople/karin-holmberg/">Karin Holmberg</a> | <a href="https://www.filmfetish.com/cpeople/linus-wahlgren/">Linus Wahlgren</a> | <a href="https://www.filmfetish.com/cpeople/niklas-jarneheim/">Niklas Jarneheim</a> | <a href="https://www.filmfetish.com/cpeople/oskar-mellander/">Oskar Mellander</a> | <a href="https://www.filmfetish.com/cpeople/sovi-ryden/">Sovi Rydén</a> | <a href="https://www.filmfetish.com/cpeople/tord-danielsson/">Tord Danielsson</a> | <a href="https://www.filmfetish.com/cpeople/troy-james/">Troy James</a></li><li>Shows / Movies: <a href="https://www.filmfetish.com/cshow/the-evil-next-door/">The Evil Next Door</a></li><li>Genres: <a href="https://www.filmfetish.com/genr/horror-films/">Horror</a> | <a href="https://www.filmfetish.com/genr/thrillers/">Thrillers</a></li><li>Story Types: <a href="https://www.filmfetish.com/stry/movie-tv-posters/">Posters</a> | <a href="https://www.filmfetish.com/stry/trailers/">Trailers</a></li></ul></div>
                    
        		</div><!-- .entry-content -->
		<div class="share-meta">
        <div class="shareline">#</div>
        <div class="bkmrk-bottom"><div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2021%2F05%2Fevil_next_door_sldr-1100x623.jpg&#038;description=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D87119" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;title=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;title=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;name=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;n=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2F2021%2F05%2F25%2Ftrailer-for-swedish-horror-the-evil-next-door%2F&#038;t=Trailer%20for%20Swedish%20horror%20The%20Evil%20Next%20Door" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=87119"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=87119"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	</div> 
<p class="cntr">Page Link<br />
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/2021/05/25/trailer-for-swedish-horror-the-evil-next-door/' /><br/>
Short Link<br/>
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/?p=87119' /></p>
<div class="shareline">#</div>
        </div><!-- .share-meta -->

		<footer class="entry-meta">
			<a href="https://www.filmfetish.com/type/video/" class="postformat pf" title="See all video" rel="search">view all &nbsp;<span class="pfor video">video posts</span></a><br>more on  <a href="https://www.filmfetish.com/category/news/" rel="category tag">News</a> <br>posted <a href="https://www.filmfetish.com/2021/05/25/trailer-for-swedish-horror-the-evil-next-door/" title="2:55 pm" rel="bookmark"><time class="entry-date" datetime="2021-05-25T14:55:57-04:00" pubdate>May 25, 2021</time></a><span class="by-author"> by <span class="author vcard"><a class="url fn n" href="https://www.filmfetish.com/author/renecarson/" title="View all posts by René Carson" rel="author">René Carson</a></span></span>								</footer><!-- .entry-meta -->
	</article><!-- #post -->

				<div>				<nav class="nav-single">
					<h3 class="assistive-text">Post navigation</h3>
					<a href="https://www.filmfetish.com/2021/05/25/check-out-the-poster-and-teaser-trailer-for-edgar-wright-psychological-thriller-last-night-in-soho/" rel="prev"><span class="nav-previous bot">&#8212; Previous</span></a>					<a href="https://www.filmfetish.com/2021/05/25/marvel-studios-revealed-new-trailer-for-oscar-winner-chloe-zhao-directed-eternals/" rel="next"><span class="nav-next bot">Next &#8212;</span></a>				</nav><!-- .nav-single -->
</div><!-- no post nav display for some post formats -->

				
			
		</div><!-- #content -->
 		
<div id="secondary-2" class="widget-area-footer" role="complementary">
		<div class="first foot-widgets">
		<aside id="nav_menu-16" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-product-types-container"><ul id="menu-product-types" class="menu"><li id="menu-item-85322" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85322"><a href="https://www.filmfetish.com/prds/apparel-accessories/">Apparel &amp; Accessories</a>
<ul class="sub-menu">
	<li id="menu-item-85323" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85323"><a href="https://www.filmfetish.com/prds/bandanas/">Bandanas</a></li>
	<li id="menu-item-85324" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85324"><a href="https://www.filmfetish.com/prds/clothing-accessories/">Clothing Accessories</a></li>
	<li id="menu-item-85325" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85325"><a href="https://www.filmfetish.com/prds/hat/">Hat</a></li>
	<li id="menu-item-85326" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85326"><a href="https://www.filmfetish.com/prds/jewelry/">Jewelry</a></li>
	<li id="menu-item-85408" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85408"><a href="https://www.filmfetish.com/prds/pullovers-hoodies/">Pullovers &amp; Hoodies</a></li>
	<li id="menu-item-85409" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85409"><a href="https://www.filmfetish.com/prds/t-shirts-full-cover-print/">T-Shirts &#8211; All Over Print</a></li>
	<li id="menu-item-85410" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85410"><a href="https://www.filmfetish.com/prds/t-shirts-long-sleeve/">T-Shirts &#8211; Long Sleeve</a></li>
	<li id="menu-item-85411" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85411"><a href="https://www.filmfetish.com/prds/t-shirts-short-sleeve/">T-Shirts &#8211; Short Sleeve</a></li>
	<li id="menu-item-85386" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85386"><a href="https://www.filmfetish.com/prds/tie-crush/">Tie Crush &#8211; Downright Dapper Neckties</a></li>
</ul>
</li>
<li id="menu-item-85328" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85328"><a href="https://www.filmfetish.com/prds/books/">Books</a>
<ul class="sub-menu">
	<li id="menu-item-85329" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85329"><a href="https://www.filmfetish.com/prds/calendars/">Calendars</a></li>
	<li id="menu-item-85330" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85330"><a href="https://www.filmfetish.com/prds/comics/">Comics</a></li>
	<li id="menu-item-85331" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85331"><a href="https://www.filmfetish.com/prds/graphic-novels/">Graphic Novels</a></li>
	<li id="menu-item-85332" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85332"><a href="https://www.filmfetish.com/prds/hardcover-books/">Hardcover Books</a></li>
	<li id="menu-item-85333" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85333"><a href="https://www.filmfetish.com/prds/magazines-newspapers/">Magazines &amp; Newspapers</a></li>
	<li id="menu-item-85412" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85412"><a href="https://www.filmfetish.com/prds/softcover-books/">Softcover Books</a></li>
</ul>
</li>
<li id="menu-item-85334" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85334"><a href="https://www.filmfetish.com/prds/equipment/">Equipment</a></li>
<li id="menu-item-85336" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85336"><a href="https://www.filmfetish.com/prds/food-items/">Food Items</a></li>
<li id="menu-item-85338" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85338"><a href="https://www.filmfetish.com/prds/games/">Games</a>
<ul class="sub-menu">
	<li id="menu-item-85339" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85339"><a href="https://www.filmfetish.com/prds/board-card-games/">Board Games</a></li>
	<li id="menu-item-85340" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85340"><a href="https://www.filmfetish.com/prds/card-games/">Card Games</a></li>
	<li id="menu-item-85417" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85417"><a href="https://www.filmfetish.com/prds/video-games/">Video Games</a></li>
</ul>
</li>
<li id="menu-item-85341" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85341"><a href="https://www.filmfetish.com/prds/art/">Hit Pictures</a>
<ul class="sub-menu">
	<li id="menu-item-85342" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85342"><a href="https://www.filmfetish.com/prds/art-prints/">Art Prints</a></li>
	<li id="menu-item-85407" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85407"><a href="https://www.filmfetish.com/prds/photo-prints/">Photo Prints</a></li>
</ul>
</li>
<li id="menu-item-85418" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85418"><a href="https://www.filmfetish.com/prds/home-and-bath/">Home &amp; Bath</a>
<ul class="sub-menu">
	<li id="menu-item-85344" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85344"><a href="https://www.filmfetish.com/prds/beach-towels/">Beach Towels</a></li>
	<li id="menu-item-85345" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85345"><a href="https://www.filmfetish.com/prds/body-pillows/">Body Pillows</a></li>
	<li id="menu-item-85346" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85346"><a href="https://www.filmfetish.com/prds/fleece-blankets/">Fleece Blankets</a></li>
	<li id="menu-item-85347" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85347"><a href="https://www.filmfetish.com/prds/mugs-cups/">Mugs &amp; Cups</a></li>
	<li id="menu-item-85413" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85413"><a href="https://www.filmfetish.com/prds/tote-bags/">Tote Bags</a></li>
</ul>
</li>
<li id="menu-item-85348" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85348"><a href="https://www.filmfetish.com/prds/memorabilia/">Memorabilia</a>
<ul class="sub-menu">
	<li id="menu-item-85349" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85349"><a href="https://www.filmfetish.com/prds/film/">Film</a></li>
	<li id="menu-item-85350" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85350"><a href="https://www.filmfetish.com/prds/gaming/">Gaming</a></li>
	<li id="menu-item-85351" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85351"><a href="https://www.filmfetish.com/prds/music-memorabilia/">Music</a></li>
	<li id="menu-item-85404" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85404"><a href="https://www.filmfetish.com/prds/other-memorabilia/">Other</a></li>
	<li id="menu-item-85405" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85405"><a href="https://www.filmfetish.com/prds/signed-memorabilia/">Signed Memorabilia</a></li>
	<li id="menu-item-85406" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85406"><a href="https://www.filmfetish.com/prds/television-memorabilia/">Television</a></li>
</ul>
</li>
<li id="menu-item-85352" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85352"><a href="https://www.filmfetish.com/prds/movies-tv/">Movies &amp; TV</a></li>
<li id="menu-item-85360" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85360"><a href="https://www.filmfetish.com/prds/music-type/">Music &amp; Spoken Word</a>
<ul class="sub-menu">
	<li id="menu-item-85434" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85434"><a href="https://www.filmfetish.com/prds/cd/">CD</a></li>
	<li id="menu-item-85433" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85433"><a href="https://www.filmfetish.com/prds/vinyl/">Vinyl</a></li>
</ul>
</li>
<li id="menu-item-85372" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85372"><a href="https://www.filmfetish.com/prds/postercrush/">Poster Crush</a>
<ul class="sub-menu">
	<li id="menu-item-85369" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85369"><a href="https://www.filmfetish.com/prds/canvas-print/">Canvas Prints</a></li>
	<li id="menu-item-85373" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85373"><a href="https://www.filmfetish.com/prds/posters-vintage-original/">Posters &#8211; Original</a></li>
	<li id="menu-item-85374" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85374"><a href="https://www.filmfetish.com/prds/posters-new/">Posters &#8211; Reprints</a></li>
</ul>
</li>
<li id="menu-item-85377" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85377"><a href="https://www.filmfetish.com/prds/press-advertising-ephemera/">Press Advertising &amp; Ephemera</a>
<ul class="sub-menu">
	<li id="menu-item-85371" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85371"><a href="https://www.filmfetish.com/prds/lobby-cards/">Lobby Cards</a></li>
	<li id="menu-item-85378" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85378"><a href="https://www.filmfetish.com/prds/magazine-newspaper-ads/">Magazine &amp; Newspaper Ads</a></li>
	<li id="menu-item-85379" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85379"><a href="https://www.filmfetish.com/prds/press-kits-books/">Press Kits &amp; Books</a></li>
	<li id="menu-item-85380" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85380"><a href="https://www.filmfetish.com/prds/press-photos/">Press Photos</a></li>
</ul>
</li>
<li id="menu-item-85383" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85383"><a href="https://www.filmfetish.com/prds/stamps/">Stamps</a></li>
<li id="menu-item-85396" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85396"><a href="https://www.filmfetish.com/prds/toys/">Toys &amp; Figures</a>
<ul class="sub-menu">
	<li id="menu-item-85361" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85361"><a href="https://www.filmfetish.com/prds/action-figures/">Action Figures</a></li>
	<li id="menu-item-85397" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85397"><a href="https://www.filmfetish.com/prds/statues/">Statues</a></li>
</ul>
</li>
</ul></div></aside><aside id="nav_menu-13" class="widget widget_nav_menu"><h3 class="widget-title">#FilmFetish #CrushCollectibles</h3><div class="menu-social-media-container"><ul id="menu-social-media" class="menu"><li id="menu-item-48865" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48865"><a title="FilmFetish on Facebook" target="_blank" rel="noopener" href="https://www.facebook.com/filmfetish">facebook.com/filmfetish</a></li>
<li id="menu-item-48866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48866"><a title="FilmFetish on Twitter" target="_blank" rel="noopener" href="http://twitter.com/filmfetish">twitter.com/filmfetish</a></li>
<li id="menu-item-68742" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68742"><a title="Crush Collectibles on Instagram" target="_blank" rel="noopener" href="http://instagram.com/crushcollectibles">instagram.com/crushcollectibles</a></li>
<li id="menu-item-48867" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48867"><a title="FilmFetish on Instagram" target="_blank" rel="noopener" href="http://instagram.com/filmfetish">instagram.com/filmfetish</a></li>
<li id="menu-item-48869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48869"><a title="Get our RSS Feed" target="_blank" rel="noopener" href="http://www.filmfetish.com/feed/">filmfetish.com/feed</a></li>
</ul></div></aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><style type="text/css">
#siteseal,#siteseal img{ box-shadow:none !important; }
</style><span id="siteseal"><script async type="text/javascript" src="https://seal.godaddy.com/getSeal?sealID=rH1l6dk2mtoVz3jYyGon3RFfR7VdpW5gXXKlATaM6kRI0sfrsWYmRCxiSuDt"></script></span></div>
		</aside>	</div><!-- .first -->
	
		<div class="second foot-widgets">
		<aside id="custom_html-2" class="widget_text widget widget_custom_html"><h3 class="widget-title">Quick Links</h3><div class="textwidget custom-html-widget"><ul id="mycc-quicknav" class="menu-item">
<li class="menu-item"><a class="protected" href="https://www.crushcollectibles.com/">Crush Collectibles Home</a></li>
<li class="menu-item"><a class="protected" href="https://www.filmfetish.com/">Film Fetish Home</a></li>
<li class="menu-item"><a class="mycc-inline protected" href="#nav_menu-16">Product Types</a></li>
<li class="menu-item"><a class="protected" href="https://www.filmfetish.com/#nav_menu-18">Find Articles</a></li>
<li class="menu-item"><a class="mycc-inline protected" href="#sotop">Share Page</a></li>
</ul></div></aside><aside id="nav_menu-17" class="widget widget_nav_menu"><h3 class="widget-title">Product Lines</h3><div class="menu-crush-product-lines-container"><ul id="menu-crush-product-lines" class="menu"><li id="menu-item-85419" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85419"><a title="Cinematic Autos" href="https://www.filmfetish.com/sets/cinematic-autos-lines/">Cinematic Autos</a></li>
<li id="menu-item-85420" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85420"><a title="Cinematic Greetings" href="https://www.filmfetish.com/sets/cinematic-greetings/">Cinematic Greetings</a></li>
<li id="menu-item-85421" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85421"><a title="Cult Cinema Icons" href="https://www.filmfetish.com/sets/cult-cinema-icons-lines/">Cult Cinema Icons</a></li>
<li id="menu-item-85422" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85422"><a title="Cult Flavor" href="https://www.filmfetish.com/sets/cult-flavor/">Cult Flavor</a></li>
<li id="menu-item-85430" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85430"><a title="Hit Pictures" href="https://www.filmfetish.com/prds/art/">Hit Pictures</a></li>
<li id="menu-item-85424" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85424"><a title="Pop Culture Quotes" href="https://www.filmfetish.com/sets/pop-culture-quotes/">Pop Culture Quotes</a></li>
<li id="menu-item-85425" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85425"><a title="Pop Fetish" href="https://www.filmfetish.com/sets/pop-fetish-lines/">Pop Fetish</a></li>
<li id="menu-item-85429" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85429"><a title="Poster Crush" href="https://www.filmfetish.com/prds/postercrush/">Poster Crush</a></li>
<li id="menu-item-85426" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85426"><a title="The Museum of Fantastic Art" href="https://www.filmfetish.com/sets/museum-of-fantastic-art/">The Museum of Fantastic Art</a></li>
<li id="menu-item-85427" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85427"><a title="Throwback Space" href="https://www.filmfetish.com/sets/throwback-space/">Throwback Space</a></li>
<li id="menu-item-85428" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85428"><a title="Tie Crush" href="https://www.filmfetish.com/prds/tie-crush/">Tie Crush &#8211; Downright Dapper Neckties</a></li>
</ul></div></aside><aside id="rss-5" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/type/quote/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">PopCultureQuotes.com</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/2021/04/26/86744/'>PopCultureQuotes.com | Quote by George Lucas</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/04/26/86742/'>PopCultureQuotes.com | Quote by Bill Maher</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/04/01/86066/'>PopCultureQuotes.com | Quote by Kevin Conway</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/03/30/86002/'>PopCultureQuotes.com | Quote by James Glickenhaus</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/03/30/86000/'>PopCultureQuotes.com | Quote by James Glickenhaus</a></li></ul></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">About</h3><div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-73871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73871"><a title="Support Film Fetish" href="https://www.filmfetish.com/support/">Support Us</a></li>
<li id="menu-item-37141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37141"><a href="https://www.filmfetish.com/about/">About Us</a></li>
<li id="menu-item-49547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49547"><a href="https://www.filmfetish.com/about/return-policy/">Return Policy</a></li>
<li id="menu-item-49546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49546"><a href="https://www.filmfetish.com/about/shipping-information/">Shipping Information</a></li>
<li id="menu-item-37143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37143"><a href="https://www.filmfetish.com/about/copyright/">Copyright</a></li>
<li id="menu-item-37145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37145"><a href="https://www.filmfetish.com/about/privacy-policy/">Privacy Policy | Terms of Use | Disclaimer</a></li>
<li id="menu-item-49545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49545"><a title="Contact" href="https://www.filmfetish.com/about/contact/">Contact</a></li>
</ul></div></aside>	</div><!-- .second -->
	</div><!-- #secondary -->       
	</div><!-- #primary -->


			<div id="secondary" class="widget-area" role="complementary">    
			<aside id="text-13" class="widget widget_text"><h3 class="widget-title">Related Stories</h3>			<div class="textwidget"><div class="myc-related"><div><a href="https://www.filmfetish.com/2013/04/19/new-trailer-for-the-hunt/" title="New trailer for The Hunt" rel="bookmark"><img style="background-color:#cccccc;" src="https://www.filmfetish.com/wp-content/plugins/concoupons/images/spcr.gif" width="170" height="170" class="related-thumb" alt="New trailer for The Hunt"></a></div><div><a href="https://www.filmfetish.com/2020/12/16/trailer-and-official-poster-for-mind-bending-sci-fi-documentary-a-glitch-in-the-matrix/" title="Trailer and official poster for mind-bending sci-fi documentary A Glitch In The Matrix" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/12/a-glitch-in-the-matrix-sldr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Trailer and official poster for mind-bending sci-fi documentary A Glitch In The Matrix"></a></div><div><a href="https://www.filmfetish.com/2014/03/11/u-s-poster-revealed-for-the-raid-2-plus-director-star-to-discuss-film-at-screening-this-weekend/" title="U.S. poster revealed for The Raid 2, plus director &#038; star to discuss film at advance screening this weekend" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2014/03/the-raid-2-us-movie-poster-images-b-170x170.jpg" width="170" height="170" class="related-thumb" alt="U.S. poster revealed for The Raid 2, plus director &#038; star to discuss film at advance screening this weekend"></a></div><div><a href="https://www.filmfetish.com/2019/02/26/finding-steve-mcqueen-official-trailer/" title="Finding Steve McQueen official trailer" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/02/finding-steve-mcqueen-poster-sldr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Finding Steve McQueen official trailer"></a></div><div><a href="https://www.filmfetish.com/2019/11/08/cult-tastic-tales-from-the-trenches-with-roger-and-julie-corman-extended-trailer/" title="Cult-Tastic: Tales from the Trenches with Roger and Julie Corman extended trailer" rel="bookmark"><img style="background-color:#cccccc;" src="https://www.filmfetish.com/wp-content/plugins/concoupons/images/spcr.gif" width="170" height="170" class="related-thumb" alt="Cult-Tastic: Tales from the Trenches with Roger and Julie Corman extended trailer"></a></div><div><a href="https://www.filmfetish.com/2012/03/29/watch-the-live-stream-from-the-bully-town-hall-right-here/" title="Watch the live stream from the Bully town hall right here" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2012/03/bully-movie-images-170x170.jpg" width="170" height="170" class="related-thumb" alt="Watch the live stream from the Bully town hall right here"></a></div><div><a href="https://www.filmfetish.com/2017/02/14/new-sneak-peek-clip-from-belkoexperiment-a-horror-thriller-from-the-directors-of-wolf-creek-and-guardians-of-the-galaxy/" title="New sneak peek clip from #BelkoExperiment, a horror thriller from the directors of Wolf Creek and Guardians of the Galaxy" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/02/the-belko-experiment-movie-images-sldr-170x170.jpg" width="170" height="170" class="related-thumb" alt="New sneak peek clip from #BelkoExperiment, a horror thriller from the directors of Wolf Creek and Guardians of the Galaxy"></a></div><div><a href="https://www.filmfetish.com/2019/10/21/check-out-the-first-trailer-for-action-comic-adaptation-bloodshot-with-vin-diesel/" title="Check out the first trailer for action comic adaptation #Bloodshot with Vin Diesel" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/10/bloodshot-movie-vin-diesel-sldr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Check out the first trailer for action comic adaptation #Bloodshot with Vin Diesel"></a></div><div><a href="https://www.filmfetish.com/2016/07/19/the-last-wave-1977-trailer/" title="The Last Wave (1977) trailer" rel="bookmark"><img style="background-color:#cccccc;" src="https://www.filmfetish.com/wp-content/plugins/concoupons/images/spcr.gif" width="170" height="170" class="related-thumb" alt="The Last Wave (1977) trailer"></a></div><div><a href="https://www.filmfetish.com/2018/03/25/check-out-the-action-packed-into-the-badlands-season-3-trailer/" title="Check out the action-packed Into the Badlands Season 3 trailer" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/03/into-the-badlands-poster-sldr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Check out the action-packed Into the Badlands Season 3 trailer"></a></div></div>
</div>
		</aside><aside id="rss-12" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/sets/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Crush Collectibles</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/henry-portrait-of-a-serial-killer-original-motion-picture-soundtrack-music-deluxe-vinyl-edition/'>Henry: Portrait of a Serial Killer Original Motion Picture Soundtrack Music Deluxe Vinyl Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/pump-up-the-volume-warner-archive-blu-ray-edition/'>Pump Up The Volume Warner Archive Blu-ray Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/jacobs-ladder-original-motion-picture-soundtrack-special-metallic-silver-vinyl-edition/'>Jacob’s Ladder Original Motion Picture Soundtrack Special Metallic Silver Vinyl Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-world-of-tim-burton-2-disc-limited-vinyl-edition/'>The World of Tim Burton 2-Disc Limited Vinyl Soundtracks Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/daughters-of-darkness-3-disc-limited-edition-4k-uhd-blu-ray-soundtrack-cd/'>Daughters of Darkness 3-Disc Limited Edition 4K UHD + Blu-ray + Soundtrack CD</a></li></ul></aside>
		<aside id="recent-posts-2" class="widget widget_recent_entries">
		<h3 class="widget-title">Latest Articles</h3>
		<ul>
											<li>
					<a href="https://www.filmfetish.com/2021/05/25/marvel-studios-revealed-new-trailer-for-oscar-winner-chloe-zhao-directed-eternals/">Marvel Studios revealed new trailer for Oscar winner Chloé Zhao-directed Eternals</a>
									</li>
											<li>
					<a href="https://www.filmfetish.com/2021/05/25/trailer-for-swedish-horror-the-evil-next-door/" aria-current="page">Trailer for Swedish horror The Evil Next Door</a>
									</li>
											<li>
					<a href="https://www.filmfetish.com/2021/05/25/check-out-the-poster-and-teaser-trailer-for-edgar-wright-psychological-thriller-last-night-in-soho/">Check out the poster and teaser trailer for Edgar Wright psychological thriller Last Night in Soho</a>
									</li>
											<li>
					<a href="https://www.filmfetish.com/2021/05/21/pop-culture-helps-bring-showboat-atlantic-city-back-to-life-with-massive-arcade-sports-bar-and-hollywood-zombie-film-shoot/">Pop culture helps bring Showboat Atlantic City back to life with massive arcade, sports bar and Hollywood zombie film shoot</a>
									</li>
											<li>
					<a href="https://www.filmfetish.com/2021/05/20/tribeca-film-fest-to-premiere-documentary-on-80s-pop-group-a-ha-check-out-the-trailer/">Tribeca Film Fest to premiere documentary on 80&#8217;s pop group A-Ha; check out the trailer</a>
									</li>
					</ul>

		</aside><aside id="nav_menu-18" class="widget widget_nav_menu"><h3 class="widget-title">Find Articles</h3><div class="menu-article-categories-container"><ul id="menu-article-categories" class="menu"><li id="menu-item-85445" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85445"><a href="https://www.filmfetish.com/stry/blvd-warriors/">Blvd Warriors</a></li>
<li id="menu-item-85446" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85446"><a href="https://www.filmfetish.com/stry/book-fetish/">Book Fetish</a></li>
<li id="menu-item-85447" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85447"><a href="https://www.filmfetish.com/stry/cinematic-autos/">Cinematic Autos</a></li>
<li id="menu-item-85448" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85448"><a href="https://www.filmfetish.com/stry/contests/">Contests</a></li>
<li id="menu-item-85449" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-has-children menu-item-85449"><a href="https://www.filmfetish.com/stry/cult-cinema-icons/">Cult Cinema Icons</a>
<ul class="sub-menu">
	<li id="menu-item-85450" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85450"><a href="https://www.filmfetish.com/stry/cult-flavor-trailers/">Cult Flavor Trailers</a></li>
</ul>
</li>
<li id="menu-item-85451" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85451"><a href="https://www.filmfetish.com/stry/events/">Events</a></li>
<li id="menu-item-85452" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85452"><a href="https://www.filmfetish.com/stry/exclusives/">Exclusives</a></li>
<li id="menu-item-85453" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85453"><a href="https://www.filmfetish.com/stry/home-theater/">Home Theater</a></li>
<li id="menu-item-85454" class="menu-item menu-item-type-taxonomy menu-item-object-cstry current-post-ancestor menu-item-has-children menu-item-85454"><a href="https://www.filmfetish.com/stry/imagery/">Imagery</a>
<ul class="sub-menu">
	<li id="menu-item-85455" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85455"><a href="https://www.filmfetish.com/stry/banners/">Banners</a></li>
	<li id="menu-item-85456" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85456"><a href="https://www.filmfetish.com/stry/film-fetish-foto/">Film Fetish Foto</a></li>
	<li id="menu-item-85457" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85457"><a href="https://www.filmfetish.com/stry/motion-posters/">Motion Posters</a></li>
	<li id="menu-item-85458" class="menu-item menu-item-type-taxonomy menu-item-object-cstry current-post-ancestor current-menu-parent current-post-parent menu-item-85458"><a href="https://www.filmfetish.com/stry/movie-tv-posters/">Posters</a></li>
	<li id="menu-item-85459" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85459"><a href="https://www.filmfetish.com/stry/still-photos/">Still Images</a></li>
</ul>
</li>
<li id="menu-item-85460" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85460"><a href="https://www.filmfetish.com/stry/news/">News</a></li>
<li id="menu-item-85461" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85461"><a href="https://www.filmfetish.com/stry/play-games/">Play Games</a></li>
<li id="menu-item-85462" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85462"><a href="https://www.filmfetish.com/stry/pop-fetish/">Pop Fetish</a></li>
<li id="menu-item-85463" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85463"><a href="https://www.filmfetish.com/stry/film-resources/">Resources</a></li>
<li id="menu-item-85464" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85464"><a href="https://www.filmfetish.com/stry/reviews/">Reviews</a></li>
<li id="menu-item-85465" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85465"><a href="https://www.filmfetish.com/stry/snapshots/">Snapshots</a></li>
<li id="menu-item-85467" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85467"><a href="https://www.filmfetish.com/stry/new-frontier/">The New Frontier</a></li>
<li id="menu-item-85468" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85468"><a href="https://www.filmfetish.com/stry/tv-fetish/">TV Fetish</a></li>
<li id="menu-item-85469" class="menu-item menu-item-type-taxonomy menu-item-object-cstry current-post-ancestor menu-item-has-children menu-item-85469"><a href="https://www.filmfetish.com/stry/video/">Video</a>
<ul class="sub-menu">
	<li id="menu-item-85470" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85470"><a href="https://www.filmfetish.com/stry/clips-and-scenes/">Clips and Scenes</a></li>
	<li id="menu-item-85471" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85471"><a href="https://www.filmfetish.com/stry/red-band-trailers/">Red Band Trailers</a></li>
	<li id="menu-item-85472" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85472"><a href="https://www.filmfetish.com/stry/short-films/">Short Films</a></li>
	<li id="menu-item-85473" class="menu-item menu-item-type-taxonomy menu-item-object-cstry current-post-ancestor current-menu-parent current-post-parent menu-item-85473"><a href="https://www.filmfetish.com/stry/trailers/">Trailers</a></li>
	<li id="menu-item-85474" class="menu-item menu-item-type-taxonomy menu-item-object-cstry menu-item-85474"><a href="https://www.filmfetish.com/stry/web-series/">Web Series</a></li>
</ul>
</li>
</ul></div></aside>		</div><!-- #secondary -->
		</div><!-- #main .wrapper -->
	<footer id="colophon" role="contentinfo">
		<div class="site-info">
					&copy; 2021 FilmFetish.com | Film Fetish and the Crush Collectibles Shop | <a href="http://hitpi.cc/mtheaterfooterurl/" title="M Theater Wordpress Theme created by Rene Carson from HIT PICTURES" target="_blank"> Website Design: HIT PICTURES</a> <span class="logshow off"><a href="https://www.filmfetish.com/wp-login.php">Log in</a></span></div><!-- .site-info -->
	</footer><!-- #colophon -->

<div id="gotop"><a href="#top"><span></span></a></div>
</div><!-- #page -->

<!-- Custom Feeds for Instagram JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.filmfetish.com/wp-admin/admin-ajax.php";

</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.widowbuster.js' id='widbuster-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids.js' id='fitvids-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids-ld.js' id='fitvids-ld-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.colorbox.js' id='colorbox-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.topspring.js' id='topspring-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/nav.js' id='mthe-nav-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.7.2' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/mediaelement-ld.js' id='mediaelement-ld-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.js?ver=1.0' id='mycccal-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
   
<script>		
jQuery(window).load(function($) {	
	jQuery('a[href$=".jpg"],a[href$=".jpeg"],a[href$=".png"],a[href$=".gif"]').colorbox({rel:'gal',maxHeight:'100%',speed:700,fadeOut:600,initialWidth:false,maxWidth:'100%',initialHeight:false,slideshow:true,slideshowAuto:false,slideshowSpeed:6000,slideshowStart:'slideshow',slideshowStop:'stop',transition:'fade'});
	jQuery('.mycc-ajax').colorbox();
	jQuery('.mycc-inline').colorbox({inline:true,speed:700,fadeOut:600,width:'100%',height:'100%',transition:'fade'});
});
</script>
	<script>
jQuery(window).load(function($){
var d = new Date();
var n = d.getMonth() + 1;
var yr = d.getFullYear();
var design_month_covers = ['https://www.filmfetish.com/img/p/2016/07/calimg160718-body-double-melanie-griffith-craig-wasson.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-elton-john-diana-ross-cher-awards-show-1980s.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-bridget-fonda-robert-deniro-samuel-l-jackson-in-jackie-brown.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-janet-leigh.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-vincent-donofrio-martin-sensmeier-manuel-garciarulfo-ethan-hawke-denzel-washington-chris-pratt-byunghunlee-magnificent-seven.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-five-easy-pieces-loews-holly-theater-hollywood-blvd.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-linda-lovelace-deep-throat-porn-icon.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-le-mans-playing-loews-state-times-square-new-york-city-1971.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-rebecca-ferguson-mission-impossible-rogue-nation-2015.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-lauren-cohan-the-boy-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-yoo-gong-in-train-to-busan-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-dane-dehaan-valerian-city-thousand-planets-2017.jpg'];
dzscal_init("#tr1",{
design_month_covers : design_month_covers,
start_month: n,
	start_year: yr
});
});
</script>
<!-- Start of StatCounter Code for Default Guide -->
<script type="text/javascript">
var sc_project=6854008; 
var sc_invisible=1; 
var sc_security="5609cdda"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="shopify
analytics ecommerce" href="http://statcounter.com/shopify/"
target="_blank"><img class="statcounter"
src="//c.statcounter.com/6854008/0/5609cdda/1/" alt="shopify
analytics ecommerce"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->
</body>
</html>