<!DOCTYPE html>
<!-- Get M Theater WordPress Theme at BY HAND Media (http://www.byhandmedia.net/mtheater) -->
<!--[if IE 7 | IE 8]>
<html class="ie" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998) |  FilmFetish.com | Film Fetish and the Crush Collectibles Shop </title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.filmfetish.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://www.filmfetish.com/wp-content/themes/m-theater/js/html5.js" type="text/javascript"></script>
<![endif]-->

<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop &raquo; Feed" href="https://www.filmfetish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop &raquo; Comments Feed" href="https://www.filmfetish.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.filmfetish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sbi_styles-css'  href='https://www.filmfetish.com/wp-content/plugins/instagram-feed-pro/css/sbi-styles.min.css?ver=5.12.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.filmfetish.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-style-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/style.css?ver=5.8' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelementcss-css'  href='https://www.filmfetish.com/wp-includes//js/mediaelement/mediaelementplayer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='naranja-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/theme-color-naranja.css' type='text/css' media='all' />
<link rel='stylesheet' id='mycccaltltpcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzstooltip/dzstooltip.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccuscalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-cal-cus.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccartcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-shopcart.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='myccmaincss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-mycc.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js?ver=2.1.4' id='jquery-js'></script>
<link rel="https://api.w.org/" href="https://www.filmfetish.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.filmfetish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.filmfetish.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8" />
<link rel="canonical" href="https://www.filmfetish.com/ffmkt/official-sony-playstation-1-ps1-console-complete-with-controller/" />
<link rel='shortlink' href='https://www.filmfetish.com/?p=88469' />
<link rel="alternate" type="application/json+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;format=xml" />
<link rel="image_src" href="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00001.jpg" />
<meta name="web_author" content="Web Site Development: HitPictures.tech" />
<meta name="wp_theme_name" content="M Theater" />
<link rel="wp_theme_address" href="http://hitpictures.tech/mtheater/" />
<meta name="copyright" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
<meta name="googlebot" content="noodp" />
<meta name="robots" content="noodp" />
<meta name="no-email-collection" content="No spam harvesting allowed" />
<meta name="dc.source" content="https://www.filmfetish.com/ffmkt/official-sony-playstation-1-ps1-console-complete-with-controller/" />
<meta name="dc.publisher" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
<meta name="dc.date" content="2021-08-22T19:54:03-04:00" />
<meta name="dc.title" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" />
<meta name="dc.creator" content="René Carson" />
<meta name="description" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)-Official Sony PlayStation 1 PS1 Console Complete with Controller.  Item has some wear from storage. Has not been tested. Please review" />
<meta name="keywords" content="action,adventure,fantasy,game/video game,science fiction,video games," />
<meta name="author" content="René Carson" />
<meta name="abstract" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" />
<meta property="og:title" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" />
<meta itemprop="name" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" />
<meta name="twitter:title" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" />
<meta property="og:type" content="article" />
<meta property="article:published_time" content="2021-08-22T19:54:03-04:00" />
<meta property="article:modified_time" content="2021-08-22T20:01:37-04:00" />
<meta property="og:description" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)-Official Sony PlayStation 1 PS1 Console Complete with Controller.  Item has some wear from storage. Has not been tested. Please review" />
<meta name="twitter:description" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)-Official Sony PlayStation 1 PS1 Console Complete with Controller.  Item has some wear from storage. Has not been tested. Please review" />
<meta itemprop="description" content="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)-Official Sony PlayStation 1 PS1 Console Complete with Controller.  Item has some wear from storage. Has not been tested. Please review" />
<meta itemprop="image" content="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00001.jpg" />
<meta name="twitter:card" content="summary" />
<meta property="og:url" content="https://www.filmfetish.com/ffmkt/official-sony-playstation-1-ps1-console-complete-with-controller/" />
<meta property="og:image" content="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00001.jpg" />
<meta property="og:site_name" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px);
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<!-- M Theater Custom CSS -->
<style type="text/css" media="screen" id="mtheater-custom-styles">
@import url("//cdn-images.mailchimp.com/embedcode/classic-10_7.css");

@import url("//www.filmfetish.com/wp-content/fetish-styles.css");

@import url("//i.hit.pictures/css/network-shops.css");
</style><!-- End Custom CSS -->

<link rel="shortcut icon" href="https://hit.pics/favicon.ico" />
<style type="text/css" media="screen" id="mtheater-custom-plugin-styles">
/* Custom M Theater CSS */
.archive-txt { display: none; }
/* Mailchimp */
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
/* Plugin */
p.bhmspamkill, textarea#bhm_nonviewable { display:none;position:absolute;left:-9000px; }
/* ie */
.ie #bhmmainpg .bhmmainlogobx .bhmmaintxt { width: 46%; float: left; }
.ie #bhmmainpg .bhmmainlogobx { width: 43%; padding: 2%; float: left; min-height: 320px; min-height: 22.857142857rem; }
.ie #bhmmainpg .bhmmainlogobx.right { float: right; }
</style></head>

<body id="top" class="ffmktcrt-template-default single single-ffmktcrt postid-88469 fffmsingle httpswwwfilmfetishcom custom-background-empty custom-font-enabled nav-nobanner style-fnt-hdr-sz-a style-fnt-hdr-styl-a style-fnt-ttl-styl-a style-fnt-bod-styl-a">

<div id="page" class="hfeed site">
	<header id="masthead" class="site-header" role="banner">
		<hgroup class="title-background">
			<h1 class="site-title"><a href="https://www.filmfetish.com/" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" rel="home">FilmFetish.com | Film Fetish and the Crush Collectibles Shop</a></h1>
			<h2 class="site-description">Cool Movies, TV, Music and Sports</h2>
		</hgroup>


<nav id="site-navigation" class="main-navigation-fet" role="navigation">
	<div class="skip-link assistive-text"><a href="#content" title="Skip to content">Skip to content</a></div>
	<div class="menu-market-top-nav-container"><ul id="menu-market-top-nav" class="nav-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom"><a class="mycc-inline" href="#nav_menu-16">Menu</a></li><li class="mbtn"><div class="mycc-viewcart"><form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post"><input type="hidden" name="business" value="sitepay@crushcollectibles.com"><input type="hidden" name="cmd" value="_cart"><input type="hidden" name="display" value="1"><input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/official-sony-playstation-1-ps1-console-complete-with-controller"><input type="image" name="submit" src="https://www.filmfetish.com/wp-content/plugins/concoupons/images/spcr22.gif" alt="View Cart" title="View Cart"><img alt="" width="1" height="1" src="https://www.filmfetish.com/wp-content/plugins/concoupons/images/spcr.gif"><input type="hidden" name="cpp_logo_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_checkout_logo161114.gif"><input type="hidden" name="page_style" value="film_fetish"></form></div></li><li><form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Try A Crush Search!"><select name="post_type" style="display: none;"><option value="ffmktcrt">ffmktcrt</option></select></form></li></ul></div></nav>
        


<div id="search-social">



<div id="searchmain" class="searchwrap"><div class="respo"><a href="https://www.crushcollectibles.com/" title="Crush Collectibles"><img class="cc logo-img  arc" src="https://www.filmfetish.com/wp-content/special-imgs/crush-collectibles.svg" alt="CRUSHCOLLECTIBLES.COM" /></a><img class="ffrl logo-img" src="https://www.filmfetish.com/wp-content/special-imgs/film-fetish-reel.svg" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="Film Fetish Home"><img class="ff logo-img  live" src="https://www.filmfetish.com/wp-content/special-imgs/film-fetish.svg" alt="FILMFETISH.COM" /></a></div></div>




</div><!-- #search-social -->
	</header><!-- #masthead -->

	<div id="main" class="wrapper">  	<div id="primary" class="site-content">
		<div id="content" role="main">

			
				
	<article id="post-88469" class="solo post-88469 ffmktcrt type-ffmktcrt status-publish hentry cgenr-action cgenr-adventure cgenr-fantasy-films cgenr-game-video-game cgenr-sci-fi-films cprds-video-games less-three">
    <div id="social-nav-top"><a class="mycc-inline protected" href="#sotop">Share Page</a> <a class="protected" href="https://www.filmfetish.com/support/">Support Us</a>
<div style="display:none;"><div id="sotop"> <div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2021%2F08%2Fplaystation-u97-00001.jpg&#038;description=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D88469" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;title=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;title=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;name=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;n=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;t=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=88469"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=88469"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	 </div></div>
<div id="socplus-right"><nav class="nav-single-top">
					<h3 class="assistive-text">Previous page navigation</h3>
									</nav><!-- #socplus-right -->
                </div><!-- .nav-single-top -->
		</div><!-- #social-nav-top -->

		<header class="entry-header">
			
                       
            <h1 class="entry-title myc-center ">Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)</h1>
		</header><!-- .entry-header -->

		<div class="entry-content">
		<div class="myc-prod-wrapper"><div class="myc-prod-wrapper-left">
<figure class="cart-image"><a href="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00001.jpg" title="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00001-210x158.jpg" width="210" height="158" class="cart-thumb" alt="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)"><div class="myc-caption">View larger</div></a></figure>

<div class="myc-related gal"><div><a href="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00001.jpg" title="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00001-170x170.jpg" width="170" height="170" class="related-thumb" alt="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)"></a></div><div><a href="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00002.jpg" title="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/08/playstation-u97-00002-170x170.jpg" width="170" height="170" class="related-thumb" alt="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)"></a></div><div><a href="https://www.filmfetish.com/img/p/2021/08/playstation-serial-no-825x1100.jpg" title="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/08/playstation-serial-no-170x170.jpg" width="170" height="170" class="related-thumb" alt="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)"></a></div></div></div><div class="myc-prod-wrapper-right">
<div class="mycc-addtocart">
<div class="myc-price">
<div><span>$69.99 </span><br/>$45.97</div>
<div class="txtright"><a class="mycc-inline protected" href="#crtopts">See Options</a></div>
</div>
<form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post">

	<input type="hidden" name="business" value="sitepay@crushcollectibles.com">
	<input type="hidden" name="cmd" value="_cart">  
	<input type="hidden" name="item_name" value="Official Sony PlayStation 1 PS1 Console Complete with Controller (Oct 1998)">
	<input type="hidden" name="item_number" value="210823-88469">
	<input type="hidden" name="add" value="1">
	<input type="hidden" name="currency_code" value="USD">

  	<input type="hidden" name="page_style" value="film_fetish">

	<input type="hidden" name="image_url" value="https://www.filmfetish.com/img/p/2016/11/paypal_150x50_161122.gif">

	<input type="hidden" name="cpp_header_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_banner161114.jpg">
  
  <input type="hidden" name="paymentaction" value="sale">
  


<div class="myc-output">


<table>
	<tr>
		<td><select name="quantity">
        <option value="1">- Select Qty -</option>
		<option value="1">1</option>		</select> <br/>1 in stock		</td>
	</tr>
</table>

<div><strong>cns</strong><br/>SKU: 210822-88469-1<br/>Part No: SCPH-7501<br/>Weight: 8.15 lbs<br/>Condition: VF Very Fine - This item is used. See Details section and photos for specifics on item condition.</div> 
</div><!-- .output -->
	<input type="hidden" name="weight" value="8.15" id="mycweight">
	<input type="hidden" name="weight_unit" value="lbs">


    	<input type="hidden" name="amount" value="45.97">

		














  
    
    
        
  	    <input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/official-sony-playstation-1-ps1-console-complete-with-controller/">
    
	    <input type="hidden" name="return" value="https://www.filmfetish.com/transaction-complete/">
        
        <input type="hidden" name="cbt" value="Continue Shopping">
        
    	<input type="hidden" name="cancel_return" value="https://www.filmfetish.com/market/">
    
        <input type="hidden" name="no_shipping" value="2">
    
        <input type="hidden" name="no_note" value="0">
    <input type="hidden" name="cn" value="Add special instructions:">
    
    <br/><input type="image" name="submit" src="https://www.paypalobjects.com/webstatic/en_US/i/btn/png/btn_addtocart_120x26.png" alt="Add to Cart">
  <img alt="" width="1" height="1" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif">

</form>
</div>	

</div></div><div><ul class="mid-wrap"><li>Product Types: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/prds/games/">Games</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/prds/video-games/">Video Games</a></strong></li><li>Genres: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/genr/action/?mcrterm=y">Action</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/genr/adventure/?mcrterm=y">Adventure</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/genr/fantasy-films/?mcrterm=y">Fantasy</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/genr/game-video-game/?mcrterm=y">Game/Video Game</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/genr/sci-fi-films/?mcrterm=y">Science Fiction</a></strong></li></ul></div><p>Official Sony PlayStation 1 PS1 Console Complete with Controller.</p>
<p>Item has some wear from storage. Has not been tested. Please review listing images for condition details.</p>
<h2 class="myc-center low">Specifications</h2><ul class="mycc-features"><li><span class="featleft">Material: </span><span class="featright">Plastic, Metal, Wires</span></li></ul><div class="explore-more"><span>Explore More...</span><br/><ul><li>Genres: <a href="https://www.filmfetish.com/genr/action/">Action</a> | <a href="https://www.filmfetish.com/genr/adventure/">Adventure</a> | <a href="https://www.filmfetish.com/genr/fantasy-films/">Fantasy</a> | <a href="https://www.filmfetish.com/genr/game-video-game/">Game/Video Game</a> | <a href="https://www.filmfetish.com/genr/sci-fi-films/">Science Fiction</a></li><li>Product Types: <a href="https://www.filmfetish.com/prds/games/">Games</a> > <a href="https://www.filmfetish.com/prds/video-games/">Video Games</a></li></ul></div><h2 class="myc-center low">Related Items</h2><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/burger-king-pokemon-23k-gold-card-charizard-06-pokeball-1999-1140/" title="Burger King Pokemon 23K Gold Card Charizard #06 Pokeball (1999) [1140]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/12/pokemon-gold-card-1140-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Burger King Pokemon 23K Gold Card Charizard #06 Pokeball (1999) [1140]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/reckoning-kingdoms-of-amalur-ps3-playstation-3-todd-mcfarlane-signed-36x24-inch-game-poster-2012-d06/" title="Reckoning Kingdoms of Amalur PS3 PlayStation 3 Todd McFarlane-Signed 36&#215;24 inch Game Poster (2012) [D06]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/11/reckoning-poster-d06-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Reckoning Kingdoms of Amalur PS3 PlayStation 3 Todd McFarlane-Signed 36&#215;24 inch Game Poster (2012) [D06]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-matrix-original-motion-picture-soundtrack-score-picture-disc-vinyl-edition/" title="The Matrix Original Motion Picture Soundtrack Score Picture Disc Vinyl Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/12/the-matrix-picture-vinyl-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Matrix Original Motion Picture Soundtrack Score Picture Disc Vinyl Edition"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-amazing-spider-man-2-amc-exclusive-13x19-inch-movie-poster-2014-d92/" title="The Amazing Spider-Man 2 AMC Exclusive 13&#215;19 inch Movie Poster (2014) [D92]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/11/amazing-spider-man-2-poster-d92-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Amazing Spider-Man 2 AMC Exclusive 13&#215;19 inch Movie Poster (2014) [D92]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/hallmark-keepsake-ornament-tonka-truck-mighty-front-loader-1997/" title="Hallmark Keepsake Ornament &#8211; Tonka Truck Mighty Front Loader (1997)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/11/ornament-tonka-truck-06-170x170.jpg" width="170" height="170" class="related-thumb" alt="Hallmark Keepsake Ornament &#8211; Tonka Truck Mighty Front Loader (1997)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/foxy-brown-original-soundtrack-album-vinyl-edition-willie-hutch/" title="Foxy Brown Original Soundtrack Album Vinyl Edition Willie Hutch" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/01/foxy-brown-soundtrack-vinyl-170x170.jpg" width="170" height="170" class="related-thumb" alt="Foxy Brown Original Soundtrack Album Vinyl Edition Willie Hutch"></a></div><div><a href="https://www.filmfetish.com/ffmkt/werner-herzogs-cobra-verde-original-soundtrack-by-popol-vuh-including-unreleased-bonus-tracks/" title="Werner Herzog&#8217;s Cobra Verde Original Soundtrack by Popol Vuh Including Unreleased Bonus Tracks" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/09/cobra-verde-soundtrack-popol-vuh-b-170x170.jpg" width="170" height="170" class="related-thumb" alt="Werner Herzog&#8217;s Cobra Verde Original Soundtrack by Popol Vuh Including Unreleased Bonus Tracks"></a></div><div><a href="https://www.filmfetish.com/ffmkt/ddr-max-2-dance-dance-revolution-playstation-2-konami-with-manual-slus-20711/" title="DDR Max 2 Dance Dance Revolution PlayStation 2 Konami with Manual [SLUS-20711]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/10/dance-dance-revolution-2-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="DDR Max 2 Dance Dance Revolution PlayStation 2 Konami with Manual [SLUS-20711]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/mel-gibson-the-patriot-special-edition-dvd-2000/" title="Mel Gibson The Patriot Special Edition DVD (2000)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/01/patriot-dvd-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Mel Gibson The Patriot Special Edition DVD (2000)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/wonder-woman-spirit-of-truth-by-paul-dini-and-alex-ross-oversized-edition/" title="Wonder Woman: Spirit of Truth by Paul Dini and Alex Ross &#8211; Oversized Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/02/wonder-woman01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Wonder Woman: Spirit of Truth by Paul Dini and Alex Ross &#8211; Oversized Edition"></a></div></div><div style="display:none;"><div id="crtopts" class="spec-wrap new"><div class="each"><span class="mycc-details">cns</span>SKU: 210822-88469-1<br/>Part No: SCPH-7501<br/>Weight: 8.15 lbs<br/>Condition: VF Very Fine - This item is used. See Details section and photos for specifics on item condition.</div></div></div>
		</div><!-- .entry-content -->
		<div class="share-meta">
        <div class="shareline">#</div>
        <div class="bkmrk-bottom"><div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2021%2F08%2Fplaystation-u97-00001.jpg&#038;description=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D88469" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;title=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;title=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;name=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;n=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fofficial-sony-playstation-1-ps1-console-complete-with-controller%2F&#038;t=Official%20Sony%20PlayStation%201%20PS1%20Console%20Complete%20with%20Controller%20%28Oct%201998%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=88469"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=88469"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	</div> 
<p class="cntr">Page Link<br />
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/ffmkt/official-sony-playstation-1-ps1-console-complete-with-controller/' /><br/>
Short Link<br/>
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/?p=88469' /></p>
<div class="shareline">#</div>
        </div><!-- .share-meta -->

		<footer class="entry-meta">
					</footer>
	</article><!-- #post -->

			
			
		</div><!-- #content -->
 		
<div id="secondary-2" class="widget-area-footer" role="complementary">
		<div class="first foot-widgets">
		<aside id="nav_menu-16" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-product-types-container"><ul id="menu-product-types" class="menu"><li id="menu-item-85322" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85322"><a href="https://www.filmfetish.com/prds/apparel-accessories/">Apparel &amp; Accessories</a>
<ul class="sub-menu">
	<li id="menu-item-85323" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85323"><a href="https://www.filmfetish.com/prds/bandanas/">Bandanas</a></li>
	<li id="menu-item-85324" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85324"><a href="https://www.filmfetish.com/prds/clothing-accessories/">Clothing Accessories</a></li>
	<li id="menu-item-85325" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85325"><a href="https://www.filmfetish.com/prds/hat/">Hat</a></li>
	<li id="menu-item-85326" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85326"><a href="https://www.filmfetish.com/prds/jewelry/">Jewelry</a></li>
	<li id="menu-item-85408" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85408"><a href="https://www.filmfetish.com/prds/pullovers-hoodies/">Pullovers &amp; Hoodies</a></li>
	<li id="menu-item-85409" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85409"><a href="https://www.filmfetish.com/prds/t-shirts-full-cover-print/">T-Shirts &#8211; All Over Print</a></li>
	<li id="menu-item-85410" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85410"><a href="https://www.filmfetish.com/prds/t-shirts-long-sleeve/">T-Shirts &#8211; Long Sleeve</a></li>
	<li id="menu-item-85411" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85411"><a href="https://www.filmfetish.com/prds/t-shirts-short-sleeve/">T-Shirts &#8211; Short Sleeve</a></li>
	<li id="menu-item-85386" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85386"><a href="https://www.filmfetish.com/prds/tie-crush/">Tie Crush &#8211; Downright Dapper Neckties</a></li>
</ul>
</li>
<li id="menu-item-85328" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85328"><a href="https://www.filmfetish.com/prds/books/">Books</a>
<ul class="sub-menu">
	<li id="menu-item-85329" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85329"><a href="https://www.filmfetish.com/prds/calendars/">Calendars</a></li>
	<li id="menu-item-85330" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85330"><a href="https://www.filmfetish.com/prds/comics/">Comics</a></li>
	<li id="menu-item-85331" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85331"><a href="https://www.filmfetish.com/prds/graphic-novels/">Graphic Novels</a></li>
	<li id="menu-item-85332" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85332"><a href="https://www.filmfetish.com/prds/hardcover-books/">Hardcover Books</a></li>
	<li id="menu-item-85333" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85333"><a href="https://www.filmfetish.com/prds/magazines-newspapers/">Magazines &amp; Newspapers</a></li>
	<li id="menu-item-85412" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85412"><a href="https://www.filmfetish.com/prds/softcover-books/">Softcover Books</a></li>
</ul>
</li>
<li id="menu-item-85334" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85334"><a href="https://www.filmfetish.com/prds/equipment/">Equipment</a></li>
<li id="menu-item-85336" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85336"><a href="https://www.filmfetish.com/prds/food-items/">Food Items</a></li>
<li id="menu-item-85338" class="menu-item menu-item-type-taxonomy menu-item-object-cprds current-ffmktcrt-ancestor menu-item-has-children menu-item-85338"><a href="https://www.filmfetish.com/prds/games/">Games</a>
<ul class="sub-menu">
	<li id="menu-item-85339" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85339"><a href="https://www.filmfetish.com/prds/board-card-games/">Board Games</a></li>
	<li id="menu-item-85340" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85340"><a href="https://www.filmfetish.com/prds/card-games/">Card Games</a></li>
	<li id="menu-item-85417" class="menu-item menu-item-type-taxonomy menu-item-object-cprds current-ffmktcrt-ancestor current-menu-parent current-ffmktcrt-parent menu-item-85417"><a href="https://www.filmfetish.com/prds/video-games/">Video Games</a></li>
</ul>
</li>
<li id="menu-item-85341" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85341"><a href="https://www.filmfetish.com/prds/art/">Hit Pictures</a>
<ul class="sub-menu">
	<li id="menu-item-85342" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85342"><a href="https://www.filmfetish.com/prds/art-prints/">Art Prints</a></li>
	<li id="menu-item-85407" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85407"><a href="https://www.filmfetish.com/prds/photo-prints/">Photo Prints</a></li>
</ul>
</li>
<li id="menu-item-85418" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85418"><a href="https://www.filmfetish.com/prds/home-and-bath/">Home &amp; Bath</a>
<ul class="sub-menu">
	<li id="menu-item-85344" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85344"><a href="https://www.filmfetish.com/prds/beach-towels/">Beach Towels</a></li>
	<li id="menu-item-85345" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85345"><a href="https://www.filmfetish.com/prds/body-pillows/">Body Pillows</a></li>
	<li id="menu-item-85346" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85346"><a href="https://www.filmfetish.com/prds/fleece-blankets/">Fleece Blankets</a></li>
	<li id="menu-item-85347" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85347"><a href="https://www.filmfetish.com/prds/mugs-cups/">Mugs &amp; Cups</a></li>
	<li id="menu-item-85413" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85413"><a href="https://www.filmfetish.com/prds/tote-bags/">Tote Bags</a></li>
</ul>
</li>
<li id="menu-item-85348" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85348"><a href="https://www.filmfetish.com/prds/memorabilia/">Memorabilia</a>
<ul class="sub-menu">
	<li id="menu-item-85349" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85349"><a href="https://www.filmfetish.com/prds/film/">Film</a></li>
	<li id="menu-item-85350" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85350"><a href="https://www.filmfetish.com/prds/gaming/">Gaming</a></li>
	<li id="menu-item-85351" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85351"><a href="https://www.filmfetish.com/prds/music-memorabilia/">Music</a></li>
	<li id="menu-item-85404" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85404"><a href="https://www.filmfetish.com/prds/other-memorabilia/">Other</a></li>
	<li id="menu-item-85405" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85405"><a href="https://www.filmfetish.com/prds/signed-memorabilia/">Signed Memorabilia</a></li>
	<li id="menu-item-85406" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85406"><a href="https://www.filmfetish.com/prds/television-memorabilia/">Television</a></li>
</ul>
</li>
<li id="menu-item-85352" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85352"><a href="https://www.filmfetish.com/prds/movies-tv/">Movies &amp; TV</a></li>
<li id="menu-item-85360" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85360"><a href="https://www.filmfetish.com/prds/music-type/">Music &amp; Spoken Word</a>
<ul class="sub-menu">
	<li id="menu-item-85434" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85434"><a href="https://www.filmfetish.com/prds/cd/">CD</a></li>
	<li id="menu-item-85433" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85433"><a href="https://www.filmfetish.com/prds/vinyl/">Vinyl</a></li>
</ul>
</li>
<li id="menu-item-85372" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85372"><a href="https://www.filmfetish.com/prds/postercrush/">Poster Crush</a>
<ul class="sub-menu">
	<li id="menu-item-85369" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85369"><a href="https://www.filmfetish.com/prds/canvas-print/">Canvas Prints</a></li>
	<li id="menu-item-85373" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85373"><a href="https://www.filmfetish.com/prds/posters-vintage-original/">Posters &#8211; Original</a></li>
	<li id="menu-item-85374" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85374"><a href="https://www.filmfetish.com/prds/posters-new/">Posters &#8211; Reprints</a></li>
</ul>
</li>
<li id="menu-item-85377" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85377"><a href="https://www.filmfetish.com/prds/press-advertising-ephemera/">Press Advertising &amp; Ephemera</a>
<ul class="sub-menu">
	<li id="menu-item-85371" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85371"><a href="https://www.filmfetish.com/prds/lobby-cards/">Lobby Cards</a></li>
	<li id="menu-item-85378" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85378"><a href="https://www.filmfetish.com/prds/magazine-newspaper-ads/">Magazine &amp; Newspaper Ads</a></li>
	<li id="menu-item-85379" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85379"><a href="https://www.filmfetish.com/prds/press-kits-books/">Press Kits &amp; Books</a></li>
	<li id="menu-item-85380" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85380"><a href="https://www.filmfetish.com/prds/press-photos/">Press Photos</a></li>
</ul>
</li>
<li id="menu-item-85383" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85383"><a href="https://www.filmfetish.com/prds/stamps/">Stamps</a></li>
<li id="menu-item-85396" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-has-children menu-item-85396"><a href="https://www.filmfetish.com/prds/toys/">Toys &amp; Figures</a>
<ul class="sub-menu">
	<li id="menu-item-85361" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85361"><a href="https://www.filmfetish.com/prds/action-figures/">Action Figures</a></li>
	<li id="menu-item-85397" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85397"><a href="https://www.filmfetish.com/prds/statues/">Statues</a></li>
</ul>
</li>
</ul></div></aside><aside id="nav_menu-13" class="widget widget_nav_menu"><h3 class="widget-title">#FilmFetish #CrushCollectibles</h3><div class="menu-social-media-container"><ul id="menu-social-media" class="menu"><li id="menu-item-48865" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48865"><a title="FilmFetish on Facebook" target="_blank" rel="noopener" href="https://www.facebook.com/filmfetish">facebook.com/filmfetish</a></li>
<li id="menu-item-48866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48866"><a title="FilmFetish on Twitter" target="_blank" rel="noopener" href="http://twitter.com/filmfetish">twitter.com/filmfetish</a></li>
<li id="menu-item-68742" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68742"><a title="Crush Collectibles on Instagram" target="_blank" rel="noopener" href="http://instagram.com/crushcollectibles">instagram.com/crushcollectibles</a></li>
<li id="menu-item-48867" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48867"><a title="FilmFetish on Instagram" target="_blank" rel="noopener" href="http://instagram.com/filmfetish">instagram.com/filmfetish</a></li>
<li id="menu-item-48869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48869"><a title="Get our RSS Feed" target="_blank" rel="noopener" href="http://www.filmfetish.com/feed/">filmfetish.com/feed</a></li>
</ul></div></aside><aside id="text-10" class="widget widget_text">			<div class="textwidget"><style type="text/css">
#siteseal,#siteseal img{ box-shadow:none !important; }
</style><span id="siteseal"><script async type="text/javascript" src="https://seal.godaddy.com/getSeal?sealID=rH1l6dk2mtoVz3jYyGon3RFfR7VdpW5gXXKlATaM6kRI0sfrsWYmRCxiSuDt"></script></span></div>
		</aside>	</div><!-- .first -->
	
		<div class="second foot-widgets">
		<aside id="custom_html-2" class="widget_text widget widget_custom_html"><h3 class="widget-title">Quick Links</h3><div class="textwidget custom-html-widget"><ul id="mycc-quicknav" class="menu-item">
<li class="menu-item"><a class="protected" href="https://www.crushcollectibles.com/">Crush Collectibles Home</a></li>
<li class="menu-item"><a class="protected" href="https://www.filmfetish.com/">Film Fetish Home</a></li>
<li class="menu-item"><a class="mycc-inline protected" href="#nav_menu-16">Product Types</a></li>
<li class="menu-item"><a class="protected" href="https://www.filmfetish.com/#nav_menu-18">Find Articles</a></li>
<li class="menu-item"><a class="mycc-inline protected" href="#sotop">Share Page</a></li>
</ul></div></aside><aside id="nav_menu-17" class="widget widget_nav_menu"><h3 class="widget-title">Product Lines</h3><div class="menu-crush-product-lines-container"><ul id="menu-crush-product-lines" class="menu"><li id="menu-item-85419" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85419"><a title="Cinematic Autos" href="https://www.filmfetish.com/sets/cinematic-autos-lines/">Cinematic Autos</a></li>
<li id="menu-item-85420" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85420"><a title="Cinematic Greetings" href="https://www.filmfetish.com/sets/cinematic-greetings/">Cinematic Greetings</a></li>
<li id="menu-item-85421" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85421"><a title="Cult Cinema Icons" href="https://www.filmfetish.com/sets/cult-cinema-icons-lines/">Cult Cinema Icons</a></li>
<li id="menu-item-85422" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85422"><a title="Cult Flavor" href="https://www.filmfetish.com/sets/cult-flavor/">Cult Flavor</a></li>
<li id="menu-item-85430" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85430"><a title="Hit Pictures" href="https://www.filmfetish.com/prds/art/">Hit Pictures</a></li>
<li id="menu-item-85424" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85424"><a title="Pop Culture Quotes" href="https://www.filmfetish.com/sets/pop-culture-quotes/">Pop Culture Quotes</a></li>
<li id="menu-item-85425" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85425"><a title="Pop Fetish" href="https://www.filmfetish.com/sets/pop-fetish-lines/">Pop Fetish</a></li>
<li id="menu-item-85429" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85429"><a title="Poster Crush" href="https://www.filmfetish.com/prds/postercrush/">Poster Crush</a></li>
<li id="menu-item-85426" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85426"><a title="The Museum of Fantastic Art" href="https://www.filmfetish.com/sets/museum-of-fantastic-art/">The Museum of Fantastic Art</a></li>
<li id="menu-item-85427" class="menu-item menu-item-type-taxonomy menu-item-object-csets menu-item-85427"><a title="Throwback Space" href="https://www.filmfetish.com/sets/throwback-space/">Throwback Space</a></li>
<li id="menu-item-85428" class="menu-item menu-item-type-taxonomy menu-item-object-cprds menu-item-85428"><a title="Tie Crush" href="https://www.filmfetish.com/prds/tie-crush/">Tie Crush &#8211; Downright Dapper Neckties</a></li>
</ul></div></aside><aside id="rss-5" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/type/quote/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">PopCultureQuotes.com</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/2021/04/26/86744/'>PopCultureQuotes.com | Quote by George Lucas</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/04/26/86742/'>PopCultureQuotes.com | Quote by Bill Maher</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/04/01/86066/'>PopCultureQuotes.com | Quote by Kevin Conway</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/03/30/86002/'>PopCultureQuotes.com | Quote by James Glickenhaus</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2021/03/30/86000/'>PopCultureQuotes.com | Quote by James Glickenhaus</a></li></ul></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">About</h3><div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-73871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73871"><a title="Support Film Fetish" href="https://www.filmfetish.com/support/">Support Us</a></li>
<li id="menu-item-37141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37141"><a href="https://www.filmfetish.com/about/">About Us</a></li>
<li id="menu-item-49547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49547"><a href="https://www.filmfetish.com/about/return-policy/">Return Policy</a></li>
<li id="menu-item-49546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49546"><a href="https://www.filmfetish.com/about/shipping-information/">Shipping Information</a></li>
<li id="menu-item-37143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37143"><a href="https://www.filmfetish.com/about/copyright/">Copyright</a></li>
<li id="menu-item-37145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37145"><a href="https://www.filmfetish.com/about/privacy-policy/">Privacy Policy | Terms of Use | Disclaimer</a></li>
<li id="menu-item-49545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49545"><a title="Contact" href="https://www.filmfetish.com/about/contact/">Contact</a></li>
</ul></div></aside>	</div><!-- .second -->
	</div><!-- #secondary -->       
	</div><!-- #primary -->

	<div id="secondary" class="widget-area" role="complementary">
		<aside id="text-11" class="widget widget_text"><h3 class="widget-title">Also Purchased</h3>			<div class="textwidget"><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/the-walking-dead-season-6-teaser-23-x-34-inch-television-series-poster/" title="The Walking Dead Season 6 Teaser 23 x 34 inch Television Series Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/04/walking-dead-season-6-teaser14339-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Walking Dead Season 6 Teaser 23 x 34 inch Television Series Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/funko-dorbz-despicable-me-3-dave-tourist-action-figure-vinyl-collectible-323/" title="Funko DORBZ Despicable Me 3 Dave Tourist Action Figure Vinyl Collectible #323" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/07/dorbz-do01-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Funko DORBZ Despicable Me 3 Dave Tourist Action Figure Vinyl Collectible #323"></a></div><div><a href="https://www.filmfetish.com/ffmkt/perdita-durango-dance-with-the-devil/" title="Perdita Durango (Dance With the Devil)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/03/perdita-durango-bluray-SEV4733BR-170x170.jpg" width="170" height="170" class="related-thumb" alt="Perdita Durango (Dance With the Devil)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/entertainment-weekly-issue-no-1057-july-24-2009-the-return-of-iron-man-comic-con-preview/" title="Entertainment Weekly Issue No. 1057 &#8211; July 24, 2009 &#8211; The Return of Iron Man, Comic-Con Preview" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/01/IMG_5678-170x170.jpg" width="170" height="170" class="related-thumb" alt="Entertainment Weekly Issue No. 1057 &#8211; July 24, 2009 &#8211; The Return of Iron Man, Comic-Con Preview"></a></div><div><a href="https://www.filmfetish.com/ffmkt/star-wars-saga-character-collage-22-x-34-inch-movie-poster/" title="Star Wars Saga Character Collage 22 x 34 Inch Movie Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/11/star-wars-saga-collage-movie-poster-170x170.jpg" width="170" height="170" class="related-thumb" alt="Star Wars Saga Character Collage 22 x 34 Inch Movie Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/batman-the-animated-series-robin-hand-painted-figure-eaglemoss-collection/" title="Batman: The Animated Series &#8211; Robin Hand Painted Figure Eaglemoss Collection" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/01/eaglemoss-robin-figure-170x170.jpg" width="170" height="170" class="related-thumb" alt="Batman: The Animated Series &#8211; Robin Hand Painted Figure Eaglemoss Collection"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-return-of-swamp-thing-original-motion-picture-soundtrack-cd-2019/" title="The Return of Swamp Thing Original Motion Picture Soundtrack CD (2019)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/08/return-of-swamp-thing-soundtrack-cd-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Return of Swamp Thing Original Motion Picture Soundtrack CD (2019)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/star-wars-hot-wheels-car-ships-millennium-falcon-v2/" title="Star Wars Hot Wheels Car Ships Millennium Falcon V2" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/05/hot-wheels-star-wars-carships-millenium-falcon-v2-1-170x170.jpg" width="170" height="170" class="related-thumb" alt="Star Wars Hot Wheels Car Ships Millennium Falcon V2"></a></div><div><a href="https://www.filmfetish.com/ffmkt/planet-of-the-apes-2001-set-of-4-hasbro-action-figures-krull-leo-davidson-ari-daena-u39/" title="Planet of the Apes (2001) Set of 4 Hasbro Action Figures &#8211; Krull, Leo Davidson, Ari, Daena [U39]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2021/07/planet-apes-4-set-u39-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Planet of the Apes (2001) Set of 4 Hasbro Action Figures &#8211; Krull, Leo Davidson, Ari, Daena [U39]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/world-heavyweight-championship-george-foreman-vs-muhammad-ali-39-x-47-inch-original-simulcast-promotional-poster/" title="World Heavyweight Championship George Foreman vs Muhammad Ali 39 x 47 inch Original Simulcast Promotional Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/07/george-foreman-vs-muhammad-ali-promo-poster-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="World Heavyweight Championship George Foreman vs Muhammad Ali 39 x 47 inch Original Simulcast Promotional Poster"></a></div></div>
</div>
		</aside><aside id="rss-13" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/sets/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Featured</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/supernatural-wb-series-sticky-note-collection/'>Supernatural WB Series Sticky Note Collection Science Fiction Fantasy Paperback [U67]</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-warriors-movie-enamel-pins-by-waxwork/'>The Warriors Movie Enamel Pins by Waxwork</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/creepshow-enamel-pins-designed-by-ghoulish-gary-pullin-3-options/'>Creepshow Enamel Pins Designed by Ghoulish Gary Pullin (3 Options)</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-silence-of-the-lambs-original-motion-picture-soundtrack-limited-edition-cd-by-howard-shore/'>The Silence of the Lambs Original Motion Picture Soundtrack Limited Edition CD by Howard Shore</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/george-a-romero-and-stephen-kings-creepshow-original-motion-picture-soundtrack-score-sea-algae-colored-vinyl-edition/'>George A. Romero and Stephen King’s Creepshow Original Motion Picture Soundtrack Score “Sea Algae” Colored Vinyl Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-transformers-the-movie-35th-anniversary-limited-edition-steelbook-4k-uhd-blu-ray/'>The Transformers: The Movie 35th Anniversary Limited Edition Steelbook 4K UHD + Blu-ray</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/escape-from-new-york-volume-four-escape-from-cleveland-graphic-novel/'>Escape From New York Volume Four – Escape From Cleveland Graphic Novel</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/john-carpenters-halloween-officially-licensed-michael-myers-lunchbox-and-thermos-set-u08/'>John Carpenter’s Halloween Officially Licensed Michael Myers Lunchbox and Thermos Set [U08]</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-daimajin-trilogy-3-disc-limited-edition-blu-ray-box-set/'>The Daimajin Trilogy 3-Disc Limited Edition Blu-ray Box Set</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-dead-zone-collectors-edition-blu-ray-with-slipcover/'>The Dead Zone Collector’s Edition Blu-ray with Slipcover</a></li></ul></aside><aside id="nav_menu-15" class="widget widget_nav_menu"><h3 class="widget-title">Popular Genres</h3><div class="menu-landing-page-genres-container"><ul id="menu-landing-page-genres" class="menu"><li id="menu-item-49449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49449"><a title="Action" href="https://www.filmfetish.com/genr/action/?mcrterm=y">Action</a></li>
<li id="menu-item-49450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49450"><a title="Adventure" href="https://www.filmfetish.com/genr/adventure/?mcrterm=y">Adventure</a></li>
<li id="menu-item-49451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49451"><a title="Comedy" href="https://www.filmfetish.com/genr/comedy/?mcrterm=y">Comedy</a></li>
<li id="menu-item-49452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49452"><a title="Crime" href="https://www.filmfetish.com/genr/crime/?mcrterm=y">Crime</a></li>
<li id="menu-item-49453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49453"><a title="Documentary" href="https://www.filmfetish.com/genr/documentary/?mcrterm=y">Documentary</a></li>
<li id="menu-item-49454" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49454"><a title="Exploitation" href="https://www.filmfetish.com/genr/exploitation/?mcrterm=y">Exploitation</a></li>
<li id="menu-item-49455" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49455"><a title="Fantasy" href="https://www.filmfetish.com/genr/fantasy-films/?mcrterm=y">Fantasy</a></li>
<li id="menu-item-49456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49456"><a title="Horror" href="https://www.filmfetish.com/genr/horror-films/?mcrterm=y">Horror</a></li>
<li id="menu-item-49457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49457"><a title="Martial Arts" href="https://www.filmfetish.com/genr/martial-arts/?mcrterm=y">Martial Arts</a></li>
<li id="menu-item-49458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49458"><a title="Mystery" href="https://www.filmfetish.com/genr/mystery-films/?mcrterm=y">Mystery</a></li>
<li id="menu-item-49459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49459"><a title="Science Fiction" href="https://www.filmfetish.com/genr/sci-fi-films/?mcrterm=y">Science Fiction</a></li>
<li id="menu-item-49460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49460"><a title="Thriller" href="https://www.filmfetish.com/genr/thrillers/?mcrterm=y">Thriller</a></li>
</ul></div></aside>	</div><!-- #secondary -->
	</div><!-- #main .wrapper -->
	<footer id="colophon" role="contentinfo">
		<div class="site-info">
					&copy; 2021 FilmFetish.com | Film Fetish and the Crush Collectibles Shop | <a href="http://hitpi.cc/mtheaterfooterurl/" title="M Theater Wordpress Theme created by Rene Carson from HIT PICTURES" target="_blank"> Website Design: HIT PICTURES</a> <span class="logshow off"><a href="https://www.filmfetish.com/wp-login.php">Log in</a></span></div><!-- .site-info -->
	</footer><!-- #colophon -->

<div id="gotop"><a href="#top"><span></span></a></div>
</div><!-- #page -->

<!-- Custom Feeds for Instagram JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.filmfetish.com/wp-admin/admin-ajax.php";

</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.widowbuster.js' id='widbuster-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids.js' id='fitvids-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids-ld.js' id='fitvids-ld-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.colorbox.js' id='colorbox-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.topspring.js' id='topspring-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/nav.js' id='mthe-nav-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.8' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/mediaelement-ld.js' id='mediaelement-ld-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.js?ver=1.0' id='mycccal-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/wp-embed.min.js?ver=5.8' id='wp-embed-js'></script>
   
<script>		
jQuery(window).load(function($) {	
	jQuery('a[href$=".jpg"],a[href$=".jpeg"],a[href$=".png"],a[href$=".gif"]').colorbox({rel:'gal',maxHeight:'100%',speed:700,fadeOut:600,initialWidth:false,maxWidth:'100%',initialHeight:false,slideshow:true,slideshowAuto:false,slideshowSpeed:6000,slideshowStart:'slideshow',slideshowStop:'stop',transition:'fade'});
	jQuery('.mycc-ajax').colorbox();
	jQuery('.mycc-inline').colorbox({inline:true,speed:700,fadeOut:600,width:'100%',height:'100%',transition:'fade'});
});
</script>
	<script>
jQuery(window).load(function($){
var d = new Date();
var n = d.getMonth() + 1;
var yr = d.getFullYear();
var design_month_covers = ['https://www.filmfetish.com/img/p/2016/07/calimg160718-body-double-melanie-griffith-craig-wasson.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-elton-john-diana-ross-cher-awards-show-1980s.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-bridget-fonda-robert-deniro-samuel-l-jackson-in-jackie-brown.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-janet-leigh.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-vincent-donofrio-martin-sensmeier-manuel-garciarulfo-ethan-hawke-denzel-washington-chris-pratt-byunghunlee-magnificent-seven.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-five-easy-pieces-loews-holly-theater-hollywood-blvd.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-linda-lovelace-deep-throat-porn-icon.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-le-mans-playing-loews-state-times-square-new-york-city-1971.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-rebecca-ferguson-mission-impossible-rogue-nation-2015.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-lauren-cohan-the-boy-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-yoo-gong-in-train-to-busan-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-dane-dehaan-valerian-city-thousand-planets-2017.jpg'];
dzscal_init("#tr1",{
design_month_covers : design_month_covers,
start_month: n,
	start_year: yr
});
});
</script>
<!-- Start of StatCounter Code for Default Guide -->
<script type="text/javascript">
var sc_project=6854008; 
var sc_invisible=1; 
var sc_security="5609cdda"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="shopify
analytics ecommerce" href="http://statcounter.com/shopify/"
target="_blank"><img class="statcounter"
src="//c.statcounter.com/6854008/0/5609cdda/1/" alt="shopify
analytics ecommerce"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->
</body>
</html>