<!DOCTYPE html>
<!-- Get M Theater WordPress Theme at BY HAND Media (http://www.byhandmedia.net/mtheater) -->
<!--[if IE 7 | IE 8]>
<html class="ie" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition |  FilmFetish.com | Film Fetish and the Crush Collectibles Shop </title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.filmfetish.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://www.filmfetish.com/wp-content/themes/m-theater/js/html5.js" type="text/javascript"></script>
<![endif]-->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//i.hit.pictures' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop &raquo; Feed" href="https://www.filmfetish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop &raquo; Comments Feed" href="https://www.filmfetish.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.filmfetish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.6"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sbi_styles-css'  href='https://www.filmfetish.com/wp-content/plugins/instagram-feed-pro/css/sbi-styles.min.css?ver=5.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.filmfetish.com/wp-includes/css/dist/block-library/style.min.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-style-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/style.css?ver=5.6' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelementcss-css'  href='https://www.filmfetish.com/wp-includes//js/mediaelement/mediaelementplayer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='naranja-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/theme-color-naranja.css' type='text/css' media='all' />
<link rel='stylesheet' id='liquidslcss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/liquid-slider.css?ver=2.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='bhadsharecss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/style-shared.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='bhadcss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccaltltpcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzstooltip/dzstooltip.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccuscalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-cal-cus.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccartcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-shopcart.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='myccmaincss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-mycc.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js?ver=2.1.4' id='jquery-js'></script>
<link rel="https://api.w.org/" href="https://www.filmfetish.com/wp-json/" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.filmfetish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.filmfetish.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.6" />
<link rel="canonical" href="https://www.filmfetish.com/ffmkt/firefly-original-graphic-novel-watch-how-i-soar-hardcover-edition/" />
<link rel='shortlink' href='https://www.filmfetish.com/?p=83997' />
<link rel="alternate" type="application/json+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;format=xml" />
<link rel="image_src" href="https://www.filmfetish.com/img/p/2020/12/firefly-watch-how-i-soar-graphic-novel.jpg" />
<meta name="web_author" content="Web Site Development: HitPictures.tech" />
<meta name="wp_theme_name" content="M Theater" />
<link rel="wp_theme_address" href="http://hitpictures.tech/mtheater/" />
<meta name="copyright" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
<meta name="googlebot" content="noodp" />
<meta name="robots" content="noodp" />
<meta name="no-email-collection" content="No spam harvesting allowed" />
<meta name="dc.source" content="https://www.filmfetish.com/ffmkt/firefly-original-graphic-novel-watch-how-i-soar-hardcover-edition/" />
<meta name="dc.publisher" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
<meta name="dc.date" content="2020-12-21T19:28:39-05:00" />
<meta name="dc.title" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition" />
<meta name="dc.creator" content="René Carson" />
<meta name="description" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition-A new graphic novel exploring one of the most pivotal moments of Joss Whedon’s acclaimed Firefly, as Wash realizes he’s" />
<meta name="keywords" content="action,adam baldwin,adventure,alan tudyk,boom entertainment,christina hendricks,ethan young,firefly,giannis milonogiannis,gina torres,graphic novels,hardcover books,jewel staite,jorge corona,joss whedon,morena baccarin,nathan fillion,ron glass,science fiction,sean maher,simon and schuster,summer glau," />
<meta name="author" content="René Carson" />
<meta name="abstract" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition" />
<meta property="og:title" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition" />
<meta itemprop="name" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition" />
<meta name="twitter:title" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition" />
<meta property="og:type" content="article" />
<meta property="article:published_time" content="2020-12-21T19:28:39-05:00" />
<meta property="article:modified_time" content="2020-12-21T19:28:39-05:00" />
<meta property="og:description" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition-A new graphic novel exploring one of the most pivotal moments of Joss Whedon’s acclaimed Firefly, as Wash realizes he’s" />
<meta name="twitter:description" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition-A new graphic novel exploring one of the most pivotal moments of Joss Whedon’s acclaimed Firefly, as Wash realizes he’s" />
<meta itemprop="description" content="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition-A new graphic novel exploring one of the most pivotal moments of Joss Whedon’s acclaimed Firefly, as Wash realizes he’s" />
<meta itemprop="image" content="https://www.filmfetish.com/img/p/2020/12/firefly-watch-how-i-soar-graphic-novel.jpg" />
<meta name="twitter:card" content="summary" />
<meta property="og:url" content="https://www.filmfetish.com/ffmkt/firefly-original-graphic-novel-watch-how-i-soar-hardcover-edition/" />
<meta property="og:image" content="https://www.filmfetish.com/img/p/2020/12/firefly-watch-how-i-soar-graphic-novel.jpg" />
<meta property="og:site_name" content="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" />
	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px);
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<!-- M Theater Custom CSS -->
<style type="text/css" media="screen" id="mtheater-custom-styles">
@import url("//cdn-images.mailchimp.com/embedcode/classic-10_7.css");

@import url("//www.filmfetish.com/wp-content/fetish-styles.css");

@import url("//i.hit.pictures/css/network-shops.css");
</style><!-- End Custom CSS -->

<link rel="shortcut icon" href="https://hit.pics/favicon.ico" />
<style type="text/css" media="screen" id="mtheater-custom-plugin-styles">
/* Custom M Theater CSS */
.archive-txt { display: none; }
/* Mailchimp */
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
/* Plugin */
p.bhmspamkill, textarea#bhm_nonviewable { display:none;position:absolute;left:-9000px; }
/* ie */
.ie #bhmmainpg .bhmmainlogobx .bhmmaintxt { width: 46%; float: left; }
.ie #bhmmainpg .bhmmainlogobx { width: 43%; padding: 2%; float: left; min-height: 320px; min-height: 22.857142857rem; }
.ie #bhmmainpg .bhmmainlogobx.right { float: right; }
</style></head>

<body id="top" class="ffmktcrt-template-default single single-ffmktcrt postid-83997 httpswwwfilmfetishcom custom-background-empty custom-font-enabled nav-nobanner style-fnt-hdr-sz-a style-fnt-hdr-styl-a style-fnt-ttl-styl-a style-fnt-bod-styl-a">

<div id="page" class="hfeed site">
	<header id="masthead" class="site-header" role="banner">
		<hgroup class="title-background">
			<h1 class="site-title"><a href="https://www.filmfetish.com/" title="FilmFetish.com | Film Fetish and the Crush Collectibles Shop" rel="home">FilmFetish.com | Film Fetish and the Crush Collectibles Shop</a></h1>
			<h2 class="site-description">Cool Movies, TV, Music and Sports</h2>
		</hgroup>


<nav id="site-navigation" class="main-navigation" role="navigation">
	<button class="menu-toggle">Menu</button>
	<div class="skip-link assistive-text"><a href="#content" title="Skip to content">Skip to content</a></div>
	<div class="menu-flea-market-container"><ul id="menu-flea-market" class="nav-menu"><li id="menu-item-49430" class="nav-depts menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49430"><a title="Departments" href="https://www.filmfetish.com/market/archive/">Depts</a>
<ul class="sub-menu">
	<li id="menu-item-49470" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49470"><a title="Apparel" href="https://www.crushcollectibles.com/movie-licensed-apparel-accessories-shop.html">Apparel</a></li>
	<li id="menu-item-49471" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49471"><a title="Books" href="https://www.crushcollectibles.com/pop-culture-film-tv-comics-books.html">Books</a></li>
	<li id="menu-item-62384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62384"><a title="Home Goods" href="https://www.crushcollectibles.com/movie-licensed-pillows-blankets-cups-shop.html">Home Goods</a></li>
	<li id="menu-item-49472" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49472"><a title="Lobby Cards &#038; Press Books" href="https://www.crushcollectibles.com/lobby-cards-press-books-photos.html">Lobby Cards &#038; Press Books</a></li>
	<li id="menu-item-49473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49473"><a title="Movies &#038; TV" href="https://www.crushcollectibles.com/movie-tv-dvd-bluray-shop.html">Movies &#038; TV</a></li>
	<li id="menu-item-49475" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49475"><a title="Music" href="https://www.crushcollectibles.com/music-spoken-word-comedy-cd-vinyl-records-shop.html">Music</a></li>
	<li id="menu-item-49477" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49477"><a title="Poster Crush" href="https://www.crushcollectibles.com/poster-crush-movie-posters-shop.html">Poster Crush</a></li>
	<li id="menu-item-49478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49478"><a title="Toys" href="https://www.crushcollectibles.com/crush-collectibles-toy-action-figure-shop.html">Toys</a></li>
</ul>
</li>
<li class="mbtn"><div class="mycc-viewcart"><form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post"><input type="hidden" name="business" value="rene@hitpictures.com"><input type="hidden" name="cmd" value="_cart"><input type="hidden" name="display" value="1"><input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/firefly-original-graphic-novel-watch-how-i-soar-hardcover-edition/"><input type="image" name="submit" src="https://www.filmfetish.com/img/p/2016/11/view-cart.gif" alt="View Cart" title="View Cart"><img alt="" width="1" height="1" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif"><input type="hidden" name="cpp_logo_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_checkout_logo161114.gif"><input type="hidden" name="page_style" value="film_fetish"></form></div></li><li><form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Search Market"><select name="post_type" style="display: none;"><option value="ffmktcrt">ffmktcrt</option></select></form></li><li class="nav-logo"><a href="https://www.crushcollectibles.com/" title="Crush Collectibles"><img class="logo-img arc" src="https://www.filmfetish.com/img/p/2018/01/main-crush-logo.gif" alt="CRUSHCOLLECTIBLES.COM" /></a><img src="https://www.filmfetish.com/img/p/2018/01/main-reel-brand.gif" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="Film Fetish Home"><img class="logo-img live" src="https://www.filmfetish.com/img/p/2018/01/main-filmfetish-logo.gif" alt="FILMFETISH.COM" /></a></li></ul></div></nav>
        


<div id="search-social">



<div id="searchmain" class="searchwrap">
<form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Search Market"><select name="post_type" style="display: none;"><option value="ffmktcrt">ffmktcrt</option></select></form><div class="respo"><a href="https://www.crushcollectibles.com/" title="Crush Collectibles"><img class="logo-img arc" src="https://www.filmfetish.com/img/p/2018/01/main-crush-logo.gif" alt="CRUSHCOLLECTIBLES.COM" /></a><img src="https://www.filmfetish.com/img/p/2018/01/main-reel-brand.gif" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="Film Fetish Home"><img class="logo-img live" src="https://www.filmfetish.com/img/p/2018/01/main-filmfetish-logo.gif" alt="FILMFETISH.COM" /></a></div></div>




</div><!-- #search-social -->
	</header><!-- #masthead -->

	<div id="main" class="wrapper">  	<div id="primary" class="site-content">
		<div id="content" role="main">

			
				
	<article id="post-83997" class="solo post-83997 ffmktcrt type-ffmktcrt status-publish hentry category-action category-adventure category-boom-entertainment category-graphic-novels category-hardcover-books category-sci-fi-films category-simon-and-schuster cppl-adam-baldwin cppl-alan-tudyk cppl-christina-hendricks cppl-ethan-young cppl-giannis-milonogiannis cppl-gina-torres cppl-jewel-staite cppl-jorge-corona cppl-joss-whedon cppl-morena-baccarin cppl-nathan-fillion cppl-ron-glass cppl-sean-maher cppl-summer-glau cshow-firefly fffmclass fffmsingle less-three">
    <div id="social-nav-top"><a class="mycc-inline protected" href="#sotop">Share Page</a> <a class="protected" href="https://www.filmfetish.com/support/">Support Us</a>
<div style="display:none;"><div id="sotop"> <div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2020%2F12%2Ffirefly-watch-how-i-soar-graphic-novel.jpg&#038;description=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D83997" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;title=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;title=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;name=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;n=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;t=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=83997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=83997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	 </div></div>
<div id="socplus-right"><nav class="nav-single-top">
					<h3 class="assistive-text">Previous page navigation</h3>
									</nav><!-- #socplus-right -->
                </div><!-- .nav-single-top -->
		</div><!-- #social-nav-top -->

		<header class="entry-header">
			
                       
            <h1 class="entry-title myc-center ">Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition</h1>
		</header><!-- .entry-header -->

		<div class="entry-content">
		<div class="myc-prod-wrapper"><div class="myc-prod-wrapper-left">
<figure class="cart-image"><a href="https://www.filmfetish.com/img/p/2020/12/firefly-watch-how-i-soar-graphic-novel.jpg" title="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/12/firefly-watch-how-i-soar-graphic-novel-210x323.jpg" width="210" height="323" class="cart-thumb" alt="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition"><div class="myc-caption">View larger</div></a></figure>

</div><div class="myc-prod-wrapper-right">
<div class="mycc-addtocart">
<p class="myc-price"><span>$21.99</span></p>
<p class="myc-price">$18.97</p>
<form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post">

	<input type="hidden" name="business" value="sitepay@crushcollectibles.com">
	<input type="hidden" name="cmd" value="_cart">  
	<input type="hidden" name="item_name" value="Firefly Original Graphic Novel: Watch How I Soar Hardcover Edition">
	<input type="hidden" name="item_number" value="201222-83997">
	<input type="hidden" name="add" value="1">
	<input type="hidden" name="currency_code" value="USD">

  	<input type="hidden" name="page_style" value="film_fetish">

	<input type="hidden" name="image_url" value="https://www.filmfetish.com/img/p/2016/11/paypal_150x50_161122.gif">

	<input type="hidden" name="cpp_header_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_banner161114.jpg">
  
  <input type="hidden" name="paymentaction" value="sale">
  


<div class="myc-output">


<table>
	<tr>
		<td><select name="quantity">
        <option value="1">- Select Qty -</option>
		<option value="1">1</option>		</select> <br/>1 in stock		</td>
	</tr>
</table>

 
</div><!-- .output -->
	<input type="hidden" name="weight" value="1.15" id="mycweight">
	<input type="hidden" name="weight_unit" value="lbs">


    	<input type="hidden" name="amount" value="18.97">

		














  
    
    
        
  	    <input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/firefly-original-graphic-novel-watch-how-i-soar-hardcover-edition/">
    
	    <input type="hidden" name="return" value="https://www.filmfetish.com/transaction-complete/">
        
        <input type="hidden" name="cbt" value="Continue Shopping">
        
    	<input type="hidden" name="cancel_return" value="https://www.filmfetish.com/market/">
    
        <input type="hidden" name="no_shipping" value="2">
    
        <input type="hidden" name="no_note" value="0">
    <input type="hidden" name="cn" value="Add special instructions:">
    
    <br/><br/><input type="image" name="submit" src="https://www.paypalobjects.com/webstatic/en_US/i/btn/png/btn_addtocart_120x26.png" alt="Add to Cart">
  <img alt="" width="1" height="1" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif">

</form>
</div>	

</div></div><div class="spec-wrap"><span class="mycc-details">Hardcover Book</span>SKU: 201221-83997-1<br/>ISBN-13: 9781684156559<br/>Weight: 1.15 lbs<br/>Condition: New</div><p class="spec-wrap">View All: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=5658&#038;mcrtrmkey=cppl">Adam Baldwin</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=8685&#038;mcrtrmkey=cppl">Alan Tudyk</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=17093&#038;mcrtrmkey=cppl">Christina Hendricks</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=3419&#038;mcrtrmkey=cppl">Gina Torres</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=613&#038;mcrtrmkey=cppl">Joss Whedon</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=8686&#038;mcrtrmkey=cppl">Morena Baccarin</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=2952&#038;mcrtrmkey=cppl">Nathan Fillion</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=34224&#038;mcrtrmkey=cppl">Ron Glass</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=6452&#038;mcrtrmkey=cppl">Summer Glau</a></strong> &nbsp;<strong>items</strong><br/>Product Types: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25142&#038;mcrtrmkey=category">Graphic Novels</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25342&#038;mcrtrmkey=category">Hardcover Books</a></strong><br/>Genres: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24211&#038;mcrtrmkey=category">Action</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24212&#038;mcrtrmkey=category">Adventure</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=15475&#038;mcrtrmkey=category">Science Fiction</a></strong><br/>Studio: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24362&#038;mcrtrmkey=category">Boom Entertainment</a></strong><br/>Original U.S. Release: September 20, 2002<br/>Item Release Date: December 1, 2020<br/>Rating: TV-14<br/><strong>Visit our main page for additional items <a href="http://www.filmfetish.fm/">Here</a>.</strong></p><h2 class="myc-center low">Details</h2><p>A new graphic novel exploring one of the most pivotal moments of Joss Whedon’s acclaimed Firefly, as Wash realizes he’s about to die and the most important moments flash before his eyes- including one that even he never expected.</p>
<p>“I AM A LEAF ON THE WIND; WATCH HOW I SOAR”</p>
<p>Return to the critically-acclaimed world of Joss Whedon’s Firefly in an all new graphic novel spotlighting Hoban “Wash” Washburne, pilot of the spaceship Serenity&#8230;who has just realized he’s about to die.</p>
<p>As Wash’s life flashes before him, he revisits the most important, never before revealed moments in his life, from growing up on a planet so ravaged by pollution that no star could shine in the sky to meeting the woman of his dreams in Zoe, who would become his wife and create a life with him beyond his wildest imagination.</p>
<p>And in those final moments, Wash will reach out to connect with a surprising someone he never thought possible to meet&#8230;proving that some bonds transcend our mortal coils.</p>
<p>Writer Greg Pak and artists Davide Gianfelice and Lalit Kumar Sharma come together to present the unforgettable untold stories of the ‘Verse’s most lovable hero set during his final moments &#8211; and how love survives even when we don’t.</p>
<h2 class="myc-center low">Specifications</h2><ul class="mycc-features"><li><span class="featleft">Pages: </span><span class="featright">128</span></li><li><span class="featleft">Language: </span><span class="featright">English</span></li><li><span class="featleft">Size: </span><span class="featright">6.63 x 0.4 x 10.19 in</span></li></ul><p>Cast: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=5658&#038;mcrtrmkey=cppl">Adam Baldwin</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=8685&#038;mcrtrmkey=cppl">Alan Tudyk</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=17093&#038;mcrtrmkey=cppl">Christina Hendricks</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=3419&#038;mcrtrmkey=cppl">Gina Torres</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=34222&#038;mcrtrmkey=cppl">Jewel Staite</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=8686&#038;mcrtrmkey=cppl">Morena Baccarin</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=2952&#038;mcrtrmkey=cppl">Nathan Fillion</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=34224&#038;mcrtrmkey=cppl">Ron Glass</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=34223&#038;mcrtrmkey=cppl">Sean Maher</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=6452&#038;mcrtrmkey=cppl">Summer Glau</a></strong><br/>Project Name<br/>Authors: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=39115&#038;mcrtrmkey=cppl">Ethan Young</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=39113&#038;mcrtrmkey=cppl">Giannis Milonogiannis</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=39114&#038;mcrtrmkey=cppl">Jorge Corona</a></strong><br/>Creators: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=613&#038;mcrtrmkey=cppl">Joss Whedon</a></strong></p><h2 class="myc-center low">Related Items</h2><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/godzilla-vs-king-ghidorah-24-x-36-inch-movie-poster/" title="Godzilla vs. King Ghidorah 24 x 36 Inch Movie Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/11/godzilla-vs-king-ghidora-movie-poster-170x170.jpg" width="170" height="170" class="related-thumb" alt="Godzilla vs. King Ghidorah 24 x 36 Inch Movie Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/21-original-press-publicity-photos-of-marlon-brando-pho882/" title="21 Original Press Publicity Photos of Marlon Brando [PHO882]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/09/photo-lot-pho882-001-170x170.jpg" width="170" height="170" class="related-thumb" alt="21 Original Press Publicity Photos of Marlon Brando [PHO882]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/superman-doomsday-original-soundtrack-recording-music-composed-by-robert-kral/" title="Superman: Doomsday Original Soundtrack Recording Music Composed by Robert Kral" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/11/superman-doomsday-original-soundtrack-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Superman: Doomsday Original Soundtrack Recording Music Composed by Robert Kral"></a></div><div><a href="https://www.filmfetish.com/ffmkt/disney-pixar-wall-e-3-disc-blu-ray-edition-with-slipcover/" title="Disney Pixar Wall E 3-Disc Blu-ray Edition with Slipcover" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/02/wall-e-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Disney Pixar Wall E 3-Disc Blu-ray Edition with Slipcover"></a></div><div><a href="https://www.filmfetish.com/ffmkt/total-recall-30th-anniversary-4k-uhd-blu-ray-digital-3-disc-edition/" title="Total Recall 30th Anniversary 4K UHD + Blu-ray + Digital 3-Disc Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/12/total-recall-4k-cover-170x170.jpg" width="170" height="170" class="related-thumb" alt="Total Recall 30th Anniversary 4K UHD + Blu-ray + Digital 3-Disc Edition"></a></div><div><a href="https://www.filmfetish.com/ffmkt/star-trek-the-original-tv-series-cast-portraits-12x18-inch-officially-licensed-canvas-print-c10/" title="Star Trek: The Original TV Series Cast Portraits 12&#215;18 inch Officially Licensed Canvas Print [C10]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/10/star-trek-classic-tv-series-canvas-c10-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Star Trek: The Original TV Series Cast Portraits 12&#215;18 inch Officially Licensed Canvas Print [C10]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/kung-fu-panda-music-from-the-motion-picture-by-hans-zimmer-and-john-powell/" title="Kung Fu Panda Music from the Motion Picture by Hans Zimmer and John Powell" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/06/kung-fu-panda-film-soundtrack-album-170x170.jpg" width="170" height="170" class="related-thumb" alt="Kung Fu Panda Music from the Motion Picture by Hans Zimmer and John Powell"></a></div><div><a href="https://www.filmfetish.com/ffmkt/first-annual-spotlight-tribute-collectors-edition-2007-jessica-alba-johnny-depp/" title="First Annual Spotlight Tribute Collector&#8217;s Edition (2007) Jessica Alba, Johnny Depp" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/09/st07-magazine-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="First Annual Spotlight Tribute Collector&#8217;s Edition (2007) Jessica Alba, Johnny Depp"></a></div><div><a href="https://www.filmfetish.com/ffmkt/jay-and-silent-bob-strike-back-music-from-the-motion-picture-cd/" title="Jay and Silent Bob Strike Back Music from the Motion Picture CD (2001)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/05/jay-silent-bob-strikes-back-cd-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Jay and Silent Bob Strike Back Music from the Motion Picture CD (2001)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/barbershop-music-from-the-motion-picture-soundtrack-cd-2002/" title="Barbershop: Music from the Motion Picture Soundtrack CD (2002)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/10/barbershop-soundtrack-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Barbershop: Music from the Motion Picture Soundtrack CD (2002)"></a></div></div><h2 class="myc-center low">Categories</h2>
			<p class="myc-center"><span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24211">Action</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24212">Adventure</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24362">Boom Entertainment</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=25142">Graphic Novels</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=25342">Hardcover Books</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=15475">Science Fiction</a></span></p>
		</div><!-- .entry-content -->
		<div class="share-meta">
        <div class="shareline">#</div>
        <div class="bkmrk-bottom"><div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2020%2F12%2Ffirefly-watch-how-i-soar-graphic-novel.jpg&#038;description=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D83997" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;title=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;title=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;name=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;n=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Ffirefly-original-graphic-novel-watch-how-i-soar-hardcover-edition%2F&#038;t=Firefly%20Original%20Graphic%20Novel%3A%20Watch%20How%20I%20Soar%20Hardcover%20Edition" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=83997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | Film Fetish and the Crush Collectibles Shop:%20https://www.filmfetish.com/?p=83997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	</div> 
<p class="cntr">Page Link<br />
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/ffmkt/firefly-original-graphic-novel-watch-how-i-soar-hardcover-edition/' /><br/>
Short Link<br/>
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/?p=83997' /></p>
<div class="shareline">#</div>
        </div><!-- .share-meta -->

		<footer class="entry-meta">
					</footer>
	</article><!-- #post -->

			
			
		</div><!-- #content -->
 		
<div id="secondary-2" class="widget-area-footer" role="complementary">
		<div class="first foot-widgets">
		<aside id="text-10" class="widget widget_text">			<div class="textwidget"><style type="text/css">
#siteseal,#siteseal img{ box-shadow:none !important; }
</style><span id="siteseal"><script async type="text/javascript" src="https://seal.godaddy.com/getSeal?sealID=rH1l6dk2mtoVz3jYyGon3RFfR7VdpW5gXXKlATaM6kRI0sfrsWYmRCxiSuDt"></script></span></div>
		</aside><aside id="rss-11" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/shop/misc/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Latest Crush Items</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/gorillaz-almanac-2020-hardcover-graphic-novel-edition/'>Gorillaz Almanac 2020 Hardcover Graphic Novel Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/planet-of-the-apes-artist-tribute-hardcover-edition-featuring-alex-ross/'>Planet of the Apes Artist Tribute Hardcover Edition – Featuring Alex Ross</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/city-of-pleasure-paris-between-the-wars-hardcover-edition/'>City of Pleasure: Paris Between the Wars Hardcover Edition</a></li></ul></aside><aside id="nav_menu-17" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-departments-container"><ul id="menu-departments" class="menu"><li id="menu-item-49437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49437"><a title="Apparel" href="https://www.crushcollectibles.com/movie-licensed-apparel-accessories-shop.html">Apparel</a></li>
<li id="menu-item-49438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49438"><a title="Books" href="https://www.crushcollectibles.com/pop-culture-film-tv-comics-books.html">Books</a></li>
<li id="menu-item-68606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68606"><a title="Games" href="https://www.crushcollectibles.com/board-card-video-games-shop.html">Games</a></li>
<li id="menu-item-62385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62385"><a title="Home Goods" href="https://www.crushcollectibles.com/movie-licensed-pillows-blankets-cups-shop.html">Home Goods</a></li>
<li id="menu-item-49439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49439"><a title="Lobby Cards &#038; Press Books" href="https://www.crushcollectibles.com/lobby-cards-press-books-photos.html">Lobby Cards &#038; Press Books</a></li>
<li id="menu-item-49440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49440"><a title="Movies &#038; TV" href="https://www.crushcollectibles.com/movie-tv-dvd-bluray-shop.html">Movies &#038; TV</a></li>
<li id="menu-item-49442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49442"><a title="Music" href="https://www.crushcollectibles.com/music-spoken-word-comedy-cd-vinyl-records-shop.html">Music</a></li>
<li id="menu-item-49444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49444"><a title="Poster &#038; Canvas Shop" href="https://www.crushcollectibles.com/poster-crush-movie-posters-shop.html">Poster Crush</a></li>
<li id="menu-item-49445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49445"><a title="Toys" href="https://www.crushcollectibles.com/crush-collectibles-toy-action-figure-shop.html">Toys</a></li>
</ul></div></aside><aside id="nav_menu-13" class="widget widget_nav_menu"><h3 class="widget-title">#FilmFetish #CrushCollectibles</h3><div class="menu-soc-media-container"><ul id="menu-soc-media" class="menu"><li id="menu-item-48865" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48865"><a title="FilmFetish on Facebook" target="_blank" rel="noopener" href="https://www.facebook.com/filmfetish">facebook.com/filmfetish</a></li>
<li id="menu-item-48866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48866"><a title="FilmFetish on Twitter" target="_blank" rel="noopener" href="http://twitter.com/filmfetish">twitter.com/filmfetish</a></li>
<li id="menu-item-68742" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68742"><a title="Crush Collectibles on Instagram" target="_blank" rel="noopener" href="http://instagram.com/crushcollectibles">instagram.com/crushcollectibles</a></li>
<li id="menu-item-48867" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48867"><a title="FilmFetish on Instagram" target="_blank" rel="noopener" href="http://instagram.com/filmfetish">instagram.com/filmfetish</a></li>
<li id="menu-item-48869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48869"><a title="Get our RSS Feed" target="_blank" rel="noopener" href="http://www.filmfetish.com/feed/">filmfetish.com/feed</a></li>
</ul></div></aside>	</div><!-- .first -->
	
		<div class="second foot-widgets">
		<aside id="custom_html-3" class="widget_text widget widget_custom_html"><h3 class="widget-title">Crush Collectibles!</h3><div class="textwidget custom-html-widget"><p><a href="http://crushcollectibles.com" title="CRUSH COLLECTIBLES"><img src="https://www.filmfetish.com/img/p/2016/06/filmfetish-teaser-announcement.jpg" alt="Pop Culture, Sports and Music Collectibles" /></a></p></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside><aside id="rss-5" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/type/quote/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">PopCultureQuotes.com</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/2019/02/24/77376/'>PopCultureQuotes.com | Quote by Steven Spielberg</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2019/01/29/77095/'>PopCultureQuotes.com | Quote by Nickell Robey-Coleman</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73493/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73491/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73489/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li></ul></aside><aside id="rss-10" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/editorials/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Recent News</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/2020/12/16/trailer-for-ifc-films-no-mans-land/'>Trailer for IFC Films’ No Man’s Land</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2020/12/16/trailer-and-official-poster-for-mind-bending-sci-fi-documentary-a-glitch-in-the-matrix/'>Trailer and official poster for mind-bending sci-fi documentary A Glitch In The Matrix</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2020/12/11/the-falcon-and-the-winter-soldier/'>First look trailer for Disney Plus series The Falcon and the Winter Soldier</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2020/12/11/loki/'>First trailer for Disney Plus series Loki</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2020/12/11/trailer-2-for-marvel-mcu-series-wandavision/'>Trailer 2 for Marvel MCU series WandaVision</a></li></ul></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">About Us</h3><div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-73871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73871"><a title="Support Film Fetish" href="https://www.filmfetish.com/support/">Support Us</a></li>
<li id="menu-item-70051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70051"><a title="Share Our Banners and Spread the Word About Us!" href="https://www.filmfetish.com/category/editorials/imagery/banners/">Share Our Banners</a></li>
<li id="menu-item-37141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37141"><a href="https://www.filmfetish.com/about/">About Us</a></li>
<li id="menu-item-49547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49547"><a href="https://www.filmfetish.com/about/return-policy/">Return Policy</a></li>
<li id="menu-item-49546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49546"><a href="https://www.filmfetish.com/about/shipping-information/">Shipping Information</a></li>
<li id="menu-item-49656" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49656"><a href="https://www.filmfetish.com/product-size-charts/">Product Size Charts</a></li>
<li id="menu-item-37143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37143"><a href="https://www.filmfetish.com/about/copyright/">Copyright</a></li>
<li id="menu-item-37145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37145"><a href="https://www.filmfetish.com/about/privacy-policy/">Privacy Policy | Terms of Use | Disclaimer</a></li>
<li id="menu-item-49545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49545"><a title="Contact" href="https://www.filmfetish.com/about/contact/">Contact</a></li>
</ul></div></aside>	</div><!-- .second -->
	</div><!-- #secondary -->       
	</div><!-- #primary -->

	<div id="secondary" class="widget-area" role="complementary">
		<aside id="nav_menu-18" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-store-quick-links-container"><ul id="menu-store-quick-links" class="menu"><li id="menu-item-65771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65771"><a title="Featured Items" href="https://www.crushcollectibles.com/">Featured Items</a></li>
<li id="menu-item-68607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68607"><a title="Poster Crush" href="https://www.crushcollectibles.com/poster-crush-movie-posters-shop.html">Poster Crush</a></li>
<li id="menu-item-65770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65770"><a title="Movies for Sale" href="https://www.crushcollectibles.com/movie-tv-dvd-bluray-shop.html">Movies for Sale</a></li>
</ul></div></aside><aside id="mtheater_content_widget-6" class="widget mthecontentwidg"><h3 class="widget-title">Shoppers Also Purchased</h3><h2 class="myc-center low">Related Items</h2><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/brain-damage-original-motion-picture-soundtrack-vinyl-special-edition/" title="Brain Damage Original Motion Picture Soundtrack Vinyl Special Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/12/brain-damage-vinyl-soundtrack-170x170.jpg" width="170" height="170" class="related-thumb" alt="Brain Damage Original Motion Picture Soundtrack Vinyl Special Edition"></a></div><div><a href="https://www.filmfetish.com/ffmkt/inside-kung-fu-magazine-august-1987-bruce-lee-cover-189125/" title="Inside Kung Fu Magazine August 1987 &#8211; Bruce Lee Cover [189125]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/09/189125-inside-kung-fu-august-1987-bruce-lee-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Inside Kung Fu Magazine August 1987 &#8211; Bruce Lee Cover [189125]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-warriors-armies-of-the-night-24-x-36-inch-vertical-movie-poster/" title="The Warriors &#8211; Armies of the Night 24 x 36 inch Vertical Movie Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/03/the-warriors-vertical-poster-51287-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Warriors &#8211; Armies of the Night 24 x 36 inch Vertical Movie Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/sealed-superman-usps-1st-day-issue-cover-sdcc-2006-limited-edition-stamp-art-matted-poster-16-x-12/" title="SEALED Superman USPS 1st Day Issue Cover SDCC 2006 Limited Edition Stamp Art Matted Poster 16 X 12" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/06/IMG_6931-170x170.jpg" width="170" height="170" class="related-thumb" alt="SEALED Superman USPS 1st Day Issue Cover SDCC 2006 Limited Edition Stamp Art Matted Poster 16 X 12"></a></div><div><a href="https://www.filmfetish.com/ffmkt/daredevil-issue-number-182-may-1982-frank-miller-12449/" title="Daredevil Issue Number 182 (May 1982) Frank Miller [12449]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/02/daredevil-12449-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Daredevil Issue Number 182 (May 1982) Frank Miller [12449]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/impact-magazine-june-1995-jean-claude-van-damme-with-street-fighter-pullout-poster-c11/" title="Impact Magazine (June 1995) Jean-Claude Van Damme with Street Fighter Pullout Poster [C11]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/12/impact-mag-c11-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Impact Magazine (June 1995) Jean-Claude Van Damme with Street Fighter Pullout Poster [C11]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/eclipse-comics-airboy-first-issue-reborn-july-1986-12328/" title="Eclipse Comics Airboy First Issue Reborn! (July 1986) [12328]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2020/02/airboy-1-12328-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Eclipse Comics Airboy First Issue Reborn! (July 1986) [12328]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/what-have-they-done-with-your-daughters-special-edition-2018/" title="What Have They Done With Your Daughters? Special Edition (2018)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/09/what-have-they-done-daughters-arrow-bd-170x170.jpg" width="170" height="170" class="related-thumb" alt="What Have They Done With Your Daughters? Special Edition (2018)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/dc-direct-batman-black-and-white-statue-designed-by-jim-lee-2007/" title="DC Direct Batman Black and White Statue Designed by Jim Lee (2007)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/01/dc-comics-batman-black-white-a-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="DC Direct Batman Black and White Statue Designed by Jim Lee (2007)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/jackie-chan-international-fan-club-magazine-number-32-april-june-1988/" title="Jackie Chan International Fan Club Magazine Number 32 [April June 1988] 198143" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/11/189143-jackie-chan-fan-club-32-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Jackie Chan International Fan Club Magazine Number 32 [April June 1988] 198143"></a></div></div></aside><aside id="rss-13" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/shop/misc/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Latest Featured Items</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/gorillaz-almanac-2020-hardcover-graphic-novel-edition/'>Gorillaz Almanac 2020 Hardcover Graphic Novel Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/planet-of-the-apes-artist-tribute-hardcover-edition-featuring-alex-ross/'>Planet of the Apes Artist Tribute Hardcover Edition – Featuring Alex Ross</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/city-of-pleasure-paris-between-the-wars-hardcover-edition/'>City of Pleasure: Paris Between the Wars Hardcover Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-sci-fi-fantasy-art-of-patrick-j-jones-hardcover-edition/'>The Sci-Fi &amp; Fantasy Art of Patrick J. Jones Hardcover Edition</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/army-of-darkness-mondo-24x36-inch-movie-poster-variant-edition-tom-whalen-evil-dead-2014/'>Army Of Darkness MONDO 24×36 inch Movie Poster Variant Edition Tom Whalen Evil Dead (2014)</a></li></ul></aside><aside id="nav_menu-14" class="widget widget_nav_menu"><h3 class="widget-title">Departments</h3><div class="menu-departments-container"><ul id="menu-departments-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49437"><a title="Apparel" href="https://www.crushcollectibles.com/movie-licensed-apparel-accessories-shop.html">Apparel</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49438"><a title="Books" href="https://www.crushcollectibles.com/pop-culture-film-tv-comics-books.html">Books</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68606"><a title="Games" href="https://www.crushcollectibles.com/board-card-video-games-shop.html">Games</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62385"><a title="Home Goods" href="https://www.crushcollectibles.com/movie-licensed-pillows-blankets-cups-shop.html">Home Goods</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49439"><a title="Lobby Cards &#038; Press Books" href="https://www.crushcollectibles.com/lobby-cards-press-books-photos.html">Lobby Cards &#038; Press Books</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49440"><a title="Movies &#038; TV" href="https://www.crushcollectibles.com/movie-tv-dvd-bluray-shop.html">Movies &#038; TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49442"><a title="Music" href="https://www.crushcollectibles.com/music-spoken-word-comedy-cd-vinyl-records-shop.html">Music</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49444"><a title="Poster &#038; Canvas Shop" href="https://www.crushcollectibles.com/poster-crush-movie-posters-shop.html">Poster Crush</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49445"><a title="Toys" href="https://www.crushcollectibles.com/crush-collectibles-toy-action-figure-shop.html">Toys</a></li>
</ul></div></aside><aside id="nav_menu-15" class="widget widget_nav_menu"><h3 class="widget-title">Popular Genres</h3><div class="menu-popular-genres-container"><ul id="menu-popular-genres" class="menu"><li id="menu-item-49449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49449"><a title="Action" href="https://www.filmfetish.com/market/archive/?mcrterm=24211&#038;mcrtrmkey=category">Action</a></li>
<li id="menu-item-49450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49450"><a title="Adventure" href="https://www.filmfetish.com/market/archive/?mcrterm=24212&#038;mcrtrmkey=category">Adventure</a></li>
<li id="menu-item-49451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49451"><a title="Comedy" href="https://www.filmfetish.com/market/archive/?mcrterm=24216&#038;mcrtrmkey=category">Comedy</a></li>
<li id="menu-item-49452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49452"><a title="Crime" href="https://www.filmfetish.com/market/archive/?mcrterm=24217&#038;mcrtrmkey=category">Crime</a></li>
<li id="menu-item-49453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49453"><a title="Documentary" href="https://www.filmfetish.com/market/archive/?mcrterm=24218&#038;mcrtrmkey=category">Documentary</a></li>
<li id="menu-item-49454" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49454"><a title="Exploitation" href="https://www.filmfetish.com/market/archive/?mcrterm=24220&#038;mcrtrmkey=category">Exploitation</a></li>
<li id="menu-item-49455" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49455"><a title="Fantasy" href="https://www.filmfetish.com/market/archive/?mcrterm=958&#038;mcrtrmkey=category">Fantasy</a></li>
<li id="menu-item-49456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49456"><a title="Horror" href="https://www.filmfetish.com/market/archive/?mcrterm=24226&#038;mcrtrmkey=category">Horror</a></li>
<li id="menu-item-49457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49457"><a title="Martial Arts" href="https://www.filmfetish.com/market/archive/?mcrterm=24227&#038;mcrtrmkey=category">Martial Arts</a></li>
<li id="menu-item-49458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49458"><a title="Mystery" href="https://www.filmfetish.com/market/archive/?mcrterm=24231&#038;mcrtrmkey=category">Mystery</a></li>
<li id="menu-item-49459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49459"><a title="Science Fiction" href="https://www.filmfetish.com/market/archive/?mcrterm=24235&#038;mcrtrmkey=category">Science Fiction</a></li>
<li id="menu-item-49460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49460"><a title="Thriller" href="https://www.filmfetish.com/market/archive/?mcrterm=24240&#038;mcrtrmkey=category">Thriller</a></li>
</ul></div></aside>	</div><!-- #secondary -->
	</div><!-- #main .wrapper -->
	<footer id="colophon" role="contentinfo">
		<div class="site-info">
					&copy; 2020 FilmFetish.com | Film Fetish and the Crush Collectibles Shop | <a href="http://hitpi.cc/mtheaterfooterurl/" title="M Theater Wordpress Theme created by Rene Carson from HIT PICTURES" target="_blank"> Website Design: HIT PICTURES</a> <span class="logshow off"><a href="https://www.filmfetish.com/wp-login.php">Log in</a></span></div><!-- .site-info -->
	</footer><!-- #colophon -->

<div id="gotop"><a href="#top"><span></span></a></div>
</div><!-- #page -->

<!-- Custom Feeds for Instagram JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.filmfetish.com/wp-admin/admin-ajax.php";

</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.widowbuster.js' id='widbuster-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids.js' id='fitvids-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids-ld.js' id='fitvids-ld-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.colorbox.js' id='colorbox-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.topspring.js' id='topspring-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/nav.js' id='mthe-nav-js'></script>
<script type='text/javascript' id='mediaelement-core-js-before'>
var mejsL10n = {"language":"en","strings":{"mejs.download-file":"Download File","mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen":"Fullscreen","mejs.play":"Play","mejs.pause":"Pause","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.live-broadcast":"Live Broadcast","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.16' id='mediaelement-core-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.6' id='mediaelement-migrate-js'></script>
<script type='text/javascript' id='mediaelement-js-extra'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/mediaelement-ld.js' id='mediaelement-ld-js'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.easing.js?ver=1.3' id='jqueryeasing-js'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.touchSwipe.min.js?ver=1.3' id='jquerytouchsw-js'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.liquid-slider.min.js?ver=2.3.8' id='liquidslider-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.js?ver=1.0' id='mycccal-js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/wp-embed.min.js?ver=5.6' id='wp-embed-js'></script>
   
<script>		
jQuery(window).load(function($) {	
	jQuery('a[href$=".jpg"],a[href$=".jpeg"],a[href$=".png"],a[href$=".gif"]').colorbox({rel:'gal',maxHeight:'100%',speed:700,fadeOut:600,initialWidth:false,maxWidth:'100%',initialHeight:false,slideshow:true,slideshowAuto:false,slideshowSpeed:6000,slideshowStart:'slideshow',slideshowStop:'stop',transition:'fade'});
	jQuery('.mycc-ajax').colorbox();
	jQuery('.mycc-inline').colorbox({inline:true,speed:700,fadeOut:600,width:'100%',height:'100%',transition:'fade'});
});
</script>
	<script>
jQuery(window).load(function($){
var d = new Date();
var n = d.getMonth() + 1;
var yr = d.getFullYear();
var design_month_covers = ['https://www.filmfetish.com/img/p/2016/07/calimg160718-body-double-melanie-griffith-craig-wasson.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-elton-john-diana-ross-cher-awards-show-1980s.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-bridget-fonda-robert-deniro-samuel-l-jackson-in-jackie-brown.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-janet-leigh.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-vincent-donofrio-martin-sensmeier-manuel-garciarulfo-ethan-hawke-denzel-washington-chris-pratt-byunghunlee-magnificent-seven.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-five-easy-pieces-loews-holly-theater-hollywood-blvd.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-linda-lovelace-deep-throat-porn-icon.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-le-mans-playing-loews-state-times-square-new-york-city-1971.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-rebecca-ferguson-mission-impossible-rogue-nation-2015.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-lauren-cohan-the-boy-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-yoo-gong-in-train-to-busan-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-dane-dehaan-valerian-city-thousand-planets-2017.jpg'];
dzscal_init("#tr1",{
design_month_covers : design_month_covers,
start_month: n,
	start_year: yr
});
});
</script>
<div class="bhad-wrapper plugin_load_early"><div class='bhadads plugin_load_early'><div class='liquid-slider ad' id='adsysslide'>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/website-services/" title="Website Services">Website Services</a></h2>
<p><a href="http://hitpi.cc/domains/" target="_blank" rel="noopener noreferrer"><span class="icn">X</span> HitPictures.tech <span class="arw">⇒</span> Domain Names, Websites</a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/headshotcard-com-comp-card-services/" title="HeadshotCard.com Comp Card Services">HeadshotCard.com Comp Card Services</a></h2>
<p><a href="http://headshotcard.com/" target="_blank" rel="noopener noreferrer"><span class="icn">r</span> HEADSHOTCARD.COM <span class="arw">⇒</span> Comp Cards, Headshots</a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/flyer-hype-promotional-event-flyers/" title="Flyer Hype Promotional Event Flyers">Flyer Hype Promotional Event Flyers</a></h2>
<p><a href="http://hitpi.cc/domains/" target="_blank" rel="noopener noreferrer"><span class="icn">Y</span> Promo Flyers for Deejay/Filmmaker Events <span class="arw">⇒</span></a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/movie-tv-music-and-sports-collectibles/" title="Movie, TV, Music and Sports Collectibles">Movie, TV, Music and Sports Collectibles</a></h2>
<p><a href="http://crushcollectibles.com/" target="_blank" rel="noopener noreferrer"><span class="icn">a</span> Crush Collectibles <span class="arw">⇒</span></a></p>
</div>
</div></div></div><script>
			$('#adsysslide').liquidSlider({
				panelTitleSelector:".bhadadtitle",
				autoSlide:true,
				dynamicArrows:false,
				hoverArrows:false,
				dynamicArrowsGraphical:false,
				autoSlideInterval:10000,
				dynamicTabs:false,
				pauseOnHover:true,
				autoHeight:false,
				mobileNavigation:false,
				includeTitle:false
		});
	</script><!-- Start of StatCounter Code for Default Guide -->
<script type="text/javascript">
var sc_project=6854008; 
var sc_invisible=1; 
var sc_security="5609cdda"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="shopify
analytics ecommerce" href="http://statcounter.com/shopify/"
target="_blank"><img class="statcounter"
src="//c.statcounter.com/6854008/0/5609cdda/1/" alt="shopify
analytics ecommerce"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->
</body>
</html>