<!DOCTYPE html>
<!-- Get M Theater WordPress Theme at BY HAND Media (http://www.byhandmedia.net/mtheater) -->
<!--[if IE 7 | IE 8]>
<html class="ie" lang="en-US">
<![endif]-->
<!--[if !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US">
<!--<![endif]-->
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width" />
<title>Black Sabbath: The Ozzy Osbourne Years (2000) |  FilmFetish.com | CrushCollectibles.com </title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="pingback" href="https://www.filmfetish.com/xmlrpc.php" />
<!--[if lt IE 9]>
<script src="https://www.filmfetish.com/wp-content/themes/m-theater/js/html5.js" type="text/javascript"></script>
<![endif]-->

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//i.hit.pictures' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | CrushCollectibles.com &raquo; Feed" href="https://www.filmfetish.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | CrushCollectibles.com &raquo; Comments Feed" href="https://www.filmfetish.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="FilmFetish.com | CrushCollectibles.com &raquo; Black Sabbath: The Ozzy Osbourne Years (2000) Comments Feed" href="https://www.filmfetish.com/ffmkt/black-sabbath-the-ozzy-osbourne-years/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.filmfetish.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.3"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='sb_instagram_styles-css'  href='https://www.filmfetish.com/wp-content/plugins/instagram-feed-pro/css/sb-instagram.min.css?ver=5.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://www.filmfetish.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-style-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/style.css?ver=5.2.3' type='text/css' media='all' />
<link rel='stylesheet' id='colorbox-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/colorbox.css' type='text/css' media='all' />
<link rel='stylesheet' id='mediaelementcss-css'  href='https://www.filmfetish.com/wp-includes//js/mediaelement/mediaelementplayer.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='mtheater-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&#038;subset=latin,latin-ext' type='text/css' media='all' />
<link rel='stylesheet' id='naranja-css'  href='https://www.filmfetish.com/wp-content/themes/m-theater/styles/theme-color-naranja.css' type='text/css' media='all' />
<link rel='stylesheet' id='liquidslcss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/liquid-slider.css?ver=2.3.8' type='text/css' media='all' />
<link rel='stylesheet' id='bhadsharecss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/style-shared.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='bhadcss-css'  href='https://www.filmfetish.com/wp-content/plugins/bhm-adsys/css/style.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccaltltpcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzstooltip/dzstooltip.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccuscalcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-cal-cus.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='mycccartcss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-shopcart.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='myccmaincss-css'  href='https://www.filmfetish.com/wp-content/plugins/concoupons/css/style-mycc.css?ver=1.0' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/2.1.4/jquery.min.js?ver=2.1.4'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.6-78496d1'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<link rel='https://api.w.org/' href='https://www.filmfetish.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.filmfetish.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.filmfetish.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Thuvia Maid of Mars &#038; The Chessmen of Mars by Edgar Rice Burroughs Hardcover (1972) Frank Frazetta Cover Art' href='https://www.filmfetish.com/ffmkt/thuvia-maid-of-mars-the-chessmen-of-mars-by-edgar-rice-burroughs-hardcover-1972-frank-frazetta-cover-art/' />
<link rel='next' title='RARE Friday the 13th Camp Crystal Lake Banner' href='https://www.filmfetish.com/ffmkt/rare-friday-the-13th-camp-crystal-lake-banner/' />
<meta name="generator" content="WordPress 5.2.3" />
<link rel="canonical" href="https://www.filmfetish.com/ffmkt/black-sabbath-the-ozzy-osbourne-years/" />
<link rel='shortlink' href='https://www.filmfetish.com/?p=78997' />
<link rel="alternate" type="application/json+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.filmfetish.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;format=xml" />
<link rel="image_src" href="https://www.filmfetish.com/img/p/2019/09/black-sabbath-86034-01-825x1100.jpg" />
<meta name="web_author" content="Web Site Development: HitPictures.tech" />
<meta name="wp_theme_name" content="M Theater" />
<link rel="wp_theme_address" href="http://hitpictures.tech/mtheater/" />
<meta name="copyright" content="FilmFetish.com | CrushCollectibles.com" />
<meta name="googlebot" content="noodp" />
<meta name="robots" content="noodp" />
<meta name="no-email-collection" content="No spam harvesting allowed" />
<meta name="dc.source" content="https://www.filmfetish.com/ffmkt/black-sabbath-the-ozzy-osbourne-years/" />
<meta name="dc.publisher" content="FilmFetish.com | CrushCollectibles.com" />
<meta name="dc.date" content="2019-09-23T01:50:26-04:00" />
<meta name="dc.title" content="Black Sabbath: The Ozzy Osbourne Years (2000)" />
<meta name="dc.creator" content="René Carson" />
<meta name="description" content="Black Sabbath: The Ozzy Osbourne Years (2000)-In 1969, four youths from the factory town of Birmingham, England--Ozzy Osbourne, Tony Iommi, Geezer Butler and Bill Ward--formed a" />
<meta name="keywords" content="- flea market,biography,black sabbath,documentary,music videos,musical,ozzy osbourne,robert v. conte,softcover books," />
<meta name="author" content="René Carson" />
<meta name="abstract" content="Black Sabbath: The Ozzy Osbourne Years (2000)" />
<meta property="og:title" content="Black Sabbath: The Ozzy Osbourne Years (2000)" />
<meta itemprop="name" content="Black Sabbath: The Ozzy Osbourne Years (2000)" />
<meta name="twitter:title" content="Black Sabbath: The Ozzy Osbourne Years (2000)" />
<meta property="og:type" content="article" />
<meta property="article:published_time" content="2019-09-23T01:50:26-04:00" />
<meta property="article:modified_time" content="2019-09-23T01:50:40-04:00" />
<meta property="og:description" content="Black Sabbath: The Ozzy Osbourne Years (2000)-In 1969, four youths from the factory town of Birmingham, England--Ozzy Osbourne, Tony Iommi, Geezer Butler and Bill Ward--formed a" />
<meta name="twitter:description" content="Black Sabbath: The Ozzy Osbourne Years (2000)-In 1969, four youths from the factory town of Birmingham, England--Ozzy Osbourne, Tony Iommi, Geezer Butler and Bill Ward--formed a" />
<meta itemprop="description" content="Black Sabbath: The Ozzy Osbourne Years (2000)-In 1969, four youths from the factory town of Birmingham, England--Ozzy Osbourne, Tony Iommi, Geezer Butler and Bill Ward--formed a" />
<meta itemprop="image" content="https://www.filmfetish.com/img/p/2019/09/black-sabbath-86034-01-825x1100.jpg" />
<meta name="twitter:card" content="summary" />
<meta property="og:url" content="https://www.filmfetish.com/ffmkt/black-sabbath-the-ozzy-osbourne-years/" />
<meta property="og:image" content="https://www.filmfetish.com/img/p/2019/09/black-sabbath-86034-01-825x1100.jpg" />
<meta property="og:site_name" content="FilmFetish.com | CrushCollectibles.com" />
	<style type="text/css">
			.site-title,
		.site-description {
			position: absolute;
			clip: rect(1px 1px 1px 1px);
			clip: rect(1px, 1px, 1px, 1px);
		}
		</style>
	<!-- M Theater Custom CSS -->
<style type="text/css" media="screen" id="mtheater-custom-styles">
@import url("//cdn-images.mailchimp.com/embedcode/classic-10_7.css");

@import url("//www.filmfetish.com/wp-content/fetish-styles.css");

@import url("//i.hit.pictures/css/network-shops.css");
</style><!-- End Custom CSS -->

<style type="text/css" media="screen" id="mtheater-custom-plugin-styles">
/* Custom M Theater CSS */
.archive-txt { display: none; }
/* Mailchimp */
#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
/* Plugin */
p.bhmspamkill, textarea#bhm_nonviewable { display:none;position:absolute;left:-9000px; }
/* ie */
.ie #bhmmainpg .bhmmainlogobx .bhmmaintxt { width: 46%; float: left; }
.ie #bhmmainpg .bhmmainlogobx { width: 43%; padding: 2%; float: left; min-height: 320px; min-height: 22.857142857rem; }
.ie #bhmmainpg .bhmmainlogobx.right { float: right; }
</style></head>

<body id="top" class="ffmktcrt-template-default single single-ffmktcrt postid-78997 httpswwwfilmfetishcom custom-background-empty custom-font-enabled nav-nobanner style-fnt-hdr-sz-a style-fnt-hdr-styl-a style-fnt-ttl-styl-a style-fnt-bod-styl-a">

<div id="page" class="hfeed site">
	<header id="masthead" class="site-header" role="banner">
		<hgroup class="title-background">
			<h1 class="site-title"><a href="https://www.filmfetish.com/" title="FilmFetish.com | CrushCollectibles.com" rel="home">FilmFetish.com | CrushCollectibles.com</a></h1>
			<h2 class="site-description">Cool Movies, TV, Music and Sports</h2>
		</hgroup>


<nav id="site-navigation" class="main-navigation" role="navigation">
	<button class="menu-toggle">Menu</button>
	<div class="skip-link assistive-text"><a href="#content" title="Skip to content">Skip to content</a></div>
	<div class="menu-flea-market-container"><ul id="menu-flea-market" class="nav-menu"><li id="menu-item-49430" class="nav-depts menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-49430"><a title="Departments" href="https://www.filmfetish.com/market/archive/">Depts</a>
<ul class="sub-menu">
	<li id="menu-item-49470" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49470"><a title="Apparel" href="https://www.filmfetish.com/market/archive/?mcrterm=24386&#038;mcrtrmkey=category">Apparel</a></li>
	<li id="menu-item-49471" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49471"><a title="Books" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></li>
	<li id="menu-item-49489" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49489"><a title="Featured" href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured</a></li>
	<li id="menu-item-62384" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62384"><a title="Home Goods" href="https://www.filmfetish.com/market/archive/?mcrterm=24612&#038;mcrtrmkey=category">Home Goods</a></li>
	<li id="menu-item-49472" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49472"><a title="Lobby Cards" href="https://www.filmfetish.com/market/archive/?mcrterm=24383&#038;mcrtrmkey=category">Lobby Cards</a></li>
	<li id="menu-item-49473" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49473"><a title="Movies &#038; TV" href="https://www.filmfetish.com/market/archive/?mcrterm=24129&#038;mcrtrmkey=category">Movies &#038; TV</a></li>
	<li id="menu-item-49474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49474"><a title="Mugs &#038; Cups" href="https://www.filmfetish.com/market/archive/?mcrterm=24277&#038;mcrtrmkey=category">Mugs &#038; Cups</a></li>
	<li id="menu-item-49475" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49475"><a title="Music" href="https://www.filmfetish.com/market/archive/?mcrterm=24252&#038;mcrtrmkey=category">Music</a></li>
	<li id="menu-item-49476" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49476"><a title="Photo Prints" href="https://www.filmfetish.com/market/archive/?mcrterm=24274&#038;mcrtrmkey=category">Photo Prints</a></li>
	<li id="menu-item-49477" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49477"><a title="Poster Crush" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
	<li id="menu-item-49478" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49478"><a title="Toys" href="https://www.filmfetish.com/market/archive/?mcrterm=24128&#038;mcrtrmkey=category">Toys</a></li>
</ul>
</li>
<li class="mbtn"><div class="mycc-viewcart"><form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post"><input type="hidden" name="business" value="rene@hitpictures.com"><input type="hidden" name="cmd" value="_cart"><input type="hidden" name="display" value="1"><input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/black-sabbath-the-ozzy-osbourne-years/"><input type="image" name="submit" src="https://www.filmfetish.com/img/p/2016/11/view-cart.gif" alt="View Cart" title="View Cart"><img alt="" width="1" height="1" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif"><input type="hidden" name="cpp_logo_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_checkout_logo161114.gif"><input type="hidden" name="page_style" value="film_fetish"></form></div></li><li><form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Search Market"><select name="post_type" style="display: none;"><option value="ffmktcrt">ffmktcrt</option></select></form></li><li class="nav-logo"><a href="https://www.filmfetish.com/market/" title="CRUSHCOLLECTIBLES.COM"><img class="logo-img arc" src="https://www.filmfetish.com/img/p/2018/01/main-crush-logo.gif" alt="CRUSHCOLLECTIBLES.COM" /></a><img src="https://www.filmfetish.com/img/p/2018/01/main-reel-brand.gif" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="FILMFETISH.COM"><img class="logo-img live" src="https://www.filmfetish.com/img/p/2018/01/main-filmfetish-logo.gif" alt="FILMFETISH.COM" /></a></li></ul></div></nav>
        


<div id="search-social">



<div id="searchmain" class="searchwrap">
<form action="https://www.filmfetish.com/" id="searchform" method="get"><input type="search" name="s" value="" id="s" placeholder="Search Market"><select name="post_type" style="display: none;"><option value="ffmktcrt">ffmktcrt</option></select></form><div class="respo"><a href="https://www.filmfetish.com/market/" title="CRUSHCOLLECTIBLES.COM"><img class="logo-img arc" src="https://www.filmfetish.com/img/p/2018/01/main-crush-logo.gif" alt="CRUSHCOLLECTIBLES.COM" /></a><img src="https://www.filmfetish.com/img/p/2018/01/main-reel-brand.gif" alt="FILM FETISH" /><a href="https://www.filmfetish.com/" title="FILMFETISH.COM"><img class="logo-img live" src="https://www.filmfetish.com/img/p/2018/01/main-filmfetish-logo.gif" alt="FILMFETISH.COM" /></a></div></div>




</div><!-- #search-social -->
	</header><!-- #masthead -->

	<div id="main" class="wrapper">  	<div id="primary" class="site-content">
		<div id="content" role="main">

			
				
	<article id="post-78997" class="solo post-78997 ffmktcrt type-ffmktcrt status-publish hentry category-flea-market category-biography category-documentary category-music-videos category-musical category-softcover-books cppl-black-sabbath cppl-ozzy-osbourne cppl-robert-v-conte fffmclass fffmsingle less-three">
    <div id="social-nav-top"><a class="mycc-inline protected" href="#sotop">Share Page</a> <a class="protected" href="https://www.filmfetish.com/support/">Support Us</a>
<div style="display:none;"><div id="sotop"> <div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2019%2F09%2Fblack-sabbath-86034-01-825x1100.jpg&#038;description=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D78997" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;title=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;title=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;name=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;n=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;t=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | CrushCollectibles.com&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | CrushCollectibles.com:%20https://www.filmfetish.com/?p=78997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | CrushCollectibles.com:%20https://www.filmfetish.com/?p=78997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	 </div></div>
<div id="socplus-right"><nav class="nav-single-top">
					<h3 class="assistive-text">Previous page navigation</h3>
									</nav><!-- #socplus-right -->
                </div><!-- .nav-single-top -->
		</div><!-- #social-nav-top -->

		<header class="entry-header">
			
                       
            <h1 class="entry-title myc-center ">Black Sabbath: The Ozzy Osbourne Years (2000)</h1>
		</header><!-- .entry-header -->

		<div class="entry-content">
		<div class="myc-prod-wrapper"><div class="myc-prod-wrapper-left">
<figure class="cart-image"><a href="https://www.filmfetish.com/img/p/2019/09/black-sabbath-86034-01-825x1100.jpg" title="Black Sabbath: The Ozzy Osbourne Years (2000)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/09/black-sabbath-86034-01-210x280.jpg" width="210" height="280" class="cart-thumb" alt="Black Sabbath: The Ozzy Osbourne Years (2000)"><div class="myc-caption">View larger</div></a></figure>

</div><div class="myc-prod-wrapper-right">
<div class="mycc-addtocart">
<p class="myc-price"><span>$39.00</span></p>
<p class="myc-price">$13.97</p>
<form target="_self" action="https://www.paypal.com/cgi-bin/webscr" method="post">

	<input type="hidden" name="business" value="sitepay@crushcollectibles.com">
	<input type="hidden" name="cmd" value="_cart">  
	<input type="hidden" name="item_name" value="Black Sabbath: The Ozzy Osbourne Years (2000)">
	<input type="hidden" name="item_number" value="190924-78997">
	<input type="hidden" name="add" value="1">
	<input type="hidden" name="currency_code" value="USD">

  	<input type="hidden" name="page_style" value="film_fetish">

	<input type="hidden" name="image_url" value="https://www.filmfetish.com/img/p/2016/11/paypal_150x50_161122.gif">

	<input type="hidden" name="cpp_header_image" value="https://www.filmfetish.com/img/p/2016/11/paypal_ff_banner161114.jpg">
  
  <input type="hidden" name="paymentaction" value="sale">
  


<div class="myc-output">


<table>
	<tr>
		<td><select name="quantity">
        <option value="1">- Select Qty -</option>
		<option value="1">1</option>		</select> <br/>1 in stock		</td>
	</tr>
</table>

 
</div><!-- .output -->

	<input type="hidden" name="weight" value="1" id="mycweight">
	<input type="hidden" name="weight_unit" value="lbs">


    	<input type="hidden" name="amount" value="13.97">

		














  
    
    
        
  	    <input type="hidden" name="shopping_url" value="https://www.filmfetish.com/ffmkt/black-sabbath-the-ozzy-osbourne-years/">
    
	    <input type="hidden" name="return" value="https://www.filmfetish.com/transaction-complete/">
        
        <input type="hidden" name="cbt" value="Continue Shopping">
        
    	<input type="hidden" name="cancel_return" value="https://www.filmfetish.com/market/">
    
        <input type="hidden" name="no_shipping" value="2">
    
        <input type="hidden" name="no_note" value="0">
    <input type="hidden" name="cn" value="Add special instructions:">
    
    <br/><br/><input type="image" name="submit" src="https://www.paypalobjects.com/webstatic/en_US/i/btn/png/btn_addtocart_120x26.png" alt="Add to Cart">
  <img alt="" width="1" height="1" src="https://www.paypalobjects.com/en_US/i/scr/pixel.gif">

</form>
</div>	

</div></div><div class="spec-wrap"><span class="mycc-details">Softcover Book</span>SKU: 190921-78997-1<br/>ISBN-10: 1890313998<br/>ISBN-13: 9781890313999<br/>Weight: 1.15 lbs<br/>Condition: Very Good - The item is used but still in very good condition. There is little to no damage to the packaging, but it may have minor wear from storage over a long period of time. There may be minimal wear on the exterior of the item. See Details section and photos for specifics on item condition.</div><p class="spec-wrap">View All: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=31111&#038;mcrtrmkey=cppl">Ozzy Osbourne</a></strong> &nbsp;<strong>items</strong><br/>Product Types: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=25343&#038;mcrtrmkey=category">Softcover Books</a></strong><br/>Genres: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24215&#038;mcrtrmkey=category">Biography</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24218&#038;mcrtrmkey=category">Documentary</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=972&#038;mcrtrmkey=category">Music Videos</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=24230&#038;mcrtrmkey=category">Musical</a></strong><br/>Item Release Date: September 8, 2000<br/><strong>Visit our main page for additional items <a href="http://www.filmfetish.fm/">Here</a>.</strong></p><h2 class="myc-center low">Details</h2><p>In 1969, four youths from the factory town of Birmingham, England&#8211;Ozzy Osbourne, Tony Iommi, Geezer Butler and Bill Ward&#8211;formed a group that would change music forever with their unique style of heavy metal. In 1980, Ozzy began an equally impressive solo career which established milestones in music history. Now, twenty years after Ozzys departure, Black Sabbath has reformed with a new album and tour with one objective: to claim their rightful place in Rock and Roll history.</p>
<p>But how did these four men reach an unprecedented level of success and influence countless musicians to emulate them for generations to come? Read the true story of Black Sabbath.</p>
<p>The item is in great condition with bends, creases and edge wear. See photos for details.</p>
<h2 class="myc-center low">Specifications</h2><ul class="mycc-features"><li><span class="featleft">Pages: </span><span class="featright">48</span></li><li><span class="featleft">Language: </span><span class="featright">English</span></li><li><span class="featleft">Size: </span><span class="featright">8 x 0.2 x 10.5 in</span></li></ul><p><br/>Authors: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=36469&#038;mcrtrmkey=cppl">Robert V. Conte</a></strong><br/>Subject: <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=30320&#038;mcrtrmkey=cppl">Black Sabbath</a></strong> | <strong><a class="mt-nobreak" href="https://www.filmfetish.com/market/archive/?mcrterm=31111&#038;mcrtrmkey=cppl">Ozzy Osbourne</a></strong></p><h2 class="myc-center low">Related Items</h2><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/screen-actor-magazine-fall-1988-whoopi-goldberg/" title="Screen Actor Magazine (Fall 1988) Whoopi Goldberg [190124]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/05/screen-actor-mag-190124-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Screen Actor Magazine (Fall 1988) Whoopi Goldberg [190124]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/bowie-album-by-album-softcover-edition/" title="Bowie: Album by Album Softcover Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/06/bowie-album-by-album-softcover-edition-book-170x170.jpg" width="170" height="170" class="related-thumb" alt="Bowie: Album by Album Softcover Edition"></a></div><div><a href="https://www.filmfetish.com/ffmkt/oscar-dearest-six-decades-of-scandal-politics-and-greed-behind-hollywoods-academy-awards-1927-1986-1931103/" title="Oscar Dearest: Six Decades of Scandal, Politics and Greed Behind Hollywood&#8217;s Academy Awards 1927-1986 [1931103]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/06/oscar-dearest-1931103-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Oscar Dearest: Six Decades of Scandal, Politics and Greed Behind Hollywood&#8217;s Academy Awards 1927-1986 [1931103]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/passion-poetry-the-ballad-of-sam-peckinpah-2-disc-special-edition/" title="Passion &#038; Poetry &#8211; The Ballad of Sam Peckinpah 2-Disc Special Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/02/passion-poetry-sam-peckinpah-doc-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Passion &#038; Poetry &#8211; The Ballad of Sam Peckinpah 2-Disc Special Edition"></a></div><div><a href="https://www.filmfetish.com/ffmkt/hieronymus-bosch-touched-by-the-devil/" title="Hieronymus Bosch: Touched by the Devil" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/02/Hieronymus-Bosch-Touched-by-the-Devil-dvd-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="Hieronymus Bosch: Touched by the Devil"></a></div><div><a href="https://www.filmfetish.com/ffmkt/pink-floyd-in-the-flesh-24x36-inch-music-concert-poster/" title="Pink Floyd in the Flesh 24&#215;36 inch Music Concert Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/01/pink-floyd-in-the-flesh-N241190-170x170.jpg" width="170" height="170" class="related-thumb" alt="Pink Floyd in the Flesh 24&#215;36 inch Music Concert Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/entertainment-weekly-magazine-best-and-worst-2015-december-18-2015/" title="Entertainment Weekly Magazine Best and Worst 2015 (December 18, 2015)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/03/entertainment-weekly-bestworst15-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Entertainment Weekly Magazine Best and Worst 2015 (December 18, 2015)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/americas-most-haunted-places-history-classics-5-dvd-box-set/" title="America&#8217;s Most Haunted Places History Classics 5-DVD Box Set" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/02/americas-most-haunted-places-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="America&#8217;s Most Haunted Places History Classics 5-DVD Box Set"></a></div><div><a href="https://www.filmfetish.com/ffmkt/david-bowie-pharoah-15x23-inch-bob-masse-music-poster/" title="David Bowie Pharoah 15&#215;23 inch Bob Masse Music Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/01/david-bowie-pharoah-BM086-170x170.jpg" width="170" height="170" class="related-thumb" alt="David Bowie Pharoah 15&#215;23 inch Bob Masse Music Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/david-bowie-the-man-who-sold-the-world-24-x-36-inch-music-poster/" title="David Bowie &#8211; The Man Who Sold the World 24 x 36 inch Music Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/12/david-bowie-man-who-sold-world-poster-170x170.jpg" width="170" height="170" class="related-thumb" alt="David Bowie &#8211; The Man Who Sold the World 24 x 36 inch Music Poster"></a></div></div><h2 class="myc-center low">Categories</h2>
			<p class="myc-center"><span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24215">Biography</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24218">Documentary</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=972">Music Videos</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=24230">Musical</a></span> | <span><a href="https://www.filmfetish.com/market/archive/?mcrtcat=25343">Softcover Books</a></span></p>
		</div><!-- .entry-content -->
		<div class="share-meta">
        <div class="shareline">#</div>
        <div class="bkmrk-bottom"><div class="soccntr">
    		                  
				<div class="socplus"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;media=https%3A%2F%2Fwww.filmfetish.com%2Fimg%2Fp%2F2019%2F09%2Fblack-sabbath-86034-01-825x1100.jpg&#038;description=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-pnt.png" width="40" height="40" alt="Pinterest" /></a></div>		
						                <div class="socplus"><a href="https://twitter.com/intent/tweet?text=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29&#038;url=https%3A%2F%2Fwww.filmfetish.com%2F%3Fp%3D78997" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-twt.png" width="40" height="40" alt="Twitter" /></a></div>
			            				<div class="socplus"><a href="https://plus.google.com/share?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-gps.png" width="40" height="40" alt="Google" /></a></div>		
			            				<div class="socplus"><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;title=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29&#038;source=" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-lin.png" width="40" height="40" alt="LinkedIn" /></a></div>     
            			            	<div class="socplus"><a href="http://digg.com/submit?phase=2&#038;url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;title=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-dig.png" width="40" height="40" alt="Digg" /></a></div>
                           
                <div class="socplus"><a href="http://www.stumbleupon.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-sbm.png" width="40" height="40" alt="Stumbleupon" /></a></div>
                            
                <div class="socplus"><a href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-red.png" width="40" height="40" alt="Reddit" /></a></div>
                              
                <div class="socplus"><a href="http://www.tumblr.com/share/link?url=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;name=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-tbr.png" width="40" height="40" alt="Tumblr" /></a></div>
               
			   
                <div class="socplus"><a href="http://www.blogger.com/blog-this.g?t&#038;u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;n=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-bgr.png" width="40" height="40" alt="Blogger" /></a></div>    
              			              	<div class="socplus"><a href="http://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.filmfetish.com%2Fffmkt%2Fblack-sabbath-the-ozzy-osbourne-years%2F&#038;t=Black%20Sabbath%3A%20The%20Ozzy%20Osbourne%20Years%20%282000%29" onclick="javascript:window.open(this.href,'', 'menubar=no,toolbar=no,resizable=yes,scrollbars=yes,height=570,width=500');return false;"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-fbk.png" width="40" height="40" alt="Facebook" /></a></div>
			            	<div class="socplus"><a href="javascript:window.print()"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-prt.png" width="40" height="40" alt="Print Page" /></a></div>
                <div class="socplus"><a href="mailto:?to=&subject=A%20link%20for%20review%20from%20FilmFetish.com | CrushCollectibles.com&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | CrushCollectibles.com:%20https://www.filmfetish.com/?p=78997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-mal.png" width="40" height="40" alt="Email Page" /></a></div>
                <div class="socplus"><a href="sms:;?&body=Found%20this%20link%20of%20interest%20at%20FilmFetish.com | CrushCollectibles.com:%20https://www.filmfetish.com/?p=78997"><img src="https://www.filmfetish.com/wp-content/themes/m-theater/images/soc-msg.png" width="40" height="40" alt="Send Text Message" /></a></div>
</div>  
	</div> 
<p class="cntr">Page Link<br />
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/ffmkt/black-sabbath-the-ozzy-osbourne-years/' /><br/>
Short Link<br/>
<input type='text' width='80%' onclick='jQuery(this).select();' value='https://www.filmfetish.com/?p=78997' /></p>
<div class="shareline">#</div>
        </div><!-- .share-meta -->

		<footer class="entry-meta">
					</footer>
	</article><!-- #post -->

			
<div id="comments" class="comments-area">

	
	
		<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ffmkt/black-sabbath-the-ozzy-osbourne-years/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.filmfetish.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate>
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" required="required"></textarea></p><p><label for="bhmcorans">What is <strong>4 + 10</strong> ?</label><input name="bhmcorans" id="bhmcorans" placeholder="Total" type="text" /></p>
	<p class="bhmspamkill"><label for="bhm_nonviewable">Comment</label><textarea id="bhm_nonviewable" name="bhm_nonviewable"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='78997' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>			</form>
			</div><!-- #respond -->
	
</div><!-- #comments .comments-area -->
			
		</div><!-- #content -->
 		
<div id="secondary-2" class="widget-area-footer" role="complementary">
		<div class="first foot-widgets">
		<aside id="text-10" class="widget widget_text">			<div class="textwidget"><style type="text/css">
#siteseal,#siteseal img{ box-shadow:none !important; }
</style><span id="siteseal"><script async type="text/javascript" src="https://seal.godaddy.com/getSeal?sealID=rH1l6dk2mtoVz3jYyGon3RFfR7VdpW5gXXKlATaM6kRI0sfrsWYmRCxiSuDt"></script></span></div>
		</aside><aside id="rss-11" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/shop/misc/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Latest Crush Items</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/space-1999-the-complete-series-plus-limited-edition-spaceship-snow-globe/'>Space: 1999 – The Complete Series plus Limited Edition Spaceship Snow Globe</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/piranha-limited-edition-blu-ray-steelbook-2019/'>Piranha Limited Edition Blu-ray Steelbook (2019)</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/humanoids-from-the-deep-limited-edition-blu-ray-steelbook/'>Humanoids From The Deep Limited Edition Blu-ray Steelbook</a></li></ul></aside><aside id="nav_menu-17" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-departments-container"><ul id="menu-departments" class="menu"><li id="menu-item-49437" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49437"><a title="Apparel" href="https://www.filmfetish.com/market/archive/?mcrterm=24386&#038;mcrtrmkey=category">Apparel</a></li>
<li id="menu-item-49438" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49438"><a title="Books" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></li>
<li id="menu-item-49488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49488"><a title="Featured" href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured</a></li>
<li id="menu-item-68606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68606"><a title="Games" href="https://www.filmfetish.com/market/archive/?mcrterm=30441&#038;mcrtrmkey=category">Games</a></li>
<li id="menu-item-62385" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62385"><a title="Home Goods" href="https://www.filmfetish.com/market/archive/?mcrterm=24612&#038;mcrtrmkey=category">Home Goods</a></li>
<li id="menu-item-49439" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49439"><a title="Lobby Cards" href="https://www.filmfetish.com/market/archive/?mcrterm=24383&#038;mcrtrmkey=category">Lobby Cards</a></li>
<li id="menu-item-49440" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49440"><a title="Movies &#038; TV" href="https://www.filmfetish.com/market/archive/?mcrterm=24129&#038;mcrtrmkey=category">Movies &#038; TV</a></li>
<li id="menu-item-49441" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49441"><a title="Mugs &#038; Cups" href="https://www.filmfetish.com/market/archive/?mcrterm=24277&#038;mcrtrmkey=category">Mugs &#038; Cups</a></li>
<li id="menu-item-49442" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49442"><a title="Music" href="https://www.filmfetish.com/market/archive/?mcrterm=24252&#038;mcrtrmkey=category">Music</a></li>
<li id="menu-item-49443" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49443"><a title="Photo Prints" href="https://www.filmfetish.com/market/archive/?mcrterm=24293&#038;mcrtrmkey=category">Photo Prints</a></li>
<li id="menu-item-49444" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49444"><a title="Poster &#038; Canvas Shop" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
<li id="menu-item-49445" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49445"><a title="Toys" href="https://www.filmfetish.com/market/archive/?mcrterm=24128&#038;mcrtrmkey=category">Toys</a></li>
</ul></div></aside><aside id="nav_menu-13" class="widget widget_nav_menu"><h3 class="widget-title">#FilmFetish #CrushCollectibles</h3><div class="menu-soc-media-container"><ul id="menu-soc-media" class="menu"><li id="menu-item-48865" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48865"><a title="FilmFetish on Facebook" target="_blank" rel="noopener noreferrer" href="https://www.facebook.com/filmfetish">facebook.com/filmfetish</a></li>
<li id="menu-item-48866" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48866"><a title="FilmFetish on Twitter" target="_blank" rel="noopener noreferrer" href="http://twitter.com/filmfetish">twitter.com/filmfetish</a></li>
<li id="menu-item-68742" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68742"><a title="Crush Collectibles on Instagram" target="_blank" rel="noopener noreferrer" href="http://instagram.com/crushcollectibles">instagram.com/crushcollectibles</a></li>
<li id="menu-item-48867" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48867"><a title="FilmFetish on Instagram" target="_blank" rel="noopener noreferrer" href="http://instagram.com/filmfetish">instagram.com/filmfetish</a></li>
<li id="menu-item-48868" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48868"><a title="FilmFetish on MyFantasticArt" target="_blank" rel="noopener noreferrer" href="http://myfantasticart.com/id/filmfetish">myfantasticart.com/id/filmfetish</a></li>
<li id="menu-item-48869" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-48869"><a title="Get our RSS Feed" target="_blank" rel="noopener noreferrer" href="http://www.filmfetish.com/feed/">filmfetish.com/feed</a></li>
</ul></div></aside>	</div><!-- .first -->
	
		<div class="second foot-widgets">
		<aside id="custom_html-3" class="widget_text widget widget_custom_html"><h3 class="widget-title">Crush Collectibles!</h3><div class="textwidget custom-html-widget"><p><a href="http://crushcollectibles.com" title="CRUSH COLLECTIBLES"><img src="https://www.filmfetish.com/img/p/2016/06/filmfetish-teaser-announcement.jpg" alt="Pop Culture, Sports and Music Collectibles" /></a></p></div></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"></div></aside><aside id="rss-5" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/type/quote/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">PopCultureQuotes.com</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/2019/02/24/77376/'>PopCultureQuotes.com | Quote by Steven Spielberg</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2019/01/29/77095/'>PopCultureQuotes.com | Quote by Nickell Robey-Coleman</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73493/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73491/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2018/05/24/73489/'>PopCultureQuotes.com | Quote by Robert De Niro</a></li></ul></aside><aside id="rss-10" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/editorials/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Recent News</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/2019/09/09/new-trailer-and-stills-released-for-jersey-shore-set-teen-crime-drama-low-tide/'>New trailer and stills released for Jersey Shore-set teen crime drama Low Tide</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2019/09/04/sony-reveals-trailer-for-bad-boys-for-life/'>Sony reveals trailer for Bad Boys for Life</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2019/06/14/warner-bros-reveals-trailer-for-the-shining-sequel-doctor-sleep/'>Warner Bros. reveals trailer for The Shining sequel Doctor Sleep</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2019/04/28/sigourney-weaver-pays-surprise-visit-to-new-jersey-stage-production-of-her-sci-fi-classic-alien/'>Sigourney Weaver pays surprise visit to New Jersey stage production of her sci-fi classic Alien</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/2019/04/26/check-out-the-final-trailer-for-the-intruder/'>Check out the final trailer for The Intruder</a></li></ul></aside><aside id="nav_menu-2" class="widget widget_nav_menu"><h3 class="widget-title">About Us</h3><div class="menu-about-container"><ul id="menu-about" class="menu"><li id="menu-item-73871" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-73871"><a title="Support Film Fetish" href="https://www.filmfetish.com/support/">Contribute to Us</a></li>
<li id="menu-item-70051" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-70051"><a title="Share Our Banners and Spread the Word About Us!" href="https://www.filmfetish.com/category/editorials/media-photos/banners/">Share Our Banners</a></li>
<li id="menu-item-37141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37141"><a href="https://www.filmfetish.com/about/">About Us</a></li>
<li id="menu-item-49547" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49547"><a href="https://www.filmfetish.com/about/return-policy/">Return Policy</a></li>
<li id="menu-item-49546" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49546"><a href="https://www.filmfetish.com/about/shipping-information/">Shipping Information</a></li>
<li id="menu-item-49656" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49656"><a href="https://www.filmfetish.com/product-size-charts/">Product Size Charts</a></li>
<li id="menu-item-37143" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37143"><a href="https://www.filmfetish.com/about/copyright/">Copyright</a></li>
<li id="menu-item-37145" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37145"><a href="https://www.filmfetish.com/about/privacy-policy/">Privacy Policy | Terms of Use | Disclaimer</a></li>
<li id="menu-item-49545" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49545"><a href="https://www.filmfetish.com/about/contact/">Contact</a></li>
</ul></div></aside>	</div><!-- .second -->
	</div><!-- #secondary -->       
	</div><!-- #primary -->

	<div id="secondary" class="widget-area" role="complementary">
		<aside id="nav_menu-18" class="widget widget_nav_menu"><h3 class="widget-title">Crush Collectibles</h3><div class="menu-store-quick-links-container"><ul id="menu-store-quick-links" class="menu"><li id="menu-item-65771" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65771"><a href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured Items</a></li>
<li id="menu-item-68607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68607"><a title="Poster Crush" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
<li id="menu-item-65769" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65769"><a href="https://www.filmfetish.com/market/archive/?mcrky=_mycprcgrp&#038;mcrvl=preorder&#038;mcrcpr=LIKE">Preorders</a></li>
<li id="menu-item-65770" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65770"><a href="https://www.filmfetish.com/market/archive/">Specials</a></li>
<li id="menu-item-65768" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65768"><a href="https://www.filmfetish.com/market/">All Items</a></li>
</ul></div></aside><aside id="mtheater_content_widget-6" class="widget mthecontentwidg"><h3 class="widget-title">Shoppers Also Purchased</h3><h2 class="myc-center low">Related Items</h2><div class="myc-related"><div><a href="https://www.filmfetish.com/ffmkt/behind-the-camera-the-cinematographers-art-by-leonard-maltin-w4857/" title="Behind the Camera: The Cinematographer&#8217;s Art by Leonard Maltin (W4857)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/07/behind-the-cam-193177-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Behind the Camera: The Cinematographer&#8217;s Art by Leonard Maltin (W4857)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/n-w-a-straight-outta-compton/" title="N.W.A. Straight Outta Compton" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/05/nwa-straight-outta-compton-cd-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="N.W.A. Straight Outta Compton"></a></div><div><a href="https://www.filmfetish.com/ffmkt/rock-archives-a-photographic-journey-through-the-first-two-decades-of-rock-roll-1984/" title="Rock Archives: A Photographic Journey Through the First Two Decades of Rock &#038; Roll (1984)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/07/rock-archives-1931104-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Rock Archives: A Photographic Journey Through the First Two Decades of Rock &#038; Roll (1984)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-revenant-original-motion-picture-soundtrack-limited-edition-2-lp-set-with-download-card/" title="The Revenant Original Motion Picture Soundtrack by Ryuichi Sakamoto Limited Edition 2-LP Set with Download Card, Alejandro Gonzalez Inarritu" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/08/The-Revenant-fr-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Revenant Original Motion Picture Soundtrack by Ryuichi Sakamoto Limited Edition 2-LP Set with Download Card, Alejandro Gonzalez Inarritu"></a></div><div><a href="https://www.filmfetish.com/ffmkt/jimi-hendrix-in-copenhagen-denmark-september-3rd-1970-music-poster/" title="Jimi Hendrix in Copenhagen, Denmark September 3rd, 1970 Music Poster 24 x 36 Inch" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/12/jimi-hendrix-copenhagen-poster-170x170.jpg" width="170" height="170" class="related-thumb" alt="Jimi Hendrix in Copenhagen, Denmark September 3rd, 1970 Music Poster 24 x 36 Inch"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-beatles-all-you-need-is-love-24-x-36-inch-poster/" title="The Beatles &#8211; All You Need is Love 24 X 36 inch Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2017/12/beatles-love-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Beatles &#8211; All You Need is Love 24 X 36 inch Poster"></a></div><div><a href="https://www.filmfetish.com/ffmkt/the-best-of-the-beatles-clarinet-paperback-1994/" title="The Best of the Beatles: Clarinet Paperback (2006)" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/08/best-of-beatles-86027-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="The Best of the Beatles: Clarinet Paperback (2006)"></a></div><div><a href="https://www.filmfetish.com/ffmkt/lawrence-of-arabia-first-signet-paperback-movie-tie-in-edition-december-1962-193132/" title="Lawrence of Arabia First Signet Paperback Movie Tie-In Edition (December 1962) [193132]" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2019/06/lawrence-of-arabia-193132-01-170x170.jpg" width="170" height="170" class="related-thumb" alt="Lawrence of Arabia First Signet Paperback Movie Tie-In Edition (December 1962) [193132]"></a></div><div><a href="https://www.filmfetish.com/ffmkt/sign-o-the-times-2-disc-vinyl-edition/" title="Sign &#8220;O&#8221; the Times 2-Disc Vinyl Edition" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/04/prince-sign-o-the-times-vinyl-a-170x170.jpg" width="170" height="170" class="related-thumb" alt="Sign &#8220;O&#8221; the Times 2-Disc Vinyl Edition"></a></div><div><a href="https://www.filmfetish.com/ffmkt/bon-jovi-cross-road-cd-with-foldout-poster/" title="Bon Jovi Cross Road CD with Foldout Poster" rel="bookmark"><img src="https://www.filmfetish.com/img/p/2018/05/bon-jovi-crossroad-music-cd-001-170x170.jpg" width="170" height="170" class="related-thumb" alt="Bon Jovi Cross Road CD with Foldout Poster"></a></div></div></aside><aside id="rss-13" class="widget widget_rss"><h3 class="widget-title"><a class="rsswidget" href="https://www.filmfetish.com/category/shop/misc/featured/feed/"><img class="rss-widget-icon" style="border:0" width="14" height="14" src="https://www.filmfetish.com/wp-includes/images/rss.png" alt="RSS" /></a> <a class="rsswidget" href="https://www.filmfetish.com/">Latest Featured Items</a></h3><ul><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/space-1999-the-complete-series-plus-limited-edition-spaceship-snow-globe/'>Space: 1999 – The Complete Series plus Limited Edition Spaceship Snow Globe</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/piranha-limited-edition-blu-ray-steelbook-2019/'>Piranha Limited Edition Blu-ray Steelbook (2019)</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/humanoids-from-the-deep-limited-edition-blu-ray-steelbook/'>Humanoids From The Deep Limited Edition Blu-ray Steelbook</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-texas-chainsaw-massacre-the-film-that-terrified-a-rattled-nation-2019/'>The Texas Chainsaw Massacre: The Film That Terrified a Rattled Nation (2019)</a></li><li><a class='rsswidget' href='https://www.filmfetish.com/ffmkt/the-sopranos-sessions-hardcover-edition-2019/'>The Sopranos Sessions Hardcover Edition (2019)</a></li></ul></aside><aside id="nav_menu-14" class="widget widget_nav_menu"><h3 class="widget-title">Departments</h3><div class="menu-departments-container"><ul id="menu-departments-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49437"><a title="Apparel" href="https://www.filmfetish.com/market/archive/?mcrterm=24386&#038;mcrtrmkey=category">Apparel</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49438"><a title="Books" href="https://www.filmfetish.com/market/archive/?mcrterm=24273&#038;mcrtrmkey=category">Books</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49488"><a title="Featured" href="https://www.filmfetish.com/market/archive/?mcrterm=24161&#038;mcrtrmkey=category">Featured</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68606"><a title="Games" href="https://www.filmfetish.com/market/archive/?mcrterm=30441&#038;mcrtrmkey=category">Games</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62385"><a title="Home Goods" href="https://www.filmfetish.com/market/archive/?mcrterm=24612&#038;mcrtrmkey=category">Home Goods</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49439"><a title="Lobby Cards" href="https://www.filmfetish.com/market/archive/?mcrterm=24383&#038;mcrtrmkey=category">Lobby Cards</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49440"><a title="Movies &#038; TV" href="https://www.filmfetish.com/market/archive/?mcrterm=24129&#038;mcrtrmkey=category">Movies &#038; TV</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49441"><a title="Mugs &#038; Cups" href="https://www.filmfetish.com/market/archive/?mcrterm=24277&#038;mcrtrmkey=category">Mugs &#038; Cups</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49442"><a title="Music" href="https://www.filmfetish.com/market/archive/?mcrterm=24252&#038;mcrtrmkey=category">Music</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49443"><a title="Photo Prints" href="https://www.filmfetish.com/market/archive/?mcrterm=24293&#038;mcrtrmkey=category">Photo Prints</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49444"><a title="Poster &#038; Canvas Shop" href="https://www.filmfetish.com/market/archive/?mcrterm=29680&#038;mcrtrmkey=category">Poster Crush</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49445"><a title="Toys" href="https://www.filmfetish.com/market/archive/?mcrterm=24128&#038;mcrtrmkey=category">Toys</a></li>
</ul></div></aside><aside id="nav_menu-15" class="widget widget_nav_menu"><h3 class="widget-title">Popular Genres</h3><div class="menu-popular-genres-container"><ul id="menu-popular-genres" class="menu"><li id="menu-item-49449" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49449"><a title="Action" href="https://www.filmfetish.com/market/archive/?mcrterm=24211&#038;mcrtrmkey=category">Action</a></li>
<li id="menu-item-49450" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49450"><a title="Adventure" href="https://www.filmfetish.com/market/archive/?mcrterm=24212&#038;mcrtrmkey=category">Adventure</a></li>
<li id="menu-item-49451" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49451"><a title="Comedy" href="https://www.filmfetish.com/market/archive/?mcrterm=24216&#038;mcrtrmkey=category">Comedy</a></li>
<li id="menu-item-49452" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49452"><a title="Crime" href="https://www.filmfetish.com/market/archive/?mcrterm=24217&#038;mcrtrmkey=category">Crime</a></li>
<li id="menu-item-49453" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49453"><a title="Documentary" href="https://www.filmfetish.com/market/archive/?mcrterm=24218&#038;mcrtrmkey=category">Documentary</a></li>
<li id="menu-item-49454" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49454"><a title="Exploitation" href="https://www.filmfetish.com/market/archive/?mcrterm=24220&#038;mcrtrmkey=category">Exploitation</a></li>
<li id="menu-item-49455" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49455"><a title="Fantasy" href="https://www.filmfetish.com/market/archive/?mcrterm=958&#038;mcrtrmkey=category">Fantasy</a></li>
<li id="menu-item-49456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49456"><a title="Horror" href="https://www.filmfetish.com/market/archive/?mcrterm=24226&#038;mcrtrmkey=category">Horror</a></li>
<li id="menu-item-49457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49457"><a title="Martial Arts" href="https://www.filmfetish.com/market/archive/?mcrterm=24227&#038;mcrtrmkey=category">Martial Arts</a></li>
<li id="menu-item-49458" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49458"><a title="Mystery" href="https://www.filmfetish.com/market/archive/?mcrterm=24231&#038;mcrtrmkey=category">Mystery</a></li>
<li id="menu-item-49459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49459"><a title="Science Fiction" href="https://www.filmfetish.com/market/archive/?mcrterm=24235&#038;mcrtrmkey=category">Science Fiction</a></li>
<li id="menu-item-49460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-49460"><a title="Thriller" href="https://www.filmfetish.com/market/archive/?mcrterm=24240&#038;mcrtrmkey=category">Thriller</a></li>
</ul></div></aside>	</div><!-- #secondary -->
	</div><!-- #main .wrapper -->
	<footer id="colophon" role="contentinfo">
		<div class="site-info">
					&copy; 2019 FilmFetish.com | CrushCollectibles.com | <a href="http://hitpi.cc/mtheaterfooterurl/" title="M Theater Wordpress Theme created by Rene Carson from HIT PICTURES" target="_blank"> Website Design: HIT PICTURES</a> <span class="logshow off"><a href="https://www.filmfetish.com/wp-login.php">Log in</a></span></div><!-- .site-info -->
	</footer><!-- #colophon -->

<div id="gotop"><a href="#top"><span></span></a></div>
</div><!-- #page -->

<!-- Custom Feeds for Instagram JS -->
<script type="text/javascript">
var sbiajaxurl = "https://www.filmfetish.com/wp-admin/admin-ajax.php";
</script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.widowbuster.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/comment-reply.min.js?ver=5.2.3'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.fitvids-ld.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.colorbox.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/jquery.topspring.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/nav.js'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/themes/m-theater/js/mediaelement-ld.js'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.easing.js?ver=1.3'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.touchSwipe.min.js?ver=1.3'></script>
<script type='text/javascript' src='//i.hit.pictures/scripts/jquery.liquid-slider.min.js?ver=2.3.8'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-content/plugins/concoupons/inc/dzscalendar/dzscalendar.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.filmfetish.com/wp-includes/js/wp-embed.min.js?ver=5.2.3'></script>
   
<script>		
jQuery(window).load(function($) {	
	jQuery('a[href$=".jpg"],a[href$=".jpeg"],a[href$=".png"],a[href$=".gif"]').colorbox({rel:'gal',maxHeight:'100%',speed:700,fadeOut:600,initialWidth:false,maxWidth:'100%',initialHeight:false,slideshow:true,slideshowAuto:false,slideshowSpeed:6000,slideshowStart:'slideshow',slideshowStop:'stop',transition:'fade'});
	jQuery('.mycc-ajax').colorbox();
	jQuery('.mycc-inline').colorbox({inline:true,speed:700,fadeOut:600,width:'100%',height:'100%',transition:'fade'});
});
</script>
	<script>
jQuery(window).load(function($){
var d = new Date();
var n = d.getMonth() + 1;
var yr = d.getFullYear();
var design_month_covers = ['https://www.filmfetish.com/img/p/2016/07/calimg160718-body-double-melanie-griffith-craig-wasson.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-elton-john-diana-ross-cher-awards-show-1980s.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-bridget-fonda-robert-deniro-samuel-l-jackson-in-jackie-brown.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-janet-leigh.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-vincent-donofrio-martin-sensmeier-manuel-garciarulfo-ethan-hawke-denzel-washington-chris-pratt-byunghunlee-magnificent-seven.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-five-easy-pieces-loews-holly-theater-hollywood-blvd.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-linda-lovelace-deep-throat-porn-icon.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-le-mans-playing-loews-state-times-square-new-york-city-1971.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-rebecca-ferguson-mission-impossible-rogue-nation-2015.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-lauren-cohan-the-boy-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-yoo-gong-in-train-to-busan-2016.jpg','https://www.filmfetish.com/img/p/2016/07/calimg160718-dane-dehaan-valerian-city-thousand-planets-2017.jpg'];
dzscal_init("#tr1",{
design_month_covers : design_month_covers,
start_month: n,
	start_year: yr
});
});
</script>
<div class="bhad-wrapper plugin_load_early"><div class='bhadads plugin_load_early'><div class='liquid-slider ad' id='adsysslide'>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/website-services/" title="Website Services">Website Services</a></h2>
<p><a href="http://hitpi.cc/domains/" target="_blank" rel="noopener noreferrer"><span class="icn">X</span> HitPictures.tech <span class="arw">⇒</span> Domain Names, Websites</a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/headshotcard-com-comp-card-services/" title="HeadshotCard.com Comp Card Services">HeadshotCard.com Comp Card Services</a></h2>
<p><a href="http://headshotcard.com/" target="_blank" rel="noopener noreferrer"><span class="icn">r</span> HEADSHOTCARD.COM <span class="arw">⇒</span> Comp Cards, Headshots</a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/flyer-hype-promotional-event-flyers/" title="Flyer Hype Promotional Event Flyers">Flyer Hype Promotional Event Flyers</a></h2>
<p><a href="http://hitpi.cc/domains/" target="_blank" rel="noopener noreferrer"><span class="icn">Y</span> Promo Flyers for Deejay/Filmmaker Events <span class="arw">⇒</span></a></p>
</div>
<div>
<h2 class='bhadadtitle'><a href="https://hit.pics/2019/02/28/movie-tv-music-and-sports-collectibles/" title="Movie, TV, Music and Sports Collectibles">Movie, TV, Music and Sports Collectibles</a></h2>
<p><a href="http://crushcollectibles.com/" target="_blank" rel="noopener noreferrer"><span class="icn">a</span> Crush Collectibles <span class="arw">⇒</span></a></p>
</div>
</div></div></div><script>
			$('#adsysslide').liquidSlider({
				panelTitleSelector:".bhadadtitle",
				autoSlide:true,
				dynamicArrows:false,
				hoverArrows:false,
				dynamicArrowsGraphical:false,
				autoSlideInterval:10000,
				dynamicTabs:false,
				pauseOnHover:true,
				autoHeight:false,
				mobileNavigation:false,
				includeTitle:false
		});
	</script><!-- Start of StatCounter Code for Default Guide -->
<script type="text/javascript">
var sc_project=6854008; 
var sc_invisible=1; 
var sc_security="5609cdda"; 
var scJsHost = (("https:" == document.location.protocol) ?
"https://secure." : "http://www.");
document.write("<sc"+"ript type='text/javascript' src='" +
scJsHost+
"statcounter.com/counter/counter.js'></"+"script>");
</script>
<noscript><div class="statcounter"><a title="shopify
analytics ecommerce" href="http://statcounter.com/shopify/"
target="_blank"><img class="statcounter"
src="//c.statcounter.com/6854008/0/5609cdda/1/" alt="shopify
analytics ecommerce"></a></div></noscript>
<!-- End of StatCounter Code for Default Guide -->
</body>
</html>